Reply
Highlighted
Follower

Support too restrictive

Extremely disappointed, having paid $500+ for an Orbi RBK50, trying hard to iron out problems and finally deciding to contact Netgear for support, to find out my free support expired 4 days ago.  Surely it must be obvious to Netgear that I have never tried to use the support and it should be available for 90 days from the time it is first accessed, not from the date of purchase.  Not all of us have the luxury of being free to attend to issues like configuring a new modem as soon as we buy it.  

Message 1 of 3
Highlighted
Guru

Re: Support too restrictive

I'm not sure where to go with this. 

Its 3 months of free support from the date of purchase. its on the box/manual. its disclosed up front. 

You upset because you paid $500 for something but didn't try to install it within 3 months.

 

Either way, you options are to seek help on here in the community forum which is free or to pay for a support contract. l

If you want help post more details.

1. what issue are you having
2. firmware on the router/satellite

3. modem its connected to

4. any any other pertinent details. Since we aren't there to see whats going on, we need details to help

CM2000-> Arris W31-> GS716v2-> TP-Link M9Plus
Message 2 of 3
Highlighted
Master

Re: Support too restrictive


@James1234 wrote:

Extremely disappointed, having paid $500+ for an Orbi RBK50, trying hard to iron out problems and finally deciding to contact Netgear for support, to find out my free support expired 4 days ago.  Surely it must be obvious to Netgear that I have never tried to use the support and it should be available for 90 days from the time it is first accessed, not from the date of purchase.  Not all of us have the luxury of being free to attend to issues like configuring a new modem as soon as we buy it.  


This is the whole reason this forum exists. You will get support here from actual users of the product. 

So rather than waste time complaining and being unhappy, gtive it a shot and post your problem.

You will probably find an answer fast. With that said most issues are user error or improper configuration of the system.

Orbi RBK53 System/RBR50/RBS50/RBS50. + Orbi Voice RBS40V
RBK753 system/RBR750/RBS750/RBS750 + RBK853 System/RBR850/RBS850/RBS850
There's always a logical answer, if you have all the facts!
Message 3 of 3
Top Contributors
Discussion stats
  • 2 replies
  • 78 views
  • 1 kudo
  • 3 in conversation
Announcements