Reply

Re: Surface Pro won't connect to strongest Orbi access point

snic
Tutor

Surface Pro won't connect to strongest Orbi access point

I recently installed an Orbi RBK23 in my house (4000 square feet). I have three access points connected with wired backhaul. It works very well for most devices. The exception is my Surface Pro 4. At first, it simply refused to connect at 5 GHz, even if I set the wifi adapter to use only the 5 GHz band. I fixed this by going into the Orbi settings and reducing the strength of the 2.4 Ghz signal to 25%. (I wish there were a way to turn if off completely.)

 

The remaining problem is that when I move from room to room, the Surface takes a long time to connect to a stronger signal. Disconnecting and reconnecting doesn't work; the Surface insists on waiting a few minutes before deciding to connect to the stronger signal. After disconnecting, the list of wifi networks shows a full 4 bars for the Orbi network - but when I re-connect to it, it goes down to just 1 bar (so it's connecting to the farther access point even though it knows there's a much stronger signal closeby).

 

Is there a solution to this?

Message 1 of 8

Accepted Solutions
snic
Tutor

Re: Surface Pro won't connect to strongest Orbi access point

It turns out that using Wifi Analyzer to switch networks doesn't work consistently. It works sometimes, but more often than not the network stays exactly the same.

 

What actually DOES work very well is to use a USB wifi adapter instead of the Surface's native adapter. I've been using this one for a couple of months now and it works nearly flawlessly - I get a good connection anywhere in the house without having to do anything, which is the way it should be.

 

I suspect that Microsoft has improved the wifi adapters in recent Surface models, but both Surface Pro 3 and Surface Pro 4 are stuck with this problem when using Orbi routers.

View solution in original post

Message 7 of 8

All Replies
FURRYe38
Guru

Re: Surface Pro won't connect to strongest Orbi access point

Its up to devcies to pick and choose where they connect too. Can try to enable Fast Roaming to see if this does anything. 

If not, you'll have to temporarily turn OFF the devices wifi radio for 5 seconds then back on when nearer the other stronger signal. 

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CAX80 Router Mode |  Wifi Router CAX800 (Router Mode) and RBK963 (APMode) | and MK63 (Router Mode) | Switches NG GS105/8, GS308v3, GS110MX and XS505M |

Additional NG HW: C7800/CAX80/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: MK63, MR6150, R7000, R7800, R7960P, R8000, R8500, RAXE500, RAX50, XR450, XR1000, EX7500/EX7700

Message 2 of 8
snic
Tutor

Re: Surface Pro won't connect to strongest Orbi access point

Fast roaming is already turned on. Whether it's on or off makes no difference, as far as I can tell.

 

Turning off wifi in the Surface and turning it back on has no effect. The Surface refuses to connect to the stronger signal unless I wait a few minutes (not seconds).

 

I know this is an issue with the Surface and likely not the Orbi (as no other devices have this problem). The question is whether there is a way to get the Surface to connect to the stronger signal.

Message 3 of 8
FURRYe38
Guru

Re: Surface Pro won't connect to strongest Orbi access point

Something to contact the mfr of the Surface about. 

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CAX80 Router Mode |  Wifi Router CAX800 (Router Mode) and RBK963 (APMode) | and MK63 (Router Mode) | Switches NG GS105/8, GS308v3, GS110MX and XS505M |

Additional NG HW: C7800/CAX80/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: MK63, MR6150, R7000, R7800, R7960P, R8000, R8500, RAXE500, RAX50, XR450, XR1000, EX7500/EX7700

Message 4 of 8
snic
Tutor

Re: Surface Pro won't connect to strongest Orbi access point

Or, you know, I could ask other Orbi users - some number of whom probably also have Surface devices - how they've solved this problem. Which is what I thought I was doing by posting my question in this forum.

 

So, I did some research, and here are the results, to help others who might have the same question:

 

It turns out that the Marvell wifi adapter in Surface devices doesn't have a roaming aggressiveness setting, which means there's no way to make the wifi less "sticky" short of buying a USB wifi adapter that supports that feature. However, I did find a workaround that seems to work pretty well. I installed an app called Wifi Analyzer. It allows you to see the strength of all available networks, even the ones with the same SSID. The upgraded version (which costs $2.99) allows you to select a specific network and connect to it. So far, it has been worth every penny.

Message 5 of 8
FURRYe38
Guru

Re: Surface Pro won't connect to strongest Orbi access point

Or searching the Surface forums that probably have more Surface users may result in more information. 

 

Glad you seem to have solved your problem. Mark your thread and solved so others will know about it. 


Enjoy. Smiley Wink

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CAX80 Router Mode |  Wifi Router CAX800 (Router Mode) and RBK963 (APMode) | and MK63 (Router Mode) | Switches NG GS105/8, GS308v3, GS110MX and XS505M |

Additional NG HW: C7800/CAX80/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: MK63, MR6150, R7000, R7800, R7960P, R8000, R8500, RAXE500, RAX50, XR450, XR1000, EX7500/EX7700

Message 6 of 8
snic
Tutor

Re: Surface Pro won't connect to strongest Orbi access point

It turns out that using Wifi Analyzer to switch networks doesn't work consistently. It works sometimes, but more often than not the network stays exactly the same.

 

What actually DOES work very well is to use a USB wifi adapter instead of the Surface's native adapter. I've been using this one for a couple of months now and it works nearly flawlessly - I get a good connection anywhere in the house without having to do anything, which is the way it should be.

 

I suspect that Microsoft has improved the wifi adapters in recent Surface models, but both Surface Pro 3 and Surface Pro 4 are stuck with this problem when using Orbi routers.

Message 7 of 8
FURRYe38
Guru

Re: Surface Pro won't connect to strongest Orbi access point

Thanks for the update and letting us know. Yes, wifi adapter drivers are important along with improvements from the Mfr. Seen similar problem with old xbox 360 slim wifi and routers of the time frame. MS never did anything with the drivers on the xbox to improve it. Of course follow on models had better wifi adapters and drivers. So yes, one can always add a external adatper for better wifi use and operation. 

 

Glad it's working now for you. 

Enjoy. Smiley Wink

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CAX80 Router Mode |  Wifi Router CAX800 (Router Mode) and RBK963 (APMode) | and MK63 (Router Mode) | Switches NG GS105/8, GS308v3, GS110MX and XS505M |

Additional NG HW: C7800/CAX80/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: MK63, MR6150, R7000, R7800, R7960P, R8000, R8500, RAXE500, RAX50, XR450, XR1000, EX7500/EX7700

Message 8 of 8
Top Contributors
Discussion stats
  • 7 replies
  • 1693 views
  • 1 kudo
  • 2 in conversation
Announcements

Orbi WiFi 6E