Reply
Highlighted
Guide

v2.5.0.38 is horrible and making my RBS satellite go out intermittently

Just want to post as well since I don't think management is getting the hint - since upgrading to v2.5.0.38, my RBS satellite just will not stay connected.  I tried unplugging, rebooting, and resetting the whole thing and after all that wasted time, it's still not working.  I am 100% sure it's the firmware since it started immediately after the upgrade.  Can I roll back?  Are you going to issue a fix?  It is clearly a bad update and needs to be addressed before you work on any other issues.

Model: RBR50|Orbi AC3000 Tri-band WiFi Router
Message 1 of 12
Highlighted
Guru

Re: v2.5.0.38 is horrible and making my RBS satellite go out intermittently

Did you ensure both RBR and RBS were updated? They have to be on same version of FW.

What is the Mfr and model# of the ISP modem the NG router is connected too?

 

What is the size of your home? Sq Ft?
What is the distance between the router and satellite(s)? 30 feet is recommended in between RBR and RBS to begin with depending upon building materials when wirelessly connected. https://kb.netgear.com/000036466/How-far-should-I-place-my-Orbi-satellite-from-my-Orbi-router

 

Any Wifi Neighbors near by? If so, how many?


Try enabling Beamforming and MIMO(MIMO may or maynot be needed) and WMM. Under Advanced Tab/Advanced Settings/Wireless Settings

Try disabling the following and see:
Armor, Circle, Daisy Chain, Fast Roaming, IPv6 and Set 20/40Mhz Coexistence to 40Mhz only. Save settings and reboot the router and satellite(s).

 

Be sure when doing a factory reset, pressing the reset button for 15 seconds is recommended. Any less may not be taking effect. Be sure you reset both RBR and RBS. 

https://community.netgear.com/t5/Orbi/ORBI-RBK50-RBS50-Tips-Tricks-Hidden-Secrets-etc/m-p/1820477/hi...

 

You can downgrade to last working version. Just download the FW files from NG download site and apply the RBS first then RBR. 

 

 


My Setup (Cable 900Mbps/50Mbps)>CAX80>XR450 v2.3.2.106(Router Mode)>RBK853 v3.2.11.2(AP Mode)
Additional NG HW: C7800/CM1100/CM1200/CM2000, Orbi CBK40, RBK853, R7800, R7960P,
EX7500/EX7700, XR450 and WNHDE111
Message 2 of 12
Highlighted
Sensei

Re: v2.5.0.38 is horrible and making my RBS satellite go out intermittently


@Vaslo wrote:

Just want to post as well since I don't think management is getting the hint - since upgrading to v2.5.0.38, my RBS satellite just will not stay connected.  I tried unplugging, rebooting, and resetting the whole thing and after all that wasted time, it's still not working.  I am 100% sure it's the firmware since it started immediately after the upgrade.  Can I roll back?  Are you going to issue a fix?  It is clearly a bad update and needs to be addressed before you work on any other issues.


Alas, my impession is (a) no actual Netgear Engineers participate in the community forum, and (b) I am pretty certain that people have been roasted over the problems with 2.5.0.38.  Where that fits in management's priorities is anybody's guess.

 

As @FURRYe38 mentioned, what most people are doing is installing the previous firmware, 2.3.5.30.  Download the zip files from the Netgear support web site. Unzip them.  Log onto the Orbi web interface (for the satellite first, then the router), and do a "Manual Update."

https://kb.netgear.com/000061080/RBR50-RBS50-Firmware-Version-2-3-5-30 

I love my Orbi.
Message 3 of 12
Highlighted
Retired_Member
Not applicable

Re: v2.5.0.38 is horrible and making my RBS satellite go out intermittently


@Vaslo wrote:

 Can I roll back? 

 

Yes, go to downloads and enter your Orbi model.

 

Once your system is up and running, leave it alone.  No more manual firmware updates.


 

Message 4 of 12
Highlighted
Guide

Re: v2.5.0.38 is horrible and making my RBS satellite go out intermittently

Thanks for the checklist but I'm 110% sure it's the firmware - so I don't think I need to check those other things.  Satellite and Router were on same version - v2.5.0.38, dont have many neighbors, signal was very strong literally until the following minute of updating the firmware, which is when we started having issues and spend several hours trying to reboot, reset, fix, etc.

 

I just got it manually downgraded on the Satellite with v2.5.0.30, and I already see improvement.  However, when I try to manually upgrade the router following the satellite, I keep seeing:

500 Internal Server Error

 

It seems to be working better but now the router and satellite are different firmware versions, and I read that's a no-no.  

Message 5 of 12
Highlighted
Retired_Member
Not applicable

Re: v2.5.0.38 is horrible and making my RBS satellite go out intermittently

Yes all should be on the same firmware.

Message 6 of 12
Highlighted
Guru

Re: v2.5.0.38 is horrible and making my RBS satellite go out intermittently

Try a factory reset on the RBR and RBS then walk thru the setup wizard. 

Try a different browser. Clear all browser caches. 

 

I never saw this with v38. 

https://community.netgear.com/t5/Orbi/ORBI-RBK50-RBS50-Tips-Tricks-Hidden-Secrets-etc/m-p/1820500/hi...


@Vaslo wrote:

Thanks for the checklist but I'm 110% sure it's the firmware - so I don't think I need to check those other things.  Satellite and Router were on same version - v2.5.0.38, dont have many neighbors, signal was very strong literally until the following minute of updating the firmware, which is when we started having issues and spend several hours trying to reboot, reset, fix, etc.

 

I just got it manually downgraded on the Satellite with v2.5.0.30, and I already see improvement.  However, when I try to manually upgrade the router following the satellite, I keep seeing:

500 Internal Server Error

 

It seems to be working better but now the router and satellite are different firmware versions, and I read that's a no-no.  


 


My Setup (Cable 900Mbps/50Mbps)>CAX80>XR450 v2.3.2.106(Router Mode)>RBK853 v3.2.11.2(AP Mode)
Additional NG HW: C7800/CM1100/CM1200/CM2000, Orbi CBK40, RBK853, R7800, R7960P,
EX7500/EX7700, XR450 and WNHDE111
Message 7 of 12
Highlighted
Retired_Member
Not applicable

Re: v2.5.0.38 is horrible and making my RBS satellite go out intermittently


@FURRYe38 wrote:

Try a factory reset on the RBR and RBS. 

 

Factory resets are for lost passwords


Message 8 of 12
Highlighted
Guide

Re: v2.5.0.38 is horrible and making my RBS satellite go out intermittently

Thanks again for the tips but no way I'm doing another factory reset.  Tried 3 different browsers (Chrome, Firefox, Edge) doesn't work.  Tried it with clearing all their caches, still an internal server error.  Going to do a restart of the PC and router and if no luck ill just leave it this way.

 

If there is a product manager on this board, please take this feedback to engineering that this update is trash and the engineer in charge of it should be embarassed for themself.

 

To anyone with this Internal Server Error issue, please note that I am using two different versions of the firmware (2.5.0.38.timewaste for the router and 2.5.0.30 for the satellite) and it appears to be working fine again.  Might not for you but totally fine for me.

 

Thanks to all who gave advice even if I didn't use it - its very appreciated.

Message 9 of 12
Highlighted
Retired_Member
Not applicable

Re: v2.5.0.38 is horrible and making my RBS satellite go out intermittently

Now stop updating your firmware.

Message 10 of 12
Highlighted
Guide

Re: v2.5.0.38 is horrible and making my RBS satellite go out intermittently

Yes, I am dumb for doing lol

Message 11 of 12
Highlighted
Retired_Member
Not applicable

Re: v2.5.0.38 is horrible and making my RBS satellite go out intermittently


@Vaslo wrote:

Yes, I am dumb for doing lol


Not dumb, perhaps curious..??

Message 12 of 12
Top Contributors
Discussion stats
  • 11 replies
  • 834 views
  • 3 kudos
  • 4 in conversation
Announcements