× NETGEAR is aware of a growing number of phone and online scams. To learn how to stay safe click here.
Orbi WiFi 7 RBE973

GS105Ev2 not getting IP Address from DHCP

jrmckins
Aspirant

GS105Ev2 not getting IP Address from DHCP

I have a GS105Ev2 that I plugged into my network today. All I have plugged into that is the cable to another switch and my laptop. My laptop gets an IP address from DHCP (192.168.87.43) just fine but the switch has the factory default (192.168.0.239). When I try to browse to http://192.168.0.239 it fails (as I expect it would). The NETGEAR Switch Discovery Tool does see it but I can't get to it. I've rebooted and factory reset many times and it won't pick up a different address. 

 

I tried re-IPing my laptop to 192.168.0.210 as suggested in the manual and disconnected the switch from my network. The NETGEAR Switch Discovery Tool does see it but I can't get to it.

 

I guess I have two problems: 

1. The switch isn't getting its configuration from DHCP

2. I can't browse to the switch even when I set my laptop's IP address to be on the same network as the switch

 

The switch seems to work fine otherwise.

 

Any ideas?

Model: GS105Ev2|ProSafe Plus 5 ports switch
Message 1 of 10

Accepted Solutions
jrmckins
Aspirant

Re: GS105Ev2 not getting IP Address from DHCP

Here's what I had to do once I figured out the issue was some jacked up firmware:

1. Install ProSAFE Plus Configuration Utility on a windows system

2. manually configure the laptop to use 192.168.0.210; netmask of 255.255.255.0

3. Download the latest firmware from: https://www.netgear.com/support/product/GS105Ev2.aspx#download 

4. Apply the firmware using  ProSAFE Plus Configuration Utility

5. Factory reset the switch

 

I was then able to browse to the switch and use the default password (password) to get in.

 

Thanks to everyone that helped.

View solution in original post

Message 10 of 10

All Replies
schumaku
Guru

Re: GS105Ev2 not getting IP Address from DHCP


@jrmckins wrote:

My laptop gets an IP address from DHCP (192.168.87.43) just fine but the switch has the factory default (192.168.0.239). When I try to browse to http://192.168.0.239 it fails (as I expect it would).


You can't reach the 192.168.0.239/24 IP address because your LAN subnet is configured to 192.168.87.0/24 - two different IPv4 subnetworks.

 


@jrmckins wrote:

The NETGEAR Switch Discovery Tool does see it but I can't get to it. I've rebooted and factory reset many times and it won't pick up a different address. 


The discovery does work on a different protocol - it can discover switches (while connected to the same LAN or broadcast domain). As explained above, the Netgear Switch Discovery Tool does use IPv4 to connect, resp. call a web browser with the discovered IP.

 


@jrmckins wrote:

I tried re-IPing my laptop to 192.168.0.210 as suggested in the manual and disconnected the switch from my network. The NETGEAR Switch Discovery Tool does see it but I can't get to it.


Double check the subnet is set to 192.168.0.0/24 (255.255.255.0) - if there is a smaller mask, the IP connection might fail again because of potentially multiple IP subnets again.

To exclude the impossible, try another port; try another network cable, ....

 

 

 

 

Message 2 of 10
jrmckins
Aspirant

Re: GS105Ev2 not getting IP Address from DHCP

"You can't reach the 192.168.0.239/24 IP address because your LAN subnet is configured to 192.168.87.0/24 - two different IPv4 subnetworks."

Yes, I even stated I didn't expect that to work. 

That's also the problem, why is it 192.168.0.239 and not getting an address from DHCP???

 

"Double check the subnet is set to 192.168.0.0/24 (255.255.255.0)"

I did.

 

I also tried multiple cables/ports. It's not working with DHCP.

Message 3 of 10
schumaku
Guru

Re: GS105Ev2 not getting IP Address from DHCP

One more idea (silly me checked the GS108Ev2 before): Does the discovery tool show a switch firmware version version number before 1.3.0.1? Reson asking is because of very early firmware (1.2.x.x) does not come with a Web GUI, and it was mainly an early factory firmware. In this case (I hope you have a Windows system at hand!), you need to go the hard way and use the ProSAFE Plus Configuration Utility _before_ the curent 2.7.2, e.g. https://kb.netgear.com/000051197/ProSAFE-Plus-Configuration-Utility-v2-5-3 for backward compatibility.

Message 4 of 10
jrmckins
Aspirant

Re: GS105Ev2 not getting IP Address from DHCP

It shows V5.4.0.3 ... That doesn't seem to be a valid firmware.

Message 5 of 10
schumaku
Guru

Re: GS105Ev2 not getting IP Address from DHCP

Ok, this is is it: You got a switch with a specific customer/project specific firmware. Updating with the utility however to the current one should be possible. Look here FMI: GS105Ev2 FW reads v5.4.0.3 

Message 6 of 10
jrmckins
Aspirant

Re: GS105Ev2 not getting IP Address from DHCP

Yeah, as soon as I checked I figured that was the issue. Time to blow the dust of a windows system so I can run that tool.

Thanks

 

Oh FFS, my windows laptop doesn't have an ethernet port.

Message 7 of 10
jrmckins
Aspirant

Re: GS105Ev2 not getting IP Address from DHCP

I updated the firmware to V1.6.0.6 and it still isn't getting an IP from DHCP

Message 8 of 10
jrmckins
Aspirant

Re: GS105Ev2 not getting IP Address from DHCP

I did a factory reset and it's working now. Thanks.

Message 9 of 10
jrmckins
Aspirant

Re: GS105Ev2 not getting IP Address from DHCP

Here's what I had to do once I figured out the issue was some jacked up firmware:

1. Install ProSAFE Plus Configuration Utility on a windows system

2. manually configure the laptop to use 192.168.0.210; netmask of 255.255.255.0

3. Download the latest firmware from: https://www.netgear.com/support/product/GS105Ev2.aspx#download 

4. Apply the firmware using  ProSAFE Plus Configuration Utility

5. Factory reset the switch

 

I was then able to browse to the switch and use the default password (password) to get in.

 

Thanks to everyone that helped.

Message 10 of 10
Top Contributors
Discussion stats
  • 9 replies
  • 6506 views
  • 2 kudos
  • 2 in conversation
Announcements