Reply

GS108T v2 no longer pulling DHCP after upgrading to the latest FW

ohos
Luminary

GS108T v2 no longer pulling DHCP after upgrading to the latest FW

I decided to upgrade to the latest FW for my GS108Tv2.
The switch works as a switch after the upgrade. However, I can't access its web HMI. The switch is no longer pulling its DHCP. It did before the FW upgrade.

The switch is going back to its default IP, still in DHCP client mode. For some reason it can't get an DHCP IP. All other clients on the switch can, and will find the DHCP server on the ISA server attached to the switch

Worked fine before the FW upgrade. No other changes.
Message 1 of 4
Shadowlore
Luminary

Re: GS108T v2 no longer pulling DHCP after upgrading to the latest FW

If you've not done a factory default on the switch, you might want to, especially if you've done a firmware update that is several revisions newer.
~ Shadowlore
Message 2 of 4
ohos
Luminary

Re: GS108T v2 no longer pulling DHCP after upgrading to the latest FW

I have. Still doesn't pull DHCP. Is there a bug in the FW?
Message 3 of 4
rewrite
Luminary

Re: GS108T v2 no longer pulling DHCP after upgrading to the latest FW

ohos wrote:
I have. Still doesn't pull DHCP. Is there a bug in the FW?


probably the same issue some people had since 5.4.2.xx firmware. you only see this issue if you use non default network address (192.168.0.x) and had a linux DHCP server).

this was the post i posted a while ago in a different thread in this forum:


I also updated to the latest 5.4.2.11 firmware and DHCP is not getting ip anymore on my GS110TP. It was working fine on 5.0.5.10. After doing some 'wiresharking', the issue I found was that the DHCP DISCOVER packet was sent with scr ip 192.168.0.239 instead of 0.0.0.0 as required in a broadcast message. This means if your DHCP server is on a different network (or your entire network is on a different network ie: 172.16.0.0/24), the packet is likely got ignored by the DHCP server because the src ip is not from the same network (i believe ubuntu server by default will do src address verification which will filter out these packets). check this post I found after doing google search which talked about the same issue (and a solution if you are able to change interface setting on your DHCP server):
http://lists.thekelleys.org.uk/pipermail/dnsmasq-discuss/2012q2/005902.html

one solution from a user:
http://lists.thekelleys.org.uk/pipermail/dnsmasq-discuss/2012q2/005909.html
Message 4 of 4
Top Contributors
Discussion stats
  • 3 replies
  • 12282 views
  • 1 kudo
  • 3 in conversation
Announcements