Reply

Betreff: GS116ev2 Web Interface dead after firmware update, any way to recover?

schunckt
Luminary

GS116ev2 Web Interface dead after firmware update, any way to recover?

As the topic says, the box is dead.

I've alrady successfully updated 4 other ones but this latest one now doesnt work any longer.

traffic works, ping response is there. Also I did a factory reset which went back from static do DHCP with new IP.

Ping still works but the web interface is dead.

 

 

Side note - but need to confirm later the day (trying reset / power cycle)

It looks like all other 4 which did work previously are also DEAD !!!!!!!!

 

WTF ....????

Old firmware was 2.6.0.24    updated to 2.6.0.48 (the previous 4 on 28-Feb and they did work since then)

 

How to recover without replacement??? Any clue, anyone..????

 

    T.

 

Message 1 of 5

Accepted Solutions
schumaku
Guru

Betreff: GS116ev2 Web Interface dead after firmware update, any way to recover?

@DaneA a thread worth reading ... the "other" problem with the MTU <1500 was discussed in various threads already. The light IP stack on these devices was secured to fail - even before of the ubiquitous issues going though the industry these days.

View solution in original post

Message 4 of 5

All Replies
schunckt
Luminary

Betreff: GS116ev2 Web Interface dead after firmware update, any way to recover?

Don't know if and how to modify my own message that's why here is an update.

It seems the switch web page really IS working!

 

After connecting the laptop wired to the switch(es) not using WLAN (Fritzbox) it works!

Then I've again access to all switches web pages!

When going back to WLAN it fails.

Also fails from my current remote site (VPN, different from the WLAN router above) so it's unlikely the Laptop...

 

Is there any intentional access restriction (security-wise)  but how? This also would not explain why i can access ALL switches if wired.

 

I think i need some Wireshark session next weekend.

 

   T.

Model: GS116Ev2|ProSafe Plus 16 ports gigabits switch
Message 2 of 5
schumaku
Guru

Betreff: GS116ev2 Web Interface dead after firmware update, any way to recover?

Suspect multiple "features" are coming together with this firmware:

 

  • VPN: fixed MTU, does not allow MTU smaller than 1500
  • Potential "security" changes causing a problem with the ARP resolution (e.g. as used by Proxy ARP on "modern" access points)
Message 3 of 5
schumaku
Guru

Betreff: GS116ev2 Web Interface dead after firmware update, any way to recover?

@DaneA a thread worth reading ... the "other" problem with the MTU <1500 was discussed in various threads already. The light IP stack on these devices was secured to fail - even before of the ubiquitous issues going though the industry these days.

Message 4 of 5
schunckt
Luminary

Betreff: GS116ev2 Web Interface dead after firmware update, any way to recover?

Indeed the MTU IS the problem!

 

My Windows 7 box did set 1492 as the WLAN MTU, checked this way:

netsh interface ipv4 show subinterfaces

After changing (as administrator) on the fly

netsh interface ipv4 set subinterface WLAN mtu=1500 store=active

it works IMMEDIATELY!

When switching back to 1492 it fails again.

 

 

(Note: WLAN is my wireless adapter name. Yours might be different.)

 

    T.

 

 

 

 

 

Message 5 of 5
Top Contributors
Discussion stats
  • 4 replies
  • 705 views
  • 2 kudos
  • 2 in conversation
Announcements