× NETGEAR is aware of a growing number of phone and online scams. To learn how to stay safe click here.
Orbi WiFi 7 RBE973
Reply

Re: M4300 and Timer Schedules / time-range Status always goes to Inactive - How to fix?

MikeNeuffer
Tutor

M4300 and Timer Schedules / time-range Status always goes to Inactive - How to fix?

We have several M4300 (52G/96x) and switches and I am trying to setup working schedules to switch off POE for several ports

during the night and the weekends when the offices are empty.

 

The involved switches are:

M4300-52G-PoE+ ProSAFE 48-port 1G PoE+ and 2-port 10GBASE-T and 2-port 10G SFP+, 12.0.17.8, B1.0.0.17

M4300-96X ProSAFE 96-port 10G, 12.0.17.8, B1.0.0.17

 

When I create a  a new Timer Schedule (System->Timer Schedule->Advanced->Global Configuration), it comes up as active.

However as soon as I define a first (or more) entry (System->Timer Schedule->Advanced->Timer Schedule Configuration) for it

the Schedule becomes inactive.

 

My question is why does the Schedule get set to "Inactive" and how do I get it back "Active"

The Schedules I set are as simple as:

No absolute entry set

--------

Timer Schedule Type: periodic

Timer Schedule Entry: 1

Time Start: 00:00

Time Stop: 07:00

Date Start: 1-Sep-2023

Date End: No End Date

Recurrence Pattern: Daily

Daily Mode: Every Weekday

----------

 

 

As soon as I add this, the Timer Schedule status goes to "Inactive".

Why? And how can I get it to active? 

 

The seems to be no documentation on this whatsoever and also next to no mentioning of this feature on the web.

 

I also need the 2nd and 3rd corresponding entries:

Timer Schedule Type: periodic

Timer Schedule Entry: 2

Time Start: 20:00

Time Stop: 00:00

Date Start: 1-Sep-2023

Date End: No End Date

Recurrence Pattern: Daily

Daily Mode: Every Weekday

-----------

Timer Schedule Type: periodic

Timer Schedule Entry: 3

Time Start: 00:00

Time Stop: 00:00

Date Start: 1-Sep-2023

Date End: No End Date

Recurrence Pattern: Weekly

Weekly Mode: Every Weeks 1 (I also tried to leave it empty)

Weekday: Sun & Sat ticked

-------------

 

I also tried to find a way to change it to active via CLI, but there doesn't seem to a a command for it.

The only thing I could find on the web was "try to change the scheduled and save it" but that didn't help either.

 

So I am stuck here.

 

Is there anybody more knowledgeable then me who can help me to get this seemingly simple configuration to work?

 

Thank you in advance.

 

 

Message 1 of 5
schumaku
Guru

Re: M4300 and Timer Schedules / time-range Status always goes to Inactive - How to fix?

This...

 

Time Start: 00:00

Time Stop: 00:00

 

...does not sound meaningful to a network device, for an all-day schedule.

Message 2 of 5
MikeNeuffer
Tutor

Re: M4300 and Timer Schedules / time-range Status always goes to Inactive - How to fix?

@schumaku First of all thank you for you answer, however

as I wrote previously, the whole timer schedule goes to inactive as soon as I enter the first entry, so this already invalidates your comment.

 

I've documented the behaviour with a few screenshots:

Add a new Timer ScheduleAdd a new Timer Schedule

Add new Timer Schedule

 

The Timer Schedule is activeThe Timer Schedule is active

The new Timer Schedule is active - but with no Schedules attached yet

 

Add a periodic Schedule to the Timer ScheduleAdd a periodic Schedule to the Timer Schedule

Add the new periodic schedule to the Timer Schedule by clicking on the <Add> button (not in the screenshot). It makes no difference if I use a day in the past, todays date or some day in the future for "Day Start".

According to the documentation this schedule will run (ie switch off POE) Mon-Fri from one minute past midnight until 7am. 

 

However:

The Timer Schedule has become inactiveThe Timer Schedule has become inactive

Now the Timer Schedule has become inactive.

 

What is wrong here ? How to switch on the schedule?

 

 

Coming back to your posting, why should 00:00-00:00 not be a meaningful entry?

How else should I qualify that POE should be down on the port for the whole day?

00:00 - 24:00 is not a valid entry and results in an error: 

"Error! Invalid 'Time End' format: 24:00"

 

Switching on POE for one minute per day (23:59 - 00:00) by setting it to 00:00 - 23:59 seems kind of non-sensical.

The devices (mostly, but not exclusively IP telephones) would start to boot, just to be choked off again almost immediately - not exactly very healthy for the hardware.

 

Message 3 of 5
schumaku
Guru

Re: M4300 and Timer Schedules / time-range Status always goes to Inactive - How to fix?


@MikeNeuffer wrote:

Coming back to your posting, why should 00:00-00:00 not be a meaningful entry?.


You re arguing with the wrong person here my friend. Just another community member here, I can just answer based on some longer experience with several Netgear switch generations which don't support continuous and 24h schedules.

 


@MikeNeuffer wrote:

How else should I qualify that POE should be down on the port for the whole day?

00:00 - 24:00 is not a valid entry and results in an error: 

"Error! Invalid 'Time End' format: 24:00"


This would make more sense, however - your result is predictable ... 

 


@MikeNeuffer wrote:

Switching on POE for one minute per day (23:59 - 00:00) by setting it to 00:00 - 23:59 seems kind of non-sensical.


It won't kill any hardware if its powered up for one minute only. Not nice, I admit. Let's see of you can get some better answers from the Netgear side...

 


@MikeNeuffer wrote:

The devices (mostly, but not exclusively IP telephones) would start to boot, just to be choked off again almost immediately - not exactly very healthy for the hardware.


Not nice, I admit. Let's see of you can get some better answers from the Netgear side...

 

Had lengthy discussion in the past over this oddity already.

Message 4 of 5
MikeNeuffer
Tutor

Re: M4300 and Timer Schedules / time-range Status always goes to Inactive - How to fix?

I order to document my findings:

 

We have undocumented behaviour here:

Once a schedule has been configured for a Timer Schedule, the status of the timer schedule (active/inactive) is determined by wether one of the schedules is _currently_ triggering/running or not. Before it is always active.

 

I found a severe bug in the current FW release 12.0.17.13 (not sure if it is also present in older releases):

If you update a Schedule of a Timer Schedule

it will immediately reset the affected ethernet ports

as soon as you click on <Apply>

if the schedule will trigger next in more then a handful minutes.

I didn't experiment in oder to find the exact required time differential,

but is was able to see the ports being reset when I was clicking on <Apply> about 10min before the Schedule would trigger, and it didn't reset them when the time differential was about 3 minutes.

Actually I first tested the 3 minutes differential, then with a modified schedule the 10min differential.

 

This is absolutely reproducible on the M4300 I did my tests on when I was discussing the active/inactive issue with 2nd/3rd level support.

 

 

 

 

Message 5 of 5
Top Contributors
Discussion stats
  • 4 replies
  • 633 views
  • 1 kudo
  • 2 in conversation
Announcements