Introducing the Orbi 970 Series Mesh System with WiFi 7 technology. For more information visit the NETGEAR Press Room.

Orbi WiFi 7 RBE973

Netgear GS308EP


Netgear GS308EP

Just received a new GS308EP switch.

I set my network settings on my MacBook Pro (2014) to manual, address of, subnet of, gateway of  Opened a tab in Safari and entered  It saw GS308EP and asked for password.  I entered: password and it just stays on the password screen.  I entered a wrong password and it says incorrect.  Correct password does not take me to the admin page.  I tried the SWITCH DISCOVERY TOOL.  It sees the switch, takes me to the password screen and I still don't get to the admin page.  It just stays on the password page.  I reset the switch and tried again 3 times.  It just gets stuck on the password page.  Help?!  Thanks!

Message 1 of 3

Re: Netgear GS308EP

Ensure the switch does have a current firmware in place https://www.netgear.com/support/product/gs308ep#download 


Dropping the browser cache might help to forget non-matching stored information.


Still possible, some minor incompatibilities exist on the embedded Web code. Try an alternate browser instead.

Message 2 of 3

Re: Netgear GS308EP

Firmware is current.
I placed a wireless router into the chain, changed over to DHCP and it worked. Weird.
Message 3 of 3
Top Contributors
Discussion stats
  • 2 replies
  • 1 kudo
  • 2 in conversation