Reply

ReadyNas RND2000 v2 & ERR_SSL_VERSION_OR_CIPHER_MISMATCH & RAIDiator 4.1.12 update quest

CES001
Aspirant

ReadyNas RND2000 v2 & ERR_SSL_VERSION_OR_CIPHER_MISMATCH & RAIDiator 4.1.12 update quest

Hello,

 

I have a ReadyNas RND2000 v2 & ERR_SSL_VERSION_OR_CIPHER_MISMATCH & RAIDiator 4.1.12 update quest: how do i update this NAS so that i dont get this SSL error message ?

 

I can access the admin page using Internet Explorer.

 

But what/which image do i need to (try to) upload to the NAS ? 

 

Hope that someone knows the solution.

 

Best regards CES

 

Model: RND2000v2|ReadyNAS Duo v2 Chassis only
Message 1 of 16

Accepted Solutions
ValerieD
Sr. NETGEAR Moderator

Re: ReadyNas RND2000 v2 & ERR_SSL_VERSION_OR_CIPHER_MISMATCH & RAIDiator 4.1.12 update quest

Hi @CES001,
 

Google Chrome, and other internet browsers, has stopped ssl1 support.
So you have to use an older browser to access your device.

Doesn't work: Chrome and Edge (I will escalate to add yours).
Currently Working: IE11 (EOL June 2022) and Firefox 97.0 (however it alerts that TLS 1.0 and 1.1 will not be supported in a future release). Pale Moon.

 
Good day to you,
Valerie D
Netgear Team

View solution in original post

Message 5 of 16

All Replies
CES001
Aspirant

Re: ReadyNas RND2000 v2 & ERR_SSL_VERSION_OR_CIPHER_MISMATCH & RAIDiator 4.1.12 update que

Hello again,

 

I tried to upload RAIDiator-arm-5.3.13 but i receive an error message.

 

Checking if there is an update from Internet also ends with an error message.....

 

Hope any of you can help me.

 

Best regards, CES

Model: RND2000|ReadyNAS Duo Chassis only
Message 2 of 16
ValerieD
Sr. NETGEAR Moderator

Re: ReadyNas RND2000 v2 & ERR_SSL_VERSION_OR_CIPHER_MISMATCH & RAIDiator 4.1.12 update quest

Hi @CES001,
 
And welcome to the NETGEAR Community! 🙂

When this "SSL error message" happens, which internet browse are you using?

 
Good day to you,
Valerie D
Netgear Team

Message 3 of 16
CES001
Aspirant

Re: ReadyNas RND2000 v2 & ERR_SSL_VERSION_OR_CIPHER_MISMATCH & RAIDiator 4.1.12 update quest

Hi Valerie,

 

The current browser is Brave but Edge also gives the same error.

ERR_SSL_VERSION_OR_CIPHER_MISMATCH

<ip address> uses an unsupported protocol.

best regards CES

 

Message 4 of 16
ValerieD
Sr. NETGEAR Moderator

Re: ReadyNas RND2000 v2 & ERR_SSL_VERSION_OR_CIPHER_MISMATCH & RAIDiator 4.1.12 update quest

Hi @CES001,
 

Google Chrome, and other internet browsers, has stopped ssl1 support.
So you have to use an older browser to access your device.

Doesn't work: Chrome and Edge (I will escalate to add yours).
Currently Working: IE11 (EOL June 2022) and Firefox 97.0 (however it alerts that TLS 1.0 and 1.1 will not be supported in a future release). Pale Moon.

 
Good day to you,
Valerie D
Netgear Team

Message 5 of 16
CES001
Aspirant

Re: ReadyNas RND2000 v2 & ERR_SSL_VERSION_OR_CIPHER_MISMATCH & RAIDiator 4.1.12 update quest

Hi Valerie,

 

Thank you for your reply.

Ok, i will retain a copy of Internet Explorer for that sense, so that i can access the admin page.

The second part of my question was: is there a way i can update the firmware of my NAS to the latest version without getting these error messages ?

Best regards Chris

Message 6 of 16
CES001
Aspirant

Re: ReadyNas RND2000 v2 & ERR_SSL_VERSION_OR_CIPHER_MISMATCH & RAIDiator 4.1.12 update quest

Hi Valerie,

 

Do you have time to look at my question how i can update my NAS  ("is there a way i can update the firmware of my NAS to the latest version without getting these error messages ?") ?

Actually i have 3 identical NAS devices which all need this update.

Can you please help ?

best regards,

Chris

Message 7 of 16
ValerieD
Sr. NETGEAR Moderator

Re: ReadyNas RND2000 v2 &amp; ERR_SSL_VERSION_OR_CIPHER_MISMATCH &amp; RAIDiator 4.1.12 update quest

Hi @CES001,
 

Sorry for the delay. 

Did you try to use IE or Firefox?

You can use the second method in this article:

https://kb.netgear.com/000049343/RAIDiator-4-Updating-firmware


Good day to you,
Valerie D
Netgear Team

Message 8 of 16
CES001
Aspirant

Re: ReadyNas RND2000 v2 & ERR_SSL_VERSION_OR_CIPHER_MISMATCH & RAIDiator 4.1.12 update quest

Hi Valerie, 

I am using Brave as a browser.

And in the second post i wrote:

"I tried to upload RAIDiator-arm-5.3.13 but i receive an error message. Checking if there is an update from Internet also ends with an error message....."

 

Question: could it be that RAIDiator-arm-5.3.13 is not the right piece of update i need to use ?

In other words: can you please help me by informing me which version i need to use ? And maybe i need to update it first to a certain software level, and then later to the latest level ? 

 

I really hope you can help me....

 

Thanks a lot !

 

Best regards Chris

Updating your ReadyNAS via the Remote option:

  1. Navigate to Frontview
  2. Select System > Update
  3. Select the Remote tab.
  4. Select the Check for Update button.
  5. If a newer firmware is available, you are prompted to update the system. Click Install to process the upgrade.
  6. Select Shutdown and Reboot device to update your ReadyNAS.

Updating your ReadyNAS via the Local option:

  1. Go to the support page for your ReadyNAS and click Downloads.
  2. Download the RAIDiator firmware for your ReadyNAS to a computer that is local to the ReadyNAS.
  3. Navigate to Frontview
  4. Select System > Update
  5. Select the Local tab.
  6. Browse to the firmware you downloaded from the support page.
  7. Click Install to process the upgrade.
  8. Select Shutdown and Reboot device to update your ReadyNAS.
Message 9 of 16
CES001
Aspirant

Re: ReadyNas RND2000 v2 & ERR_SSL_VERSION_OR_CIPHER_MISMATCH & RAIDiator 4.1.12 update quest

Hello Valerie, 

Can you please help me ?

best regards, CES

Message 10 of 16
ValerieD
Sr. NETGEAR Moderator

Re: ReadyNas RND2000 v2 & ERR_SSL_VERSION_OR_CIPHER_MISMATCH & RAIDiator 4.1.12 update quest

Hi @CES001,
 

As I explained you, I would advise to use IE or Firefox as Brave has stopped ssl1 support.

You may still get a warning when accessing the admin page but the error will be different and it can be ignored.

For the firmware you should use:

https://kb.netgear.com/000038792/RAIDiator-Version-4-1-16-Sparc

It is the last version available for your ReayNAS.

 

Good day to you,
Valerie D
Netgear Team

Message 11 of 16
CES001
Aspirant

Re: ReadyNas RND2000 v2 & ERR_SSL_VERSION_OR_CIPHER_MISMATCH & RAIDiator 4.1.12 update quest

Thank you Valerie, yes, i am using IE as a browser as an intermediate solution, because i would like to receive normal browser again after update.

 

Thank you for advise regarding https://kb.netgear.com/000038792/RAIDiator-Version-4-1-16-Sparc ; i will try it in the near future (in 2 weeks time from now) and i will let you know if i was able to solve this.

To be continued :cathappy:

 

best regards Chris

Message 12 of 16
ValerieD
Sr. NETGEAR Moderator

Re: ReadyNas RND2000 v2 & ERR_SSL_VERSION_OR_CIPHER_MISMATCH & RAIDiator 4.1.12 update quest

Hi @CES001,
 

I'm happy to help and I will wait for your update.

 

Good day to you,
Valerie D
Netgear Team

Message 13 of 16
CES001
Aspirant

Re: ReadyNas RND2000 v2 & ERR_SSL_VERSION_OR_CIPHER_MISMATCH & RAIDiator 4.1.12 update que

Hello Valerie.

 

I successfully upgraded my NAS to version RAIDiator-Sparc-4.1.16.

When i try to open the admin page using Internet Explorer that still works.

When i try to open the admin page using Brave browser, it opens on the Shares pages, stating "No shares currently accessible."  but the shares are available and do appear when using the shares page using IE.

 

Also the admin page using Brave shows  "This site can’t provide a secure connection <ip address> uses an unsupported protocol.
ERR_SSL_VERSION_OR_CIPHER_MISMATCH    where the admin page using IE shows normally.

 

Question: do i need to run yet another update after this RAIDiator-Sparc-4.1.16 update to get rid of these error messages? Or is this the latest update available where i have to live using IE (remember, IE support will stop in June so 2 months left).

 

Objective here is to run the NAS using Brave instead of using IE.

 

Looking forward again to your help once more.

 

best regards.

 

Message 14 of 16
ValerieD
Sr. NETGEAR Moderator

Re: ReadyNas RND2000 v2 & ERR_SSL_VERSION_OR_CIPHER_MISMATCH & RAIDiator 4.1.12 update que

Hi @CES001,
 

No, a new update won't change this issue. The problem here is with the new versions of browsers not supporting anymore ssl1.

You won't be able to use Brave anymore to run your ReadyNAS.

IE and Firefox still work, but they already alerted that they would not support ssl1 either in next versions. 

So I would advise you to use Pale Moon which so far hasn't reported wanting to stop supporting ssl1.

 

Good day to you,
Valerie D
Netgear Team

Message 15 of 16
CES001
Aspirant

Re: ReadyNas RND2000 v2 & ERR_SSL_VERSION_OR_CIPHER_MISMATCH & RAIDiator 4.1.12 update que

Hi Valerie,

 

Thank you for your tip about the Pale Moon browser, i did not know that browser.

Lets hope they keep SSL1 support for the time being.

 

Your help has led me to update my NAS to the latest firmware, that was useful as well.

 

I am going to think of changing NAS devices to a newer model in the coming year, but, with your Pale Moon browser tip i have now won some time not being forced to make this migration before SSL1 support is removed from the other browsers anytime soon.

 

Once again, thank you for your help and we can close this case now.

 

Have a nice day.

 

best regards

Chris

Message 16 of 16
Discussion stats
  • 15 replies
  • 25534 views
  • 1 kudo
  • 2 in conversation