No Internet After Connecting GS808E Switch to Router


No Internet After Connecting GS808E Switch to Router

I have spent too many hours resetting things to default, trying to reconfigure things, plugging and unplugging cables, etc. Whilst I have multiple devices in the house, all the PC's in the house are on Windows 10, not that it should matter. Here is my list of components in my home network:

Modem: Netgear CM600 Cable Modem (service provided by Spectrum)
Router: Asus RT-AC3200
Switch: Netgear GS808E (Nighthawk S8000)
Brief history: PC connected directly to modem, works/have internet connection. Router connected to modem/PC connected to router, works both wired and wireless. Introduced the Nighthawk S8000 (or either of the other two switches I have at home), no internet anywhere.


I assumed that adding a switch to the mix, to expand my network would be fairly easy/plug and play. A crappy TrendNET 5-port switch worked previously, when I had AT&T Uverse, and some ports worked on the crappy 8-port Monoprice switch that I had.


Yes, modem is connected to WAN port on router. Yes, port 1 on router is connected to port 8 on switch. I have enabled jumbo frame on the router under ""Switch Control"" as well. I have tried rebooting and resetting things. I have tried powering up the router first, then the switch, and tried powering up the switch, and then the router

Message 1 of 1
Discussion stats
  • 0 replies
  • 0 kudos
  • 1 in conversation