× NETGEAR will be terminating ReadyCLOUD service by July 1st, 2023. For more details click here.
Orbi WiFi 7 RBE973

Re: 6.10 t185 beta 2 - smb issues copying between shares

TeknoJnky
Hero

6.10 t185 beta 2 - smb issues copying between shares

I have experienced issues with beta 2 involving attempting to copy file/folders from one share to another via network\server\share (did not try not mapped drives).

 

reproduction steps (as best I remember)

open server \\servername

navigate to share/folder \\servername\share1\folder1

copy (copy/paste or drag drop) folder 1 to share2

\\servername\share2\folder1

expected results, folder and contents are copied from share1 to share2

actual results, windows copy dialog essentially hangs and shows no progress, no further smb access

must reboot PC and NAS to regain smb access.

 

See also other report @ thread 

 
additional info, windows is part of pre-release insider edition, not sure what the version was when I experienced the issue, windows has been updated to new builds a few times and I have not re-attempted issue due to length of downtime for desktop and nas.
 
Model: RN528X|ReadyNAS 528X - Premium Performance Business Data Storage 8-Bay
Message 1 of 16

Accepted Solutions
B_L
NETGEAR Expert
NETGEAR Expert

Re: 6.10 t185 beta 2 - smb issues copying between shares

6.9.5 Beta1 has the fix. You probably want to install 6.9.5 Beta 1 release.

View solution in original post

Message 4 of 16

All Replies
pvnnpavan
Tutor

Re: 6.10 t185 beta 2 - smb issues copying between shares

I am on windows latest main build and issue happens...after upgrading to 6.9.4 hotfix1. Issue is still there with 6.10 beta...But if you use Linux like redhat 7 or CentOS 7 I am able to copy files without issues...after fresh Nas start.. I used smb only in Linux not afp. Need to check what happens with afp during issue on linux
Downgrade to 6.9.3 resolves to issue but cannot access homepage which is a larger issue.
Message 2 of 16
Pacoo
Aspirant

Re: 6.10 t185 beta 2 - smb issues copying between shares

I have the same problem with firmware 6.9.4 hotfix 1

Model: RN426| ReadyNAS High-performance Business Data Storage - 6-Bays
Message 3 of 16
B_L
NETGEAR Expert
NETGEAR Expert

Re: 6.10 t185 beta 2 - smb issues copying between shares

6.9.5 Beta1 has the fix. You probably want to install 6.9.5 Beta 1 release.

Message 4 of 16
pvnnpavan
Tutor

Re: 6.10 t185 beta 2 - smb issues copying between shares

If 6.9.5 beta1 has fix how come I am getting issues in 6.10 beta2..

Moreover reverting from 6.10 to 6.5 us causing issues with gui
Message 5 of 16
B_L
NETGEAR Expert
NETGEAR Expert

Re: 6.10 t185 beta 2 - smb issues copying between shares

Because 6.9.5 Beta 1 was released after 6.10.0 Beta 2. If you have the GUI access issue after installing 6.9.5, please enable the secure diagnostic mode and send the port number to me in private message. I can help you to fix it.

Message 6 of 16
pvnnpavan
Tutor

Re: 6.10 t185 beta 2 - smb issues copying between shares

Thanks....let me get back... I am right now on 6.10 beta2.I had issues with GUI and apps after this upgrade...I uninstalled most of them :(...I think I upgraded apache2 which made 6.10 beta stable.

I will work again on Thursday on this and will send a note.

Thanks
Message 7 of 16
steveoelliott
Luminary

Re: 6.10 t185 beta 2 - smb issues copying between shares

Wow... I'm surprised that wasn't picked up during testing, especially in 6.9.4.

Once triggered by a simple copy between two UNC paths on the NAS do I read correctly that smb hangs completely? This is a catastrophic event that causes an outage / requires the NAS to be reloaded.

Will there be a hotfix / auto update release to fix this?

 

Also any details on what the actual root cause of this issue was?

Message 8 of 16
pvnnpavan
Tutor

Re: 6.10 t185 beta 2 - smb issues copying between shares

Hi @B_L,

 

I am running my NAS for last couple of days on 6.10 Beta 2.. and seesm to be stable.  No more issues with apache as well.. and my admin page is running as well.

 

Interestingly, I did not  face any SMB issues.. Not sure what fixed it.. I have around 3.8 TB of data.. so last couple of days I am only tring to backup all data to multiple external drives and to my FREENAS.

 

Since system seems to be stable, would like to leave it as it is.. and hope I will get a stable 6.10 soon for upgrade.

 

Onething I can think of is Plex which is scanning files.. Do you think it will caues any issues with File copying across.  May be is it locking files during library scan ??

 

Provide your comments.  And thanks once again for giving helping hand.  I really do appreciate it.

 

And if you can provide details of the changes in here or on personal message, I can give a try when I get a new HDD for FreeNAS.. just dont want to risk any crash.

 

 

Message 9 of 16
pvnnpavan
Tutor

Re: 6.10 t185 beta 2 - smb issues copying between shares

I again started facing issues with SMB.. and not sure why issue mostly happens with Photos.. When I copy large video files it worked.. Only thing which I can remember is the folder was created recently.. where as other folder was created a year ago.

 

So i downgraded to 6.9.3.. and it is working now without any issues.. No errors and home page is working without any issues.   Probably apps were causing issues with Apache before..

 

Below is the service summary..

 

 

 

 

root@PPKNAS:~# systemctl status apache2
● apache2.service - The Apache HTTP Server
   Loaded: loaded (/lib/systemd/system/apache2.service; enabled; vendor preset: enabled)
   Active: active (running) since Sun 2018-11-25 10:42:04 IST; 8min ago
  Process: 3142 ExecReload=/bin/kill -USR1 $MAINPID (code=exited, status=0/SUCCESS)
  Process: 3132 ExecReload=/usr/sbin/apache2 $OPTIONS -t (code=exited, status=0/SUCCESS)
 Main PID: 2441 (apache2)
   CGroup: /system.slice/apache2.service
           ├─2441 /usr/sbin/apache2 -k start
           ├─3151 apache_log               
           ├─3152 apache_log               
           ├─3153 apache_log               
           ├─3154 apache_log               
           ├─3155 /usr/sbin/apache2 -k start
           ├─3156 /usr/sbin/apache2 -k start
           ├─3157 /usr/sbin/apache2 -k start
           ├─3158 /usr/sbin/apache2 -k start
           ├─3159 /usr/sbin/apache2 -k start
           ├─3160 /usr/sbin/apache2 -k start
           ├─3330 /usr/sbin/apache2 -k start
           ├─3573 /usr/sbin/apache2 -k start
           ├─4257 /usr/sbin/apache2 -k start
           ├─4342 /usr/sbin/apache2 -k start
           ├─4600 /usr/sbin/apache2 -k start
           └─7050 /frontview/lib/dbbroker.cgi

Nov 25 10:42:34 PPKNAS apache2[2441]: [warn] long lost child came home! (pid 2442)
Nov 25 10:42:34 PPKNAS apache2[2441]: [warn] long lost child came home! (pid 2443)
Nov 25 10:42:34 PPKNAS apache2[2441]: [warn] long lost child came home! (pid 2444)
Nov 25 10:42:34 PPKNAS apache2[2441]: [warn] long lost child came home! (pid 2445)
Nov 25 10:42:34 PPKNAS apache2[2441]: [warn] long lost child came home! (pid 2446)
Nov 25 10:42:34 PPKNAS apache_access[3154]: ::1 "GET /server-status?auto HTTP/1.1" 200
Nov 25 10:42:36 PPKNAS apache_access[3154]: ::1 "GET /server-status?auto HTTP/1.1" 200
Nov 25 10:42:37 PPKNAS apache2[3159]: [error] [client 192.168.1.13] Connect rddclient failed, referer: https://192.168.1.100/admin/
Nov 25 10:42:37 PPKNAS apache_access[3152]: Admin session started from 192.168.1.13
Nov 25 10:42:37 PPKNAS apache2[3158]: [error] [client 192.168.1.13] Connect rddclient failed, referer: https://192.168.1.100/admin/
root@PPKNAS:~# systemctl status apache2-safe
● apache2-safe.service - The Apache HTTP Server (Safe Mode)
   Loaded: loaded (/lib/systemd/system/apache2-safe.service; static; vendor preset: enabled)
   Active: inactive (dead)

Message 10 of 16
pvnnpavan
Tutor

Re: 6.10 t185 beta 2 - smb issues copying between shares

root@PPKNAS:~# systemctl status readynasd
● readynasd.service - ReadyNAS System Daemon
   Loaded: loaded (/lib/systemd/system/readynasd.service; enabled; vendor preset: enabled)
   Active: active (running) since Sun 2018-11-25 10:42:38 IST; 10min ago
 Main PID: 2459 (readynasd)
   Status: "Start Main process"
   CGroup: /system.slice/readynasd.service
           └─2459 /usr/sbin/readynasd -v 3 -t

Nov 25 10:45:41 PPKNAS readynasd[2459]: GetUnitFileState: GDBus.Error:org.freedesktop.DBus.Error.FileNotFound: No such file or directory
Nov 25 10:45:41 PPKNAS readynasd[2459]: Failed to get state for unit fvapp-plexpy.service
Nov 25 10:45:41 PPKNAS readynasd[2459]: GetUnitFileState: GDBus.Error:org.freedesktop.DBus.Error.FileNotFound: No such file or directory
Nov 25 10:45:41 PPKNAS readynasd[2459]: Failed to get state for unit fvapp-plexpy.service
Nov 25 10:46:43 PPKNAS readynasd[2459]: (process:2459): Tracker-WARNING **: tracker-backend.vala:211: Falling back to bus backend, the direct backend failed to init
ialize: Locale change detected (DB:en_US.UTF-8, User/App:C)
Nov 25 10:47:45 PPKNAS readynasd[2459]: (process:2459): Tracker-WARNING **: tracker-backend.vala:211: Falling back to bus backend, the direct backend failed to init
ialize: Locale change detected (DB:en_US.UTF-8, User/App:C)
Nov 25 10:48:47 PPKNAS readynasd[2459]: (process:2459): Tracker-WARNING **: tracker-backend.vala:211: Falling back to bus backend, the direct backend failed to init
ialize: Locale change detected (DB:en_US.UTF-8, User/App:C)
Nov 25 10:49:53 PPKNAS readynasd[2459]: (process:2459): Tracker-WARNING **: tracker-backend.vala:211: Falling back to bus backend, the direct backend failed to init
ialize: Locale change detected (DB:en_US.UTF-8, User/App:C)
Nov 25 10:50:54 PPKNAS readynasd[2459]: (process:2459): Tracker-WARNING **: tracker-backend.vala:211: Falling back to bus backend, the direct backend failed to init
ialize: Locale change detected (DB:en_US.UTF-8, User/App:C)
Nov 25 10:52:02 PPKNAS readynasd[2459]: (process:2459): Tracker-WARNING **: tracker-backend.vala:211: Falling back to bus backend, the direct backend failed to init
ialize: Locale change detected (DB:en_US.UTF-8, User/App:C)
Message 11 of 16
pvnnpavan
Tutor

Re: 6.10 t185 beta 2 - smb issues copying between shares

There seems to be errors in logs.. but system is working as intended.

 

@B_L can you please check the messages and let me know if you need me to change anything.

Message 12 of 16
pvnnpavan
Tutor

Re: 6.10 t185 beta 2 - smb issues copying between shares

Logs from HTTPD

 

Nov 25 10:42:21 PPKNAS apache2[2509]: [error] [client 192.168.1.13] Connect rddclient failed, referer: https://192.168.1.100/admin/
Nov 25 10:42:22 PPKNAS apache_access[2445]: ::1 "GET /server-status?auto HTTP/1.1" 200
Nov 25 10:42:22 PPKNAS apache2[2450]: [error] [client ::1] File does not exist: /frontview/dashboard/stub_status
Nov 25 10:42:22 PPKNAS apache_access[2445]: ::1 "GET /stub_status HTTP/1.1" 404
Nov 25 10:42:22 PPKNAS apache2[2451]: [error] [client 127.0.0.1] File does not exist: /frontview/dashboard/stub_status
Nov 25 10:42:22 PPKNAS apache_access[2445]: 127.0.0.1 "GET /stub_status HTTP/1.1" 404
Nov 25 10:42:22 PPKNAS apache2[2447]: [error] [client ::1] File does not exist: /frontview/dashboard/stub_status
Nov 25 10:42:22 PPKNAS apache_access[2445]: ::1 "GET /stub_status HTTP/1.1" 404
Nov 25 10:42:22 PPKNAS apache2[2448]: [error] [client ::1] File does not exist: /frontview/dashboard/status
Nov 25 10:42:22 PPKNAS apache_access[2445]: ::1 "GET /status HTTP/1.1" 404
Nov 25 10:42:22 PPKNAS apache2[2509]: [error] [client 127.0.0.1] File does not exist: /frontview/dashboard/status
Nov 25 10:42:22 PPKNAS apache_access[2445]: 127.0.0.1 "GET /status HTTP/1.1" 404
Nov 25 10:42:22 PPKNAS apache2[2449]: [error] [client ::1] File does not exist: /frontview/dashboard/status
Nov 25 10:42:22 PPKNAS apache_access[2445]: ::1 "GET /status HTTP/1.1" 404
Nov 25 10:42:22 PPKNAS apache2[2450]: [error] [client ::1] File does not exist: /frontview/dashboard/status
Nov 25 10:42:22 PPKNAS apache_access[2445]: ::1 "GET /status?full&json HTTP/1.1" 404
Nov 25 10:42:22 PPKNAS apache2[2451]: [error] [client 127.0.0.1] File does not exist: /frontview/dashboard/status
Nov 25 10:42:22 PPKNAS apache_access[2445]: 127.0.0.1 "GET /status?full&json HTTP/1.1" 404
Nov 25 10:42:22 PPKNAS apache2[2447]: [error] [client ::1] File does not exist: /frontview/dashboard/status
Nov 25 10:42:22 PPKNAS apache_access[2445]: ::1 "GET /status?full&json HTTP/1.1" 404
Nov 25 10:42:26 PPKNAS apache2[2509]: [error] [client 192.168.1.13] Connect rddclient failed, referer: https://192.168.1.100/admin/
Nov 25 10:42:29 PPKNAS apache2[2449]: [error] [client 192.168.1.13] Connect rddclient failed, referer: https://192.168.1.100/admin/
Nov 25 10:42:30 PPKNAS apache2[2450]: [error] [client 192.168.1.13] Connect rddclient failed, referer: https://192.168.1.100/admin/
Nov 25 10:42:31 PPKNAS apache2[2451]: [error] [client 192.168.1.13] Connect rddclient failed, referer: https://192.168.1.100/admin/
Nov 25 10:42:32 PPKNAS apache2[2447]: [error] [client 192.168.1.13] Connect rddclient failed, referer: https://192.168.1.100/admin/
Nov 25 10:42:34 PPKNAS apache2[2509]: [error] [client 192.168.1.13] Connect rddclient failed, referer: https://192.168.1.100/admin/
Nov 25 10:42:34 PPKNAS apache2[3132]: [Sun Nov 25 10:42:34 2018] [warn] Useless use of AllowOverride in line 4 of /etc/frontview/apache/apps-https.conf.
Nov 25 10:42:34 PPKNAS apache2[3132]: [Sun Nov 25 10:42:34 2018] [warn] Useless use of AllowOverride in line 4 of /etc/frontview/apache/apps-https.conf.
Nov 25 10:42:34 PPKNAS apache2[3132]: [Sun Nov 25 10:42:34 2018] [warn] Useless use of AllowOverride in line 4 of /etc/frontview/apache/apps-https.conf.
Nov 25 10:42:34 PPKNAS apache2[3132]: [Sun Nov 25 10:42:34 2018] [warn] Useless use of AllowOverride in line 4 of /etc/frontview/apache/apps-https.conf.
Nov 25 10:42:34 PPKNAS apache2[3132]: apache2: Could not reliably determine the server's fully qualified domain name, using fe80::d861:58ff:fe3b:5e8d for ServerName
Nov 25 10:42:34 PPKNAS apache2[3132]: Syntax OK
Nov 25 10:42:34 PPKNAS apache2[2441]: [warn] RSA server certificate CommonName (CN) `nas-F2-D1-4E.local' does NOT match server name!?
Nov 25 10:42:34 PPKNAS apache2[2441]: [warn] RSA server certificate CommonName (CN) `nas-F2-D1-4E.local' does NOT match server name!?
Nov 25 10:42:34 PPKNAS apache2[2441]: [warn] Init: Name-based SSL virtual hosts only work for clients with TLS server name indication support (RFC 4366)
Nov 25 10:42:34 PPKNAS apache2[2441]: [warn] long lost child came home! (pid 2442)
Nov 25 10:42:34 PPKNAS apache2[2441]: [warn] long lost child came home! (pid 2443)
Nov 25 10:42:34 PPKNAS apache2[2441]: [warn] long lost child came home! (pid 2444)
Nov 25 10:42:34 PPKNAS apache2[2441]: [warn] long lost child came home! (pid 2445)
Nov 25 10:42:34 PPKNAS apache2[2441]: [warn] long lost child came home! (pid 2446)
Nov 25 10:42:34 PPKNAS apache_access[3154]: ::1 "GET /server-status?auto HTTP/1.1" 200
Nov 25 10:42:36 PPKNAS apache_access[3154]: ::1 "GET /server-status?auto HTTP/1.1" 200
Nov 25 10:42:37 PPKNAS apache2[3159]: [error] [client 192.168.1.13] Connect rddclient failed, referer: https://192.168.1.100/admin/
Nov 25 10:42:37 PPKNAS apache_access[3152]: Admin session started from 192.168.1.13
Nov 25 10:42:37 PPKNAS apache2[3158]: [error] [client 192.168.1.13] Connect rddclient failed, referer: https://192.168.1.100/admin/
Message 13 of 16
pvnnpavan
Tutor

Re: 6.10 t185 beta 2 - smb issues copying between shares

My posts on this reply are not going through.. and are getting rejected.. not sure why.

 

Did I do something wrong

Message 14 of 16
StephenB
Guru

Re: 6.10 t185 beta 2 - smb issues copying between shares


@pvnnpavan wrote:

My posts on this reply are not going through.. and are getting rejected.. not sure why.


They were detected by the automatic spam filter.  I released them from quarantine for you.

Message 15 of 16
pvnnpavan
Tutor

Re: 6.10 t185 beta 2 - smb issues copying between shares

@B_L thanks for your time and have me in fixing issues with apps.

This issue now stands closed after downgrade to 6.3 stable.
Message 16 of 16
Discussion stats
  • 15 replies
  • 4949 views
  • 2 kudos
  • 6 in conversation
Announcements