× NETGEAR will be terminating ReadyCLOUD service by July 1st, 2023. For more details click here.
Orbi WiFi 7 RBE973
Reply

RN524X stuck on "booting..." after flashing 6.10.0

chopin70
Virtuoso

RN524X stuck on "booting..." after flashing 6.10.0

I never had any issues flashing firmware.

This time, I wanted to update the 6.9.5 to 6.10.0 I got from Netgear official OS6 page.

Usually I wait for stable FW, but since it was delayed and because of the High grade CVE fix, I wanted to update manually.

After first flash and reboot, GUI came back to v6.9.5. Log didn't show any flashing error, and version was still 6.9.5 in check for updates.

I don't know why I decided to flash it again manually.

Well, after this second flash, it is stuck on "Booting..."

I pressed Power button after 15mn, it immeadiately restarted and again stuck on booting. GUI is not accessible. Raidar doesn't see the NAS

Any help please to avoid a full reset ?

Model: RN524X|ReadyNAS 524X – Premium Performance Data Storage - 4-Bay
Message 1 of 9

Accepted Solutions
JohnCM_S
NETGEAR Employee Retired

Re: RN524X stuck on "booting..." after flashing 6.10.0

Hi chopin70,

 

Based on the logs, it tried to update the firmware but had a problem, so it did not proceed with the upgrade.

 

[2019/04/14 12:00:04 UTC] Could not update flash device!
[2019/04/14 13:23:55 UTC] Updated from ReadyNASOS 6.9.5 (ReadyNASOS) to 6.10.0 (ReadyNASOS).

 

It is possible that you might have downloaded a bad copy of the firmware.

 

Also, can you confirm that the RN524X actually boots directly in a recovery USB key if it finds one plugged in any port, and even without pressing Ok button on start ? Seems like my unit behaves like that

Yes, this is known and expected behavior. In 6.4, if you have a USB Recovery connected, it will look for the flag automatically and initiate it.

 

Regards,

View solution in original post

Message 8 of 9

All Replies
chopin70
Virtuoso

Re: RN524X stuck on "booting..." after flashing 6.10.0

I just tried the USB recovery procedure after a search. I put back 6.10.0 on the USB key as I saw we should not downgrade from this version.

I had to test 2 keys before pressing Ok button actually did something.

Also wired stuff:

- after pressing the Ok button for a few seconds, display changes to "Booting.." with 2 dots instead of the "Booting..." with three dots

- it displays info about updating firmware

- then it turns off

- I had to remove the USB key to avoid this thing happen in a loop once the NAS is turned back on

 

Is this normal ? I saw nowhere a note that we need to take out the USB key from front USB port once the NAS turns off automatically after the USB recovery procedure.

 

It finally updated to 6.10.0

At tech support: do you need logs to fix it ? First time I get such an issue updating stable firmware manually.

Also, one of my volumes has a 5% free capacity, but still some 100 gigs of free storage. Can it be the cause ?

Hope you can give some feedback

 

Best regards

Message 2 of 9
chopin70
Virtuoso

Re: RN524X stuck on "booting..." after flashing 6.10.0

Today: turned on my NAS with the recovery USB key plugged in back USB port

I did not watch at the GUI display but NAS turned off by its self after booting a few minutes

I removed the USB key from back, turned on the NAS, and it booted normally

The logs have no entries about that boot time when it turned off by its self !

I feel like there are still issues since this update to 6.10.0 that went wrong.

I am not sure the USB key with recovery sequence is the cause though.

Any help please

Message 3 of 9
StephenB
Guru

Re: RN524X stuck on "booting..." after flashing 6.10.0


@chopin70 wrote:

I feel like there are still issues since this update to 6.10.0 that went wrong.


FWIW, I had no issues doing the update on my own RN524x.

 


@chopin70 wrote:

Any help please


You should probably grab the log zip file, before it rotates.  Then PM  @JohnCM_S with a link to them, and ask him to analyze.  Don't post them publicly; send the link in a private message.  Then he might be able to tell you what went wrong (and escalate to development if there's a bug in the update that needs to be addressed).

Message 4 of 9
chopin70
Virtuoso

Re: RN524X stuck on "booting..." after flashing 6.10.0

Thank you

I downloaded the logs after the first successful update. I can see the time of the first boot when it was stuck, but nothing I could interpret my self.

I also downloaded the logs after the strange issue of this morning

 

Can you confirm that if I keep a USB recovery key plugged in any port and boot, it will boot on it and update FW directly without I have to presse the Ok button ? This could explain the issue of this morning.

I will PM the person you linked and ask him if ok to get the logs.

Also, is there any parts in the logs I should remove for privacy/security ?

Message 5 of 9
StephenB
Guru

Re: RN524X stuck on "booting..." after flashing 6.10.0


@chopin70 wrote:

Also, is there any parts in the logs I should remove for privacy/security ?


Send the full log zip file.  There is some information leakage (which is why we don't want links posted publicly).  But Netgear does need the full logs to troubleshoot what's going on.

 


@chopin70 wrote:

Can you confirm that if I keep a USB recovery key plugged in any port and boot, it will boot on it and update FW directly without I have to presse the Ok button ?


I haven't needed the USB recovery myself, so I don't have direct experience.  But I think your explanation is likely, and I wouldn't leave the key plugged in.

Message 6 of 9
chopin70
Virtuoso

Re: RN524X stuck on "booting..." after flashing 6.10.0

Thank you again

I just sent the logs

Message 7 of 9
JohnCM_S
NETGEAR Employee Retired

Re: RN524X stuck on "booting..." after flashing 6.10.0

Hi chopin70,

 

Based on the logs, it tried to update the firmware but had a problem, so it did not proceed with the upgrade.

 

[2019/04/14 12:00:04 UTC] Could not update flash device!
[2019/04/14 13:23:55 UTC] Updated from ReadyNASOS 6.9.5 (ReadyNASOS) to 6.10.0 (ReadyNASOS).

 

It is possible that you might have downloaded a bad copy of the firmware.

 

Also, can you confirm that the RN524X actually boots directly in a recovery USB key if it finds one plugged in any port, and even without pressing Ok button on start ? Seems like my unit behaves like that

Yes, this is known and expected behavior. In 6.4, if you have a USB Recovery connected, it will look for the flag automatically and initiate it.

 

Regards,

Message 8 of 9
chopin70
Virtuoso

Re: RN524X stuck on "booting..." after flashing 6.10.0

Thanks for clarifying it.
I suspected a bad fw and I binary compared the version i flashed with a new downloaded version and they were the same. Also, I guess the nas should extract the new fw from the binary package and do a hash check before flashing the packaged binary !
Anyway, first time it happens and I am happy the undocumented recovery mode fixed it without an OS reinstall resetting parts of my config
Message 9 of 9
Top Contributors
Discussion stats
  • 8 replies
  • 3493 views
  • 0 kudos
  • 3 in conversation
Announcements