× NETGEAR will be terminating ReadyCLOUD service by July 1st, 2023. For more details click here.
Orbi WiFi 7 RBE973

ReadyCLOUD - Something is preventing the ReadyNAS from connecting to the ReadyCLOUD server.


ReadyCLOUD - Something is preventing the ReadyNAS from connecting to the ReadyCLOUD server.

Hello, I have a fault with a ReadyNAS 316. The issue is the inability to communicate to the ReadyCLOUD service. 


The history is that this device was connected to a readycloud account under a previous staff member's personal email address. The email on record was changed form the http://readycloud.netgear.com/client web interface using Settings and Change Email. The name was also changed.


At the same time the Cloud ReadyCLOUD setting was removed and re-joined, however the device will no longer join ReadyCLOUD and the accounts are a little bit stuck in limbo.


Repeatable steps:

  1. Turn on ReadyCLOUD by changing switch under the Cloud Tab from Off to On
  2. Enter in new credentials (new email \ password combination as updated earlier)
  3. Click Join
  4. The web interface spins for a bit and then returns error message "Something is preventing the ReadyNAS from connecting to the ReadyCLOUD server. Please reboot your ReadyNAS and try again".
  5. Refrshing the Cloud tab on the NAS Admin UI 
  6. If trying to enable it a second time (immediately after clicking OK on the former error message) then the two Green ticks appear on the Cloud tab (Internet\Cloud) and the ReadyCLOUD pane shows "signed in as xxx" and enabled. 
  7. From the ReadyCloud web interface (Readycloud.netgear.com) the device appears but shows "offline"
  8. Removing the device from the ReadyCloud web interface, then rebooting the ReadyNAS 316 device, and then repeating the steps again 1 through 6 all occur in exactly the same sequence

The NAS has correct and appropriate DNS Resolver and Gateway Settings, the device is fully routable and able to access all routed subnets. It's connected interface has access from the Gateway and other subnets beyond the gateway. So I think it suffices to say it is not a fundamental L3 issue.


There is a possability that the device and communication to the cloud services are blocked at the edge firewall, however I believe this is unlikely due to the fact that this was working perfectly fine prior to changing the email address on file from the former staff member's personal email address to the department's group email address.


We changed the email because we did not want new Cloud User invitations to appear from the former staff member, and from the departmental group instead. I believe something in the configuration of the Cloud facility might be blocking access because of the configuration (e.g. there are left over accounts in the Cloud Users section which can't be removed - because they're cloud accounts and we can't remove them from the cloud because the NAS won't make a connection to readyCloud services).


I have tried numerous combinations of enabling services and rebooting, disabling services, rebooting and enabling and disabling services, rebooting and re-enabling without rebooting and everything inbetween such as creating a new admin account. I have tried changing the cloud account to a completely (something totally different) email address and the same issues still present in the same order with the same error messages.


Does anyone have any advice about how to possibly manually remove the whole IAS\IDM component (e.g. users\groups) via the Unix OS and try again? This seems like a logical and practical next step, however my experience using the Unix OS for this particular Netgear device is limited - I have done this before on QNAP OS.


Thanks in advance


Model: RN31664E|ReadyNAS 316 6-Bay 6x4TB Enterprise Drive
Message 1 of 2

Re: ReadyCLOUD - Something is preventing the ReadyNAS from connecting to the ReadyCLOUD server.

The cloud configuration is in folders under /opt, mainly in XML files.

You could cat the relevant xml files to see if they mention the users you wish to remove.

An editor like vi or vim or nano etc. could be used to edit these.

Local users would show up in /etc/passwd, /etc/shadow etc. There are commands like userdel and deluser to remove users on Linux.

Message 2 of 2
Top Contributors
Discussion stats
  • 1 reply
  • 0 kudos
  • 2 in conversation