× NETGEAR will be terminating ReadyCLOUD service by April 1st, 2023. For more details click here.
Reply

Readynas 6.10.3 beta

Greysquirrel
Aspirant

Readynas 6.10.3 beta

The software link on the readynas page now has a reference to 6.10.3 being the latest software. The NAS alerts me to an update. However, when clicking download on the Nas it fails and when using the download from the netgear site it fails to upload saying unspecified server error.

 

I note this forum doesn't yet have a link to 6.10.3 - is there an issue with it? anyone else managed to update?

Message 1 of 16
Marc_V
NETGEAR Employee Retired

Re: Readynas 6.10.3 beta

@Greysquirrel

 

What model are you trying to update? 6.10.3 has been officially released that is why it is on the Support page.

 

Have you checked your connectivity on the Internet? Can you send me your logs and also a screenshot of the error you are getting so in case this is an issue with the release then we will report it.

 

Regards

 

 

 

Marc_V
NETGEAR Community Team

It's what you do that defines you
NETGEAR Community User Guidelines
Message 2 of 16
Greysquirrel
Aspirant

Re: Readynas 6.10.3 beta

Hi, Thanks - device is RN104.

 

Screenshots to show auto download and manual upload/install error messages.

Message 3 of 16
Marc_V
NETGEAR Employee Retired

Re: Readynas 6.10.3 beta

@Greysquirrel

 

There might be a downtime on the server but when manually installing the FW kindly unzip the file first. Then use the file included on the package (.img) for uploading to the NAS, it should successfully update the ReadyNAS RN104

 

Untitled.png

 

Do note though that there's a warning on the release notes when updating the RN100 series.

 

Warnings:

  • Devices updated with 6.10.3 firmware should not be downgraded to firmware versions before 6.10.0.
  • ReadyNAS 102, 104, and 2120 systems must not be updated directly to 6.10.x from 6.3.x or older firmware. They must first be updated to either 6.2.5 or 6.3.5 then to 6.5.2 and then to 6.10.x.

HTH

 

Regards

Marc_V
NETGEAR Community Team

It's what you do that defines you
NETGEAR Community User Guidelines
Message 4 of 16
StephenB
Guru

Re: Readynas 6.10.3 beta

Try just rebooting the RN104, and see if the NAS completes the install.  Usually it will when you see the "unrecognized server" error.

Message 5 of 16
Greysquirrel
Aspirant

Re: Readynas 6.10.3 beta

Thanks for your help. Unzipping/restarting didn't work. 

Message 6 of 16
StephenB
Guru

Re: Readynas 6.10.3 beta


@Greysquirrel wrote:

Thanks for your help. Unzipping/restarting didn't work. 


What firmware are you currently running?

Message 7 of 16
Greysquirrel
Aspirant

Re: Readynas 6.10.3 beta

6.10.2.

Message 8 of 16
StephenB
Guru

Re: Readynas 6.10.3 beta

Have you downloaded the full log zip file?

Message 9 of 16
givememynamebak
Luminary

Re: Readynas 6.10.3 beta

Mine downloaded, and installed - but now I am stuck at the splash screen with version on it.  After trying in another browser it hung too at the first screen.  After at least a few minutesand staring at the splash screen and several retries to get it with reloading the page, emptying cache etc, it finally came up.  Scariest update so far... 

Message 10 of 16
StephenB
Guru

Re: Readynas 6.10.3 beta


@givememynamebak wrote:

After at least a few minutes and staring at the splash screen and several retries to get it with reloading the page, emptying cache etc, it finally came up.  Scariest update so far... 


My experience was better - I updated yesterday, and had no issues.  

 

If you don't have a backup plan in place, I suggest that you take care of that (RAID protection isn't enough).  And make sure your backup is up to date before you upgrade firmware or manipulate disks.  Backups remove the fear factor for me. Smiley Happy

Message 11 of 16
Greysquirrel
Aspirant

Re: Readynas 6.10.3 beta

I might need to post this in the general forum but i think i have narrowed the problem. Alrhough my NAS was reboting and still allowing me to access admin page/access content on it, having looked at the front of the box today it is stuck 'booting' on 94%. Rebooting again results in it sticking on 84% or 99% booting.

I suspect it is either large log files or a corrupt flash image that is causing the problem? last time something like this happened on an update on the very helpful netgear guys logged in and cleared the files and all was good again. Can anyone assist in this regard again? much appreciated. 

Thanks

Message 12 of 16
Greysquirrel
Aspirant

Re: Readynas 6.10.3 beta

radiar log shows:

 

System
Volume root is 100.00% full
Volume TB3 is inactive
Volume TB32 is inactive
Volume TB2 is inactive
Volume TB6 is inactive
Volume TB3 is inactive
Volume TB32 is inactive
Volume TB2 is inactive
Volume TB6 is inactive
Logs
No errors found.
System Management
2020-03-29 14:07:52: DB (main) schema version: 24 ==> 24
2020-03-29 14:07:52: rndb_create() ==> 3 (555ms)
2020-03-29 14:07:52: Error create table (db)
2020-03-29 14:07:52: dba create failed
2020-03-29 14:07:51: Failed to start ReadyNAS System Daemon.

Model: RN104|ReadyNAS 100 Series 4- Bay
Message 13 of 16
StephenB
Guru

Re: Readynas 6.10.3 beta

So it is a full volume.

 

Paid Netgear support is one option - per-incident support should be about ~$75 USD.

 

If you are familiar with SSH, then you could boot up the NAS in tech support mode, and attempt to clean it out yourself.

Message 14 of 16
Greysquirrel
Aspirant

Re: Readynas 6.10.3 beta

Thanks - i was able to clear some items out and install 6.10.3. I've now run into a different issue but thanks for your help on this one.

 

Message 15 of 16
givememynamebak
Luminary

Re: Readynas 6.10.3 beta

Alerts - Can't sign in with Google (again) with 6.10.3

 

I get an attempt at page : http://192.168.1.100/emailservicecb.html

 

Says "Redirecting please wait..." and it does nothing.  Just hangs, but Frontview (or whatever it's called now) returns an error: 

Model: ReadyNAS 628X
Firmware: 6.10.3
Context: system_panel_support
Error:
1001000022


Logs say: 

Mar 29 12:42:22 ReadyNAS readynasd[5915]: Application docker-cli-rnapp is installed successfully.
Mar 29 12:42:47 ReadyNAS readynasd[5915]: Failed to issue method call: Connection timed out
Mar 29 12:43:13 ReadyNAS readynasd[5915]: NAS_SEND_MSMTP_RUN: Fail. (status=65. error_buf=(null))
Mar 29 12:43:38 ReadyNAS readynasd[5915]: Failed to issue method call: Connection timed out
Mar 29 12:43:38 ReadyNAS readynasd[5915]: Could not send email
Mar 29 12:44:47 ReadyNAS readynasd[5915]: spooler (pid=9828) returns spool_status=1 outbuf=(null) errbuf=(null) is_localapp=1 name=portainer pkgname=portainer
Mar 29 12:44:49 ReadyNAS readynasd[5915]: Failed to send message: No such file or directory
Mar 29 12:44:49 ReadyNAS readynasd[5915]: unit = fvapp-portainer-installer.service
Mar 29 12:44:49 ReadyNAS readynasd[5915]: Cannot install application portainer.
Mar 29 12:45:14 ReadyNAS readynasd[5915]: Failed to issue method call: Activation of com.readynas.OAuth2Vault timed out
Mar 29 12:45:39 ReadyNAS readynasd[5915]: NAS_SEND_MSMTP_RUN: Fail. (status=65. error_buf=(null))
Mar 29 12:46:04 ReadyNAS readynasd[5915]: Failed to issue method call: Connection timed out
Mar 29 12:46:04 ReadyNAS readynasd[5915]: Could not send email

 

system.log:

Mar 29 12:42:21 ReadyNAS apache2[9060]: [ssl:warn] [pid 9060] AH01909: fe80::b2b9:8aff:fe44:bdf0:443:0 server certificate does NOT include an ID which matches the server name
Mar 29 12:42:21 ReadyNAS apache2[9063]: [ssl:warn] [pid 9063] AH01909: fe80::b2b9:8aff:fe44:bdf0:443:0 server certificate does NOT include an ID which matches the server name
Mar 29 12:42:22 ReadyNAS apache_access[9065]: Admin session started from 192.168.1.176
Mar 29 12:42:22 ReadyNAS dbus[5172]: [system] Activating via systemd: service name='com.readynas.OAuth2Vault' unit='dbus-com.readynas.OAuth2Vault.service'
Mar 29 12:42:47 ReadyNAS dbus[5172]: [system] Failed to activate service 'com.readynas.OAuth2Vault': timed out
Mar 29 12:42:48 ReadyNAS dbus[5172]: [system] Activating via systemd: service name='com.readynas.OAuth2Vault' unit='dbus-com.readynas.OAuth2Vault.service'
Mar 29 12:43:13 ReadyNAS dbus[5172]: [system] Failed to activate service 'com.readynas.OAuth2Vault': timed out
Mar 29 12:43:13 ReadyNAS msmtpq[9379]: mail for [ -C /etc/msmtprc <intentionallyremoved>@gmail.com,<intentionallyremoved>@gmail.com --timeout=60 ] : send was unsuccessful ; msmtp exit code was 65
Mar 29 12:43:13 ReadyNAS msmtpq[9381]: enqueued mail as : [ 2020-03-29-12.42.47 ] ( -C /etc/msmtprc <intentionallyremoved>@gmail.com,<intentionallyremoved>@gmail.com --timeout=60 )
Mar 29 12:43:13 ReadyNAS dbus[5172]: [system] Activating via systemd: service name='com.readynas.OAuth2Vault' unit='dbus-com.readynas.OAuth2Vault.service'
Mar 29 12:43:38 ReadyNAS dbus[5172]: [system] Failed to activate service 'com.readynas.OAuth2Vault': timed out
Mar 29 12:44:38 ReadyNAS apache_access[9065]: 192.168.1.176 "POST /admin-cgi/localapp.cgi HTTP/1.1" 200
Mar 29 12:44:48 ReadyNAS apache2[10300]: [ssl:warn] [pid 10300] AH01909: fe80::b2b9:8aff:fe44:bdf0:443:0 server certificate does NOT include an ID which matches the server name
Mar 29 12:44:48 ReadyNAS apache2[10303]: [ssl:warn] [pid 10303] AH01909: fe80::b2b9:8aff:fe44:bdf0:443:0 server certificate does NOT include an ID which matches the server name
Mar 29 12:44:49 ReadyNAS dbus[5172]: [system] Activating via systemd: service name='com.readynas.OAuth2Vault' unit='dbus-com.readynas.OAuth2Vault.service'
Mar 29 12:44:49 ReadyNAS apache_access[10305]: Admin session started from 192.168.1.176
Mar 29 12:45:14 ReadyNAS dbus[5172]: [system] Failed to activate service 'com.readynas.OAuth2Vault': timed out
Mar 29 12:45:14 ReadyNAS dbus[5172]: [system] Activating via systemd: service name='com.readynas.OAuth2Vault' unit='dbus-com.readynas.OAuth2Vault.service'
Mar 29 12:45:39 ReadyNAS dbus[5172]: [system] Failed to activate service 'com.readynas.OAuth2Vault': timed out
Mar 29 12:45:39 ReadyNAS msmtpq[10422]: mail for [ -C /etc/msmtprc <intentionallyremoved>@gmail.com,<intentionallyremoved>@gmail.com --timeout=60 ] : send was unsuccessful ; msmtp exit code was 65
Mar 29 12:45:39 ReadyNAS msmtpq[10424]: enqueued mail as : [ 2020-03-29-12.45.14 ] ( -C /etc/msmtprc <intentionallyremoved>,<intentionallyremoved>@gmail.com --timeout=60 )

 

I'm guessing some of my issues with the hang are related to this unable to send mail via SMTP for alerts...

 

 

 

 

Model: RN628X|ReadyNAS 628X - Ultimate Performance Business Data Storage - 8-Bay
Message 16 of 16
Discussion stats
  • 15 replies
  • 4258 views
  • 0 kudos
  • 4 in conversation
Announcements