Reply

NAS 424 Sharing for external users

OAoffice
Aspirant

NAS 424 Sharing for external users

Hi,

 

We are trying to give access to an external user (not within our company) to a folder that is setup within a shared folder on our network.  We are able to share and access the 'shared folder' but dont want them to have access to the whole of this shared folder - only a sub folder within it.

 

Is there a way we can do this - I cant see how to create a share within the exisiting share, or how to setup external permission for this particular sub folder?

 

To clarify, we have 'Folder A' as a shared folder with lots of subfolders inside - we need them to access 'Sub Folder A' and nothing else.

 

Currently running 6.9.3 firmware

 

Any thoughts?

Thanks

Model: RN424| ReadyNAS 424 4-Bay with up to 40 TB total storage
Message 1 of 3
StephenB
Guru

Re: NAS 424 Sharing for external users


@OAoffice wrote:

 

To clarify, we have 'Folder A' as a shared folder with lots of subfolders inside - we need them to access 'Sub Folder A' and nothing else.

 


The simplest solution is to move sub folder A into its own share.

 

You can also set the file permissions to allow access to subfolder A, but not the other subfolders.  The external user will still see those subfolder names.  Also, file permissions can be changed by your local users (just by right-clicking on the folders).  So it's not as easy to manage as making sub folder A its own share. 

Message 2 of 3
Sandshark
Sensei

Re: NAS 424 Sharing for external users

If access is stricly via Windows and SMB, you can use Windows to specify access within a share (right-click, Properties, Security tab).  But what you are trying to do, give access to only one sub-folder, means you'll have to remove access from everything else.  Setting up a special share for your outside users is a far easier and more secure thing to do.  You can always put a shortcut to the other share in the main one to assist your internal users in accessing it.  A Linux symbolic link would be even better, but I believe you have to go in via SSH to create that.

Message 3 of 3
Discussion stats
  • 2 replies
  • 1186 views
  • 0 kudos
  • 3 in conversation
Announcements