Reply

ReadyCloud Desktop Client Disconnected

JVera
Aspirant

ReadyCloud Desktop Client Disconnected

Hello.

 

We are a SoHo with a ReadyNAS RN102 with firmware 6.10.3. ReadyCloud Desktop Client for Windows version 1.19.

 

Due to COVID-19 I have to setup remote access remotely. I've managed to install the ReadyCloud client on a remote machine with Windows 10 and another with Windows 7 and was able to access the shares (two different users) on Friday 20th. On Monday 23rd, when I tried adding a third user, this user was unable to connect remotely to the NAS (VPN disconnected). I decided to update NAS's firmware from 6.9.3 to 6.10.3 (which accoring to release notes can be done without problems). Now I find that neither of the clients can even see the NAS online. I can access the NAS from the website (http://readycloud.netgear.com) and locally (via a remote desktop connection to a computer in the office)

 

Things I tried:

- Restarted ReadyCLOUD service from admin page (both Internet & Services show as available)

- Rebooted NAS

- Close session and re-login on remote client

 

None of this have worked so far. Any ideas? (is there any way to know if the NetGear VPN is working?). Please remember I don't have physical access to the device.

 

Thanks.

José

Model: RN102|ReadyNAS 100 Series 2- Bay
Message 1 of 14
Marc_V
NETGEAR Employee Retired

Re: ReadyCloud Desktop Client Disconnected

@JVera

 

Welcome to the Community!

 

Have you tried removing the users and then re-inviting them for access? I'm not sure if this is an effect of the current situation but there shouldn't be any issues connecting.

 

Will update you if there's something. For now, kindly try to remove the users and reinvite them.

 

If you have a Firewall/Security software installed kindly disable them first as well.

 

HTH

 

Regards

 

 

Marc_V
NETGEAR Community Team

It's what you do that defines you
NETGEAR Community User Guidelines
Message 2 of 14
JVera
Aspirant

Re: ReadyCloud Desktop Client Disconnected

Thanks @Marc_V for your prompt reply. As I'm testing with myself I have no way (I think) to remove my own account from the ReadyNAS Cloud and add it back in. Any suggestions?

Message 3 of 14
Marc_V
NETGEAR Employee Retired

Re: ReadyCloud Desktop Client Disconnected

@JVera

 

You can do so by leaving ReadyCloud service instead of turning it off. This will remove all users as well. Please make sure that there are no data save on each Home folders since this will be deleted once you leave ReadyCloud.

Let me know if rejoining to the NAS and reinviting the users will be able to help you resolve this issue.

 

Also, there have been reported issues with ReadyCloud service not connecting and engineering is confirming it.

 

We really appreciate your patience.

 

Regards

Marc_V
NETGEAR Community Team

It's what you do that defines you
NETGEAR Community User Guidelines
Message 4 of 14
StephenB
Guru

Re: ReadyCloud Desktop Client Disconnected


@JVera wrote:

 As I'm testing with myself I have no way (I think) to remove my own account from the ReadyNAS Cloud and added back in. Any suggestions?


There is some risk with removing your own ReadyCloud account.  But it is possible using your remote PC connection.  If you can't access the shares, then it would be better to create a new user account and invite that one.  Getting one account to work should be enough, as the users can share it (assuming you aren't using access controls to restrict access).

 

I am wondering if your office router supports OpenVPN.  That would give your users another way to access the SoHo network w/o needing ReadyCloud.  Several higher-end Netgear routers have it built in (including all Nighthawks and Orbis).  It would also give you another way in (in case the office PC goes down).

Message 5 of 14
JVera
Aspirant

Re: ReadyCloud Desktop Client Disconnected

Hi @Marc_V. I've tried this with no luck. Still shows as NAS Disconnected. 

Please let me know about the status of the service when you have a chance. Thanks!

Message 6 of 14
JVera
Aspirant

Re: ReadyCloud Desktop Client Disconnected

Hi @StephenB 

Thank you for your reply. I've have already done this before seeing your post. I was able to do it but did not solve my problem.

We have a Linksys router with OpenVPN support, but to be honest I have no experience whatsoever with this. Can you share some links so I can read about it? Thank you.

Message 7 of 14
JVera
Aspirant

Re: ReadyCloud Desktop Client Disconnected

I was able to establish a connection via OpenVPN but don't know how to access the shares. Do you have any pointers? TIA

Message 8 of 14
StephenB
Guru

Re: ReadyCloud Desktop Client Disconnected


@JVera wrote:

I was able to establish a connection via OpenVPN but don't know how to access the shares. Do you have any pointers? TIA


You'd access them the same way you do when you are in the office.  OpenVPN gives you full access to the office network.

 

You might need to use \\nas-ip-address instead of \\hostname though.

Message 9 of 14
JVera
Aspirant

Re: ReadyCloud Desktop Client Disconnected

Thank you for your assistant @StephenB. I'm able to ping the gateway (Linksys router) but nothing else. I'm trying to access the router's web interface via brower and the nas by IP via Explorer with no luck...

 

ReadyNAS Client still doesn't work also... (I know is unrelated to the OpenVPN stuff)

Message 10 of 14
JVera
Aspirant

Re: ReadyCloud Desktop Client Disconnected

Hi @Marc_V, do you have any confirmation as to whether the system is working or not on you end? Thanks.

Message 11 of 14
JVera
Aspirant

Re: ReadyCloud Desktop Client Disconnected

Hello,

 

I still have no solution to this. The desktop client continues to show "Disconnected". I've tried all the solutions suggested (expect router-VPN stuff that I wasn't able to make it work) and I'm still unable to connect to the SoHo NAS over the Internet. Only Android client and website works.

Is there any other alternatives? Can I setup a secure FTP o similar?

 

Thanks in advance.

Message 12 of 14
StephenB
Guru

Re: ReadyCloud Desktop Client Disconnected


@JVera wrote:

 

I still have no solution to this. The desktop client continues to show "Disconnected".


@Marc_V asked you about internet security software on the PCs earlier - but you didn't respond to that.  If you do have internet security software running, then try disabling it.

 


@JVera wrote:

 

Is there any other alternatives? Can I setup a secure FTP o similar?

 


Yes.  You can enable FTP as a protocol for the NAS shares, and configure the system to force FTPS (not the same as SFTP) in system->settings->FTP.  Authentication mode should be set to "user" of course.

 

You'll need to allocate a range of passive ports - generally I suggest 4 ports per user.  These should be in the range 49152-65535 (which is the designated dynamic port range).  Also I recommend using a custom port for the control connection.  All these ports need to be forwarded to the NAS in the firewall.  For instance, if you have 8 simultaneous users, then you could configure 50001-50064 as passive ports in the NAS, and 50000 as the control port.  Then forward 50000-50064 in the router.  

 

Either WinSCP and FileZilla can be used for access on the PC.  FileZilla is nice because it works with masquerading disabled (allowing it to be used both on the local network and over the internet).  Both are free.

 

With FileZilla, you configure the site using the DNS/DDNS hostname of the router, and choose "Use explicit FTP over TLS if available" - i.e., FTPS.  Of course configure the port for the control connection too.  Also go into Edit->Settings->Transfer and limit the number of concurrent transfers.  I recommend setting that to 3 (one less than the number of passive ports per user).  That gives you some margin on the number of passive ports needed - ensuring that retries and aborted connections don't result in running out of ports.

Message 13 of 14
JVera
Aspirant

Re: ReadyCloud Desktop Client Disconnected


@StephenB wrote:

@JVera wrote:

 

I still have no solution to this. The desktop client continues to show "Disconnected".


@Marc_V asked you about internet security software on the PCs earlier - but you didn't respond to that.  If you do have internet security software running, then try disabling it.

 

Sorry, I did miss that. There were no changes from when the client was working to when it was not (either in the client or the NAS). Despite that, I've checked Windows Firewall and is allowed to work (both Private & Public). There's no other ISS running on the computer.

 


@JVera wrote:

 

Is there any other alternatives? Can I setup a secure FTP o similar?

 


Yes.  You can enable FTP as a protocol for the NAS shares, and configure the system to force FTPS (not the same as SFTP) in system->settings->FTP.  Authentication mode should be set to "user" of course.

 

You'll need to allocate a range of passive ports - generally I suggest 4 ports per user.  These should be in the range 49152-65535 (which is the designated dynamic port range).  Also I recommend using a custom port for the control connection.  All these ports need to be forwarded to the NAS in the firewall.  For instance, if you have 8 simultaneous users, then you could configure 50001-50064 as passive ports in the NAS, and 50000 as the control port.  Then forward 50000-50064 in the router.  

 

Either WinSCP and FileZilla can be used for access on the PC.  FileZilla is nice because it works with masquerading disabled (allowing it to be used both on the local network and over the internet).  Both are free.

 

With FileZilla, you configure the site using the DNS/DDNS hostname of the router, and choose "Use explicit FTP over TLS if available" - i.e., FTPS.  Of course configure the port for the control connection too.  Also go into Edit->Settings->Transfer and limit the number of concurrent transfers.  I recommend setting that to 3 (one less than the number of passive ports per user).  That gives you some margin on the number of passive ports needed - ensuring that retries and aborted connections don't result in running out of ports.

 

Thank for the detailed explanation. I will try to go this route.


 

Message 14 of 14
Top Contributors
Discussion stats
  • 13 replies
  • 1867 views
  • 3 kudos
  • 3 in conversation
Announcements