× NETGEAR will be terminating ReadyCLOUD service by July 1st, 2023. For more details click here.
Orbi WiFi 7 RBE973

Access problems again with ReadyNAS NV+ and Windows 10


Access problems again with ReadyNAS NV+ and Windows 10



Well, it seems I spoke too soon about having solved my access problems between my ReadyNAS NV+ and my Windows 10 Dell XPS15 9570 laptop.  I am no longer able to access either my old 'xps15' share or the newly created 'newxps15' share, although I WAS able to access them for a few days after the last go around.


Things that I know:


  • I can map a drive to all ReadyNAS shares.  To all but two shares, I can copy a test file (random text file) from my laptop to any sub-folder in the share. On the other two ('xps15' and 'newxps15' I can copy a test file to the share itself, but not to any subfolder - I get 'Destination folder access denied'.
  • I can copy a test file to the share itself, but not to any sub-folder.  However, if I create a new folder in the share using the normal windows 10 new->folder menu options, then I can copy my test file to that folder.  I can also create a sub-folder under the new folder, and I can copy my test file to that subfolder as well.  AFAICT, the security properties for all the folders and subfolders are identical.
  • When I had this fixed before, on 26 November, I was able to connect my AJC Active Backup app on my Win 10 laptop to the 'newXPS15' share on the ReadyNAS, and AJC successfully copied over 18,000 files to the 'newXPS15' share
  • Per the previous thread, I changed the security mode on the NAS from 'share' to 'user' (with workgroup NAS1 unchanged from the default) and changed the folder owner/group to admin/nogroup for all shares.

Other possibly relevant data

  • Based on the previous discussion, I created windows credentials pointing at the NAS (\\ using my PC username/password combination, but I don't know if that was necessary or irrelevant.  Looking back on this now, I was (and am) unsure whether this credential should use the PC username/password or the NAS username/password.  I have tried it both ways and AFAICT it doesn't change the above behavior either way.
  • I have another laptop (Dell XPS13) connected to a previously existing share on the NAS using AJCBackup and it is happily cooking along, no problem

This is driving me even more nutso than usual, especially since this ReadyNAS/AJC Backup arrangement has been serving me flawlessly for many years until now.


Any help would be appreciated.



Model: ReadyNAS-NV+|ReadyNAS NV+
Message 1 of 3

Re: Access problems again with ReadyNAS NV+ and Windows 10

Your file permissions appear to have gotten messed up.


Go to the Advanced Options page for the new share configurations, and check the box next to "Set ownership and permission for existing files and folders...".  Also check the box next to "Grant rename and delete privileges to non-owners of files".  Then click Apply in the bottom right.  The system will reset file permissions in the background, there will be a pop-up message when it finishes.


After that go to the CIFS page, and scroll down to "Advanced CIFS permissions". Make sure that "Automatically set permissions on new files and folders" and "Do not allow ACL changes to be more restrictive than this" are both checked.  Also make sure the four rights (folder group rights, folder everyone rights, file group rights, file everyone rights) are all set to read/write.  Click Apply if you change any of those settings.

Message 2 of 3

Re: Access problems again with ReadyNAS NV+ and Windows 10

That seems to have done the trick - THANKS!




Message 3 of 3
Discussion stats
  • 2 replies
  • 0 kudos
  • 2 in conversation