× NETGEAR will be terminating ReadyCLOUD service by April 1st, 2023. For more details click here.
Reply

Direct ELC share access permissions not working

DaveSF12
Follower

Direct ELC share access permissions not working

I have an ELC share configured and syncing with Egnyte. For fast access, we'd like to be able to have direct read/write access to the ELC share on the readyNAS (not going through Egnyte). When I try accessing the //ELC/Shared/ folder some folder permissions aren't right and I'm unable to access folder that I should be. (Screenshot: https://www.evernote.com/shard/s10/sh/65efa6a9-c1bb-440b-93fb-83cab31c3718/a9cdc0e5f7bdcb5e6357872ee16a12ab)

I'm not sure how the ELC share drive permissions should be configured. What should AFS default access setting be? Should egnyte groups be listed below? (https://www.evernote.com/shard/s10/sh/ce71664f-e746-4131-a110-9e838786e57c/1a78a8335d515434448a2f17fb01d315).

- We are trying to access on OSX so using AFP share
- Newly created folders seem to work for the user that created them, but others in the Egnyte group can't access. Previously created folders aren't accessible by anyone.
- I've tried forcing an Egnyte sync
- I've tried resetting to nobody/nogroup as well as admin/admin in the Advanced Settings tab: https://www.evernote.com/shard/s10/sh/e5d63e88-1221-4184-9d0f-ba2ce54eee2d/ce9da3b15d03b96f3b0f2f3df03edef9

I'm happy to complete re-create the ELC share on the ReadyNAS if that resolves the problem.
Message 1 of 2
OOM-9
NETGEAR Expert

Re: Direct ELC share access permissions not working

Do you have the "Advanced CIFS Permissions" enabled? (I would make sure that is enabled"
I would have the nobody/nogroup with the everyone set to read/write. These settings are done on the file level.

I suggest to secure the files/folders on the protocol level to help keep things simple for the file level permissions and have the protocol act as the "gate keeper".
Message 2 of 2
Top Contributors
Discussion stats
  • 1 reply
  • 5055 views
  • 0 kudos
  • 2 in conversation
Announcements