× NETGEAR will be terminating ReadyCLOUD service by July 1st, 2023. For more details click here.
Orbi WiFi 7 RBE973

Re: Subsonic web interface not working


Subsonic web interface not working


I have been having some issues getting the Subsonic v4.7.04 addon to run properly. Initially I had issues installing the addon via FrontView (it would just hang on the "loading" animation). I decided I would install it via SSH which seems to have been successful. However, when I enable the addon from FrontView and click launch or go to localhost:4040 I just a get a "web page not available" message.

I have tried
ps aux | grep -i subsonic

and get
root      4735  0.0  0.0   3840   496 pts/0    S+   21:00   0:00 grep -i subsonic

I did have version 2.0.00 installed previously, I reckon I uninstalled it properly though.

Does anyone have any suggestions on how to get the web interface to come to life?
Message 1 of 10

Re: Subsonic web interface not working

No one able to provide any help?
Message 2 of 10

Re: Subsonic web interface not working

Let me see if I can help...

Please let me know what happens when you execute the following on your ReadyNAS:

Message 3 of 10

Re: Subsonic web interface not working

To PYarr,
Can you let us know your NAS model #, and firmware rev to start out with?

Thanks Marto
Message 4 of 10

Re: Subsonic web interface not working


I've tried to install the version 4.7.04 on my Readynas Ultra 2 which runs Radiator 4.2.22. Unfortunately, I experience the same problem as mentioned above. When I try to launch the subsonic add-on, the web interface doesn't open.

Did anybody find a solution for this issue?
Thanks in advance.
Message 5 of 10

Re: Subsonic web interface not working

I have the exact same issue as geertvdbn with the exactly the same hw and sw. Is there a way to get it running??
Message 6 of 10

Re: Subsonic web interface not working

I am having the same issue after having a HD failure and replacing with new HD and rebuilding ReadyNAS configuration. After activating in the WebUI, if you navigate back to the installed Add-ins, it doesnt show as enabled. I tried manually running the startup script manually but no success. Checked the log and it looks like the startup script references a JRE that wasnt installed by the normal upload/checkin via the WebUi.

zeus-nas:/c/webroot/subsonic# ./subsonic.sh
Started Subsonic [PID 4816, /c/webroot/subsonic/subsonic_sh.log]
zeus-nas:/c/webroot/subsonic# more subsonic_sh.log
./subsonic.sh: line 116: /c/webroot/subsonic/jre1.6.0_20/bin/java: No such file or directory
zeus-nas:/c/webroot/subsonic# ls -l
total 30740
-rw-r--r-- 1 root root 3072 2013-06-16 14:29 Getting Started.html
-rw-r--r-- 1 root root 35819 2013-06-16 14:29 LICENSE.TXT
-rw-r--r-- 1 root root 540 2013-06-16 14:29 README.TXT
-rwxr-xr-x 1 root root 1081 2013-06-16 14:29 subsonic.bat
-rw-r--r-- 1 root root 10801885 2013-06-16 14:29 subsonic-booter-jar-with-dependencies.jar
-rwxr-xr-x 1 root root 5105 2013-06-16 14:29 subsonic.sh
-rw-r--r-- 1 root root 93 2013-06-16 17:25 subsonic_sh.log
-rw-r--r-- 1 root root 20603945 2013-06-16 14:29 subsonic.war
drwxr-xr-x 2 root root 4096 2013-06-16 14:29 transcode

Removed subsonic in the WebUI and then attempted reinstall. It verified the file fine but then when installing it hangs (waited over 30 mins). WebUI essentially unresponsive without reloading from address bar. Now it shows as installed but not enabled. I remember this same behavior when initially trying the install but disregarded because I was doing alot of over things when doing that install (large data transfers, setting mounts, etc) and chalked it up to that. I tried enabling but same behavior. it acts like the install is probably getting hungup putting the java down after it puts down the subsonic files (just a guess).

I was able to go to the oracle site and download the missing jre and installed it to the location referenced aboved and was able to get subsonic started and it is usable. Only problem is the WebUI still shows it as disabled, so I am assuming its not going to start on its own the next time the device boots. Also, its saying on the devices that server is unlicensed and 30 days left. Anybody got any information on that?
Message 7 of 10

Re: Subsonic web interface not working

Im RAIDiator 4.2.22. Ultra 2 also. I noticed the following error in the "logs" section of the WebUI "Invalid checksum detected in the update file. Update aborted"
Message 8 of 10

Re: Subsonic web interface not working

The 4.7.4 version of the addon doesn't seem to contain the jetty web server or JAVA components required for Subsonic to run. Either that, or they simply don't get installed. I don't know how this happened but if you compare the file sizes of the 4.7.4 version and the 2.0.0 version, the later one is roughly half the size. To get the latest version to work, install the 2.0.0 version, and install the 4.7.4 version OVER THE TOP without uninstalling the old one.
Message 9 of 10

Re: Subsonic web interface not working

Additional Note: If anyone here having done the Manual Java Update is having issues with Subsonic shutting itself down and only "minor" errors appearing in the log (incorrect format art, etc.), then you might want to perform the above procedure with EJRE 1.6.0 (Update 38) instead depending on the Subsonic version installed.

Seems currently Subsonic 4.7 and 4.8 are not fully compatible with Java 1.7.0.
Message 10 of 10
Top Contributors
Discussion stats
  • 9 replies
  • 0 kudos
  • 7 in conversation