Reply

Update file is not valid for this architecture?

EkDor
Aspirant

Update file is not valid for this architecture?

Earlier this year I bought a ReadyNAS NV+ (silver body, 4 bays all with 2tb, scheme 5,0).
It's running RAIDiator version 4.1.9 build 1.00a043 (Orange and Blue FrontView web interface).

Today I purchased the following.

- Python2.7_2.7.3-rnsparc-0.5.1
- SABnzbd_0.6.15-rnsparc-0.7.0
- SickBeard_0.485.1-rnsparc-0.8.1

Went to System/update/local. Clicked "Choose File". Selected "Python2.7_2.7.3-rnsparc-0.5.1" add-on (bin file). Clicked "Upload and verify image". Clicked "OK". Got this error message, "Update file is not valid for this architecture".

What's going on, has the processor been changed? Have I misunderstood the installation process?

Bellow are some possibly relevant information.

- I have done what I can to verify the processor, but there appears to be nothing in FrontView or RAIDar that verifies this.
- I don't have SSH installed because I read somewhere that it invalidates warranty.
- I got this same error some time back when I tried manually updating RAIDiator.
- I just tried some other SPARC add-ons and I always get this message.
- I have no third party add-ons installed.
- I have the "ReadyDLNA" streaming service and "TimeMachine support" turned on.
- I haven't tried any from the other architecture because I don't want to waste more money and I'm sure it is SPARC.

Thanks in advance for any help.
Message 1 of 3

Accepted Solutions
EkDor
Aspirant

Problem Solved

A tech at ReadyNASXtras (MDGM) solved this for me. It turns out that at somepoint I attempted to install PLEX which isn't available for SPARC. It failed but was not removed. There was no FrontView evidence (apart from this error) of the residue. The failed install was confusing the update script/s. The tech cleaned it up and all works properly now.

Problem Solved. Thanks MDGM.

P.S. I was just informed by MDGM that a reinstall of the RAIDiator firmware would have also fixed this.

Cheers,. EkDor

View solution in original post

Message 2 of 3

All Replies
EkDor
Aspirant

Problem Solved

A tech at ReadyNASXtras (MDGM) solved this for me. It turns out that at somepoint I attempted to install PLEX which isn't available for SPARC. It failed but was not removed. There was no FrontView evidence (apart from this error) of the residue. The failed install was confusing the update script/s. The tech cleaned it up and all works properly now.

Problem Solved. Thanks MDGM.

P.S. I was just informed by MDGM that a reinstall of the RAIDiator firmware would have also fixed this.

Cheers,. EkDor
Message 2 of 3
mdgm-ntgr
NETGEAR Employee Retired

Re: Problem Solved

Split derekca's post into a new thread: https://community.netgear.com/t5/Legacy-NETGEAR-and-Partners-Add/Update-file-is-not-valid-for-this-a...

Please don't revive long dead threads, but instead link to them if needed.

Message 3 of 3
Top Contributors
Discussion stats
  • 2 replies
  • 4843 views
  • 0 kudos
  • 2 in conversation
Announcements