Reply
Occasional Contributor
Posts: 11
Registered: ‎2010-08-23

Setting up an iSCSI target on RHEL5 (Redhat)

Hi,

I am trying to set-up an i-SCSI target in RHEL5. I have set-up the target on the Ultra 4. I can stop and start it

[root@Linux1 ~]# service iscsi stop
Logging out of session [sid: 1, target: iqn.2011-08.nas-F8-FD-E0Smiley Surprisedrafs1, portal: 192.168.168.168,3260]
Logout of [sid: 1, target: iqn.2011-08.nas-F8-FD-E0Smiley Surprisedrafs1, portal: 192.168.168.168,3260] successful.
Stopping iSCSI daemon:
[root@Linux1 ~]# service iscsi start
iscsid is stopped
Starting iSCSI daemon: [ OK ]
[ OK ]
Setting up iSCSI targets: Logging in to [iface: default, target: iqn.2011-08.nas-F8-FD-E0Smiley Surprisedrafs1, portal: 192.168.168.168,3260]
Login to [iface: default, target: iqn.2011-08.nas-F8-FD-E0Smiley Surprisedrafs1, portal: 192.168.168.168,3260] successful.
[ OK ]

I am then trying to get a consistent device name that I can reference like /dev/iscsi/orafs/part that persists with the same name through reboots. However when I set-up my udev script to achieve this, I get completley lost. I am using Connecting to an iSCSI Target with Open-iSCSI Initiator using Linux by Jeff Hunter. These instructions work perfectly with Openfiler and I am hoping to adjust them for my ReadyNas.

I was hoping to get a consistent device name such as /dev/iscsi/orafs1/part that I could fdisk. However I am not gettting this and cannot proceed.

Any help greatly appreciated.

Kind regards.
Occasional Contributor
Posts: 11
Registered: ‎2010-08-23

Re: Setting up an iSCSI target on RHEL5 (Redhat)

Discussion Stats
  • 1 reply
  • 176 views
  • 0 kudos
  • 1 in conversation
Top Contributors