× Introducing the Orbi 970 Series Mesh System with WiFi 7 technology. For more information visit the NETGEAR Press Room.
Orbi WiFi 7 RBE973
Reply

Netgear R6400 Slow Wired Speed Issues

BigNutBean
Aspirant

Netgear R6400 Slow Wired Speed Issues

Good afternoon folks, I'm new to the forums and new to home networking in general. I tried searching the forums and online for solutions but I got mixed results and I'm not sure how to proceed forward.

 

Problem: I'm not getting the advertised speed from my ISP while using my router. Conducting a speed test, I only get a maximum of 95 Mbps upload and download. Connecting directly to my Modem, I get the full advertised speed both for my Laptop and PC.

 

I have tried doing a factory reset on the Router and then updating its firmware to the latest version but it still shows 95 Mbps up and down. I made sure in the Nighthawk App that Traffic Meter is turned off. I logged into my Router and went into Advance Settings and made sure that Upstream and Downstream QoS in turned off/unchecked. 

 

ISP Plan: Symmetrical internet 600/600 Mbps

Modem: Nokia ONT XS-010X-Q

Router: R6400

Router Firmware: V1.0.1.78_1.0.50

 

Thank you!

Note: All test were performed using a WIRED connection unless stated otherwise.

Message 1 of 5

Re: Netgear R6400 Slow Wired Speed Issues

The first refrain you will here is "Check the cables".

 

 

 

 

Message 2 of 5
plemans
Guru

Re: Netgear R6400 Slow Wired Speed Issues

You can check and see what link speed its connecting at

https://kb.netgear.com/24222/How-do-I-display-Internet-port-statistics-on-my-Nighthawk-router

 

if its 10/100mbps, then try swapping cables

Message 3 of 5
BigNutBean
Aspirant

Re: Netgear R6400 Slow Wired Speed Issues

Hello! I have checked my cables and ran them through a speed test and everything came out looking normal except when plugged into the R6400 Router as pictured below. I do not get my full speed.

 

Untitled Diagram.drawio (1).png

 _______________________________________________________________________________________________

When I ran the test as pictured below, I get my full internet speed.

 

Untitled Diagram.drawio (2).png

 _______________________________________________________________________________________________

 

I followed your instruction on checking the link speed and it shows 10/100mbps at the WAN Port. I unfortunately do not have another ethernet cable and will have to wait for another cable to arrive to test. What I don't understand is if I'm getting full speed connecting directly to the Modem, my cables should be fine and eliminated as the suspect?

 

Thank you! 

 

Message 4 of 5
plemans
Guru

Re: Netgear R6400 Slow Wired Speed Issues

some devices aren't as tolerant as others of sketcy connections. Routers tend to be less tolerant as if they mess up, the whole system messes up. Versus if a laptops connection is sketchy, its only effecting itself. 

but it could be the router. That's always a chance. A bent/dirty, or bad port could be causing it. I'm not ruling that out. 

 

Message 5 of 5
Top Contributors
Discussion stats
  • 4 replies
  • 340 views
  • 0 kudos
  • 3 in conversation
Announcements

Orbi WiFi 7