× NETGEAR is aware of a growing number of phone and online scams. To learn how to stay safe click here.
× Introducing the new Orbi 770 Series Mesh System. To learn more click here.
Orbi WiFi 7 RBE973
Reply

Re: Orbi RBK50 Sonos Connect Amp Gen 2 not allowing Device to connect

Chew14
Aspirant

Orbi RBK50 Sonos Connect Amp Gen 2 not allowing Device to connect

Looking for help.  I have had my orbi for a few years and bought a Sonos Connect Amp with speakers. System worked fine about a year and half ago but since I have moved I can't get the Sonos connected again.  I can get it connect and shows in my devices when I connect with Ethernet and can see it for wireless but when I try to use the App it wont connect to my PD (Apple phone or iPad).  I have read several forums but all sound like they worked before latest update.  Help

Message 1 of 3
olympos1625
NETGEAR Employee Retired

Re: Orbi RBK50 Sonos Connect Amp Gen 2 not allowing Device to connect

Hi Chew14,

 

Welcome to NETGEAR Community!

 

Thank you for reaching out. We are sorry to hear about your experience with the product. May we know when did you update the firmware? When did the issue start? What is the current firmware of the router and satellite? When did you move?

 

Please do not hesitate to let me know if you need further assistance. 

 

Regards,

 

Oliver

Community Team

Message 2 of 3
Chew14
Aspirant

Re: Orbi RBK50 Sonos Connect Amp Gen 2 not allowing Device to connect

Hello I am unsure of when the update occurred as I have my updates done automatically. We move a little over a 1 1/2 ago but I had other things I needed done around house before I could install the Sonos system. I have been trying for last 2 weeks to get the Sonos connected now. Firmware is v2.7.3.22

Thank you for any help you can provide beyond frustrated at this time
Message 3 of 3
Top Contributors
Discussion stats
  • 2 replies
  • 798 views
  • 0 kudos
  • 2 in conversation
Announcements

Orbi 770 Series