Reply
newt_uk
Aspirant

GS724TS boot code and firmware upgrade gone wrong.

I have a GS724TS switch that I wanted to repurpose, so cleaned out with an air duster, and attempted to do any firmware updates.  The switch was on an early version 1 firmware and early boot code. (I can't remember exact;ly what versions).

Using the Smart Wizard Discovery tool, I managed to upgrade to the interim image: GS700TP_V1.0.0.inter.ros.

I can't recall if the boot code was already on version 1.0.0.4, or whether I managed to upgrade the boot code to1.0.0.4.via the discovery tool. I had a few "illegal file" errors when trying some firmware updates, and can't recall if a boot code updaate worked from the discovery tool.

After the interim firmware update, the next step I did was to wait for the switch to reboot and then upgraded the firmware from interim to: GS700TP_V3.0.0.21.ros

Another reboot and I tried several times to get the TFTP boot code to update from 1004 to 1005.

The web interface was basically unusable. It wouold load inconsistently and required several refreshes / reloads, emptying of and browser cache, more reloads, also tried compatibility mode in IE. I tried from two Windows 10 laptops with  Edge, Chrome, Internet Explorer and Opera.  All browsers on both laptops had the same inconsisencies, where the switches web interface would only occasionally fully load, presenting all buttons and functionality.

Having setup a TFTP service and created an allow rule in the Windows 10 firewall, I coulld not get the switch to connect over TFTP.  I could connect from the other laptop to the TFTP service, and noticed connection strings in the TFTP log file.

I could not get a connection at all from the switch, despite trying for around two hours.

Using the Smart Wizard Discovery tool, I tried taking the switch to the next firmware release to see if the web interface became any more reliable.

That firmware upgrade to: GS7xxTP-V305.ros completed successfully and the switch automatically rebooted.

Since then it has been unresponsive.

It powers up, and with the LAN cable in port 1, the port 1 LED lights up solid green. It does not flash and the discovery tool does not discover anything.

Each upgrade I did tonight ended in a similar way, and required a factory reset to get the switch to boot properly.

The same factory reset is not working this time.

I have tried that, plus normal reset, also holding in the factory reset while powering up, and other combinations of buttron holding and resetting and powering on.

I am now thinking that this is bricked.

Unless someone has other ideas and methods of recovery?

Any advice welcomed.

Thanks.

Model: GS724TS|ProSafe Gigabit Stackable Smart switch|EOL
Message 1 of 3
JohnC_V
NETGEAR Moderator

Re: GS724TS boot code and firmware upgrade gone wrong.

@newt_uk,

 

Welcome to our community! Smiley Happy

 

It seems that this switch is already bricked after failing the firmware upgrade. It would be best if you will contact support in order for us to do a hardware check. If the device is still under warranty, an online replacement will be provided.

 

Regards,

 

John

NETGEAR Community Team

Message 2 of 3
newt_uk
Aspirant

Re: GS724TS boot code and firmware upgrade gone wrong.

Thanks John,

 

I called support and they helped me out with a product replacement, even though I can't find the proof of purchase.

I just have to pay for shipping.

Excellent service!

 

Regards

Martin

Model: GS724TS|ProSafe Gigabit Stackable Smart switch|EOL
Message 3 of 3
Top Contributors
Discussion stats
  • 2 replies
  • 70 views
  • 0 kudos
  • 2 in conversation
Announcements