Reply

Re: GS724TV4 can't get bandwidth aggregation by LAG?

sparkf1
Tutor

GS724TV4 can't get bandwidth aggregation by LAG?

Hi, I have two servers and one gs724tv4 switch, both server have two 1Gb NICs installed and I'd like to do a bandwidth aggregation by using LAG feature.

Server 1 connects to switch port 1 and port 2 and binded to ch1 with LACP.

Server 2 connects to switch port 3 and port 4 and binded to ch2 with LACP.

The OS is Windows 2012R2 and enabled build-in NIC Teaming feature with LACP for both servers.

 

 

When I do a file copy testing, I found the actual transfer speed has not increased to 2Gb but only 1Gb (110MB/s), I'm sure there is no bottleneck from other components like HDD. I've updated firmware to latest version 6.3.1.11 but also not works.

Anyone could help on this case? Thanks.

 

 

Model: gs724tv4

Boot Version: B1.0.0.4

Firmware: 6.3.1.11

Model: GS724Tv4|ProSafe 24 ports Gigabit Smart switch
Message 1 of 11
sparkf1
Tutor

Re: GS724TV4 can't get bandwidth aggregation by LAG?

BTW, I did a test by replaceing gs724tv4 with a gs108tv2 switch, and keep all other setting has no changed, the bandwidth aggregation is working fine now, so I suppose there is a issue/bug from gs724tv4 switch. Can anyone confirm this?

Message 2 of 11
DaneA
NETGEAR Moderator

Re: GS724TV4 can't get bandwidth aggregation by LAG?

Hi sparkf1,

 

Welcome to the community! Smiley Happy

 

So far there are no issue(s) logged about LAG for the GS724Tv4.  Did you perform a factory reset on the GS724Tv4 after upgrading the firmware to v6.3.1.11?  It is recommended to reset the switch to factory default settings after a successful firmware upgrade.  Then, check if same problem will occur.

 

Regards,

 

DaneA

NETGEAR Community Team

Message 3 of 11
sparkf1
Tutor

Re: GS724TV4 can't get bandwidth aggregation by LAG?

Hi DaneA,

 

Yes, I did a factory reset after each firmware upgrade but no help, all settings are factory default except LAG configuration.

Message 4 of 11
DaneA
NETGEAR Moderator

Re: GS724TV4 can't get bandwidth aggregation by LAG?

Hi sparkf1,

 

When the 2 Windows 2012 R2 servers are both connected via a LAG to the GS724Tv4, is the LAG state "Link Down" or "Link Up?"

 

I suggest doing a test using Jperf.  Kindly do a Jperf test while the 2 Windows 2012 R2 servers are both connected via a LAG to the GS724Tv4 as well as with the GS108Tv2 for comparison.  Make sure to save the test results and get screenshots of it.  

 

Use these links below on how to measure network performance using Jperf:

 

Measuring Network Performance - Jperf

 

Troubleshooting client speed and traffic shaping using Jperf

 

If ever the LAG setup on the GS724Tv4 has failed the Jperf test then I advise you to open an online case with NETGEAR Support at anytime.  State your concern and attach the Jperf test results on the online case you have opened to be reviewed by the support team.  

 

 

Regards,

 

DaneA

NETGEAR Community Team

Message 5 of 11
sparkf1
Tutor

Re: GS724TV4 can't get bandwidth aggregation by LAG?

Hi DaneA,

 

I've finished Jperf testing and the result is same as Windows File Copying, it shows the LAG transfer bandwidth of GS724TV4 only half of GS108TV2, please check the below link for testing screenshot, and I also submitted a support ticket #26811494 to NETGEAR Support.

 

ScreenShot Link: https://onedrive.live.com/redir?resid=1543A8A4A6FA6DF7!1181968&authkey=!AOi-9obOWVx0pbw&ithint=folde...

Message 6 of 11
DaneA
NETGEAR Moderator

Re: GS724TV4 can't get bandwidth aggregation by LAG?

Hi sparkf1,

 

Kindly wait for the response of NETGEAR Support team to the online case you have opened for further assistance.  

 

 

Regards,

 

DaneA

NETGEAR Community Team

Message 7 of 11
sparkf1
Tutor

Re: GS724TV4 can't get bandwidth aggregation by LAG?

It has been a long days but thing still has not any improvement. I would say that the support engineer's skill and responsibility is so poor, they couldn't resolve my case and even don't understand what is it, they have totally no idea about what is load balance and what kind of mechanism has been used in GS724TV4 product. Most of replies from support guys are bull **bleep**s, as they were always asking the question that had been answered in my previous sent, and the worst thing is they had closed my ticket and wasn't give me any update. Is that a way to meeting the SLA of their job?

 

Related ticket Number:

#26849248
#26811494

 

How can I escalate?

Message 8 of 11
DaneA
NETGEAR Moderator

Re: GS724TV4 can't get bandwidth aggregation by LAG?

Hi sparkf1,

 

Thanks for keeping us posted.  The NETGEAR Support Tech assigned on your online case will be the one to escalate the online case to the engineering team.

 

 

Regards,

 

DaneA

NETGEAR Community Team

 

Message 9 of 11
DaneA
NETGEAR Moderator

Re: GS724TV4 can't get bandwidth aggregation by LAG?

Hi sparkf1,

 

Any updates on the online case you have opened?

 

 

Regards,

 

DaneA

NETGEAR Community Team

Message 10 of 11
omicron_persei8
Luminary

Re: GS724TV4 can't get bandwidth aggregation by LAG?

Can you try with Static LAG instead of LACP?
Static LAG is round-robin, so it uses one cable after the other.
LACP LAG will calculate a hash and use one cable or the other based on the result.
Depending on the level of hash you selected, if the source and the destination are the always the same (exactly like during your transfer test), only one cable will actually be used!
Message 11 of 11
Top Contributors
Discussion stats
  • 10 replies
  • 4904 views
  • 1 kudo
  • 3 in conversation
Announcements