Reply
Highlighted
Aspirant

How to let all multicast traffic through all ports with the GS110TP

Hi,

I'm using this (POE) switch in a small office environment with little traffic so bandwidth savings is not much of an issue and would rather configure all ports the same to make things easier to patch.

We have KNX routers connected to this switch (home automation routers coupling different automation buses over ethernet) and they seem to make use of multicast to communicate to eachother (and it represents very little bandwidth in the gigabit ethernet world we live in).

 

Does anyone knows how to let all multicast trafic through all ports?

I saw there is a "video" setting supposed to make things easy for VLAN 3, but I tried changing the VLAN of all ports to 3 without success (they all stay in vlan 1). I must say I'm starting to feel there is either something wrong with me or the switch.

 

Thanks for your help

Model: GS110TP|ProSAFE 8-port Gigabit PoE Smart Switch
Message 1 of 6

Accepted Solutions
Highlighted
NETGEAR Expert

Re: How to let all multicast traffic through all ports with the GS110TP

Hi Martmel

 

Disabling IGMP Snooping globally is the right way: by doing that we ensure any kind of Multicast traffic is flooded to all ports.

 

Unfortunately your screenshot is lowres and I can't really figure if this is done correctly on your switch. Do you have VLANs? 

 

At this point I think we need to check if you disable all together:

 

Switching-->Multicast-->IGMP Snooping-->IGMP Snooping Configuration

  • Auto-Video Configuration
  • IGMP Snooping Status
  • Validate IGMP IP Header
  • Block Unknown Multicast Addresses

Switching-->Multicast-->IGMP Snooping-->IGMP Snooping Interface Configuration

  • Click All for all ports and all LAGs
  • Ensure Admin Mode is disabled for all ports

 

For all that please refer to the GS110TP Software Administration Manual page 41, then page 43, and then page 44-45.

 

Once checked please save the configuration and reboot the switch. Now we made sure there is no more Multicast filtering at Layer 2 in the switch. Your KNX routers should be able to send and receive Multicast traffic without being IGMP compliant. Please note this is very unsual use case though. At Layer 2 Multicast devices are expected to send and receive IGMP messages. If it still doesn't work, we will need to learn more about your KNX devices, and check if they are really sending Multicast traffic - and if they are succesfully working with other type of Ethernet switch - Unmanaged for instance. 

 

It makes me realize it might be broadcast traffic instead? Sanity check: please go to Security-->Traffic Control, and then click the Storm Control link on the left menu and verify Storm Control is disabled all the way (no filtering at all - please see page 174 in the manual).

Laurent Masia
NETGEAR Senior Product Line Manager, Managed Switches

View solution in original post

Message 6 of 6

All Replies
Highlighted
NETGEAR Moderator

Re: How to let all multicast traffic through all ports with the GS110TP

Hi Martmel,

 

Welcome to the community! Smiley Happy 

 

Let me share these articles below and use it as guides:

 

How do I enable Internet Group Management Protocol (IGMP) querier using the web interface on my ProS...

 

Configuring IGMP Snooping on the Netgear GS724Tv4

 

 

Regards,

 

DaneA

NETGEAR Community Team

Message 2 of 6
Highlighted
Aspirant

Re: How to let all multicast traffic through all ports with the GS110TP

Hello DaneA,

 

Thanks for the welcome, quick reply and links

I spent a little while reading the linked articles about configuring IGMP and as I want to disable all the smart multicast filtering, I disabled IGMP alltogether.

 

It however does not seem to make a difference if I enable or disable it.

Is there a simple switch that can be used to let all multicast through like on an unmanaged switch?

 

Thanks!

Martin

Message 3 of 6
Highlighted
Aspirant

Re: How to let all multicast traffic through all ports with the GS110TP

No matter how hard I try it, even if I disable Igmp, multicast is not forwarded to the other ports:

Screenshot from 2017-01-28 22:37:13.pngScreenshot from 2017-01-28 22:37:35.png

 

Is this switch so smart it can't be dumb?

Thanks for your help !

Martin

Message 4 of 6
Highlighted
Aspirant

Re: How to let all multicast traffic through all ports with the GS110TP

Can't anyone help me?

Message 5 of 6
Highlighted
NETGEAR Expert

Re: How to let all multicast traffic through all ports with the GS110TP

Hi Martmel

 

Disabling IGMP Snooping globally is the right way: by doing that we ensure any kind of Multicast traffic is flooded to all ports.

 

Unfortunately your screenshot is lowres and I can't really figure if this is done correctly on your switch. Do you have VLANs? 

 

At this point I think we need to check if you disable all together:

 

Switching-->Multicast-->IGMP Snooping-->IGMP Snooping Configuration

  • Auto-Video Configuration
  • IGMP Snooping Status
  • Validate IGMP IP Header
  • Block Unknown Multicast Addresses

Switching-->Multicast-->IGMP Snooping-->IGMP Snooping Interface Configuration

  • Click All for all ports and all LAGs
  • Ensure Admin Mode is disabled for all ports

 

For all that please refer to the GS110TP Software Administration Manual page 41, then page 43, and then page 44-45.

 

Once checked please save the configuration and reboot the switch. Now we made sure there is no more Multicast filtering at Layer 2 in the switch. Your KNX routers should be able to send and receive Multicast traffic without being IGMP compliant. Please note this is very unsual use case though. At Layer 2 Multicast devices are expected to send and receive IGMP messages. If it still doesn't work, we will need to learn more about your KNX devices, and check if they are really sending Multicast traffic - and if they are succesfully working with other type of Ethernet switch - Unmanaged for instance. 

 

It makes me realize it might be broadcast traffic instead? Sanity check: please go to Security-->Traffic Control, and then click the Storm Control link on the left menu and verify Storm Control is disabled all the way (no filtering at all - please see page 174 in the manual).

Laurent Masia
NETGEAR Senior Product Line Manager, Managed Switches

View solution in original post

Message 6 of 6
Top Contributors
Discussion stats
  • 5 replies
  • 15036 views
  • 1 kudo
  • 3 in conversation
Announcements