× Get weekly deals on business products. Shop Ethernet Switches and more In the NETGEAR Store
Discussion stats
  • 6 replies
  • 731 views
  • 0 kudos
  • 3 in conversation
Announcements

Top Contributors
Reply
Highlighted
Aspirant

XS512EM password login issue after firmware upgrade to 1.0.0.9

Hi,

My switch is only 6 months old.   When purchased and put to use, I upgraded to latest firmware at the time which was 1.0.0.8 and have had no issues with it so far.   After upgrading this switch from firmware 1.0.0.8 to 1.0.0.9 recently published with some security improvements, I can no longer log into admin function for this switch.

I had changed default password months ago when I last upgraded to 1.0.0.8 and was able to log in successfully to perform firmware upgrade now to the latest version noted above.   Switch appears to be functioning normally otherwise for network use.   

 

I was forced to do a factory reset on this latest firmware so I could log in again using default password.    I tried to change it again after that and it accepted my password change, was able to save it, and save to config file, however as soon as I do this I can no longer log in again (neither my password or the default one work after I change password).   I did this 3 times with factory reset followed by password change to ensure I had not made a mistake and the result was the same.   For now I have to either leave the switch on default password, or revert back to previous firmware.    Very annoying to say the least and not great for security.

 

Anyone run into this yet?

Model: XS512EM|12 Port 10-Gigabit/Multi-Gigabit Ethernet Smart Managed Plus Switch with 2 SFP+ Ports
Message 1 of 7
Highlighted
Guru

Re: XS512EM password login issue after firmware upgrade to 1.0.0.9

Hi,

 

Trouble is I can't locate the PSV-2018-0538, PSV-2018-0542, and PSV-2018-0612 on the Netgear Security Advisories page. Had no problems with the custom password on the very similar XS724EM after the update to 1.0.0.9, but vaguely remember there were some changes in the parsing of the password on the Web UI.

 

Appeared the password problem only on the Web UI, or also on the Plus Config Utility? 

 

Using any "special" characters in the password beyond of A..Z, a..z, 0..9, ...?

 

What Web browser is involved?

PS. A moderator is kindly asked to move this thread to the appropriate Smart / Plus / Click Switches community section please  @DaneA 

Message 2 of 7
Highlighted
Aspirant

Re: XS512EM password login issue after firmware upgrade to 1.0.0.9

Thanks for quick reply.

 

I'm using only Webgui interface using latest version of Chrome browser V75 on Windows 10 Pro 1903.   Password I was using is same as prior release with combination of capital letters, numbers and 1 special character.   When I change from default to this password, it is accepted and saved, however I can't then log back in afterwards.   Hope that helps.      

Model: XS512EM|12 Port 10-Gigabit/Multi-Gigabit Ethernet Smart Managed Plus Switch with 2 SFP+ Ports
Message 3 of 7
Highlighted
Guru

Re: XS512EM password login issue after firmware upgrade to 1.0.0.9

Please tell us more about that special character, and it's position in the password string.
Message 4 of 7
Highlighted
Aspirant

Re: XS512EM password login issue after firmware upgrade to 1.0.0.9

The special character is a "#" and is at the end of the password.     Again, this worked fine on previous release.

 

BTW, the previous comment about moving this thread to a more appropriate switch catergory makes sense.  It wasn't on the drop-down list when I created it or I would have done that.   Thanks.    

Model: XS512EM|12 Port 10-Gigabit/Multi-Gigabit Ethernet Smart Managed Plus Switch with 2 SFP+ Ports
Message 5 of 7
Highlighted
Guru

Re: XS512EM password login issue after firmware upgrade to 1.0.0.9

OK, will try some similar password on my XS724EM early next week. The # and similar chars form the lower ASCII charset should work flawless if allowed - was concerned it's one that might be encoded in a different way (need to do some more testing, too). Thank you for sharing with the community as we're always keen to help Netgear making the products better.

 

Don't worry, the Netgear moderators are active more during the common business hours, so the moving will take some more days, too. 

Message 6 of 7
Highlighted
Aspirant
Aspirant

Re: XS512EM password login issue after firmware upgrade to 1.0.0.9

I also have upgraded an XS512EM switch to 1.0.0.9, with the same result. No one seems to have responded with a solution to this. The last reply was towards the end of June. It is now lat(ish) July.

 

Would somebody kindly respond to this thread with a solution, or isn't there one?

 

Thank you,

 

Paul

Model: XS512EM|12 Port 10-Gigabit/Multi-Gigabit Ethernet Smart Managed Plus Switch with 2 SFP+ Ports
Message 7 of 7