Reply

Re-flash your NetGear Stora

robyb
Aspirant

Re-flash your NetGear Stora

Hey guys,

This solution has already been passed around this forum, but Ill make it easy to find.

Before re-flashing your Stora:

-Run SelfCheck update.
-Hard Reset your Stora.

If these solutions do not resolve the problem and the problem is related to:

Failing updates
Missing Web UI
Error messages within the Web UI
Media Servers
Samba acces

Version after reflash: 2.5.1

Re-flash your Stora:

Procedure


• To put the device into recovery mode first power off the device.
• Push and release the power button, time 15 seconds(exactly), then press and hold the reset button while bootup continues.
• The bootup process will take approximately 30 seconds and the blue LED will be blinking during that period.
• As soon as the recovery mechanism kicks in, the blue light turns off and HDDLED1 will turn orange. The reset button can be released at this point.
• Then the device will request a DHCP lease and try to get an IP
o If an IP is obtained, HDDLED2 will also turn orange for 1 second.
o If no IP is assigned the following pattern will be shown on the leds and the recovery mechanism will stop.
Power LED Off -> HDDLED1 and HDDLED2 will blink 3 times together -> All LEDs off
• Once network is up, the download and burn process will begin. During the download procedure the LED behaviour is:
Power LED Off -> HDDLED1 and HDDLED2 will turn on and off in turns
• The download and burn will take around 4-5 mins with a fast connection speed.
• Once the download and burn is done:
o If the burn is successful, all LEDs will turn on for 5 seconds and then the device will reboot normally
o If the burn fails the LED behaviour will stay as follows and the recovery mechanism will stop
Power LED On -> HDDLED1 and HDDLED2 will blink together

Once this is completed you will be able to re-register your Stora with the same product key and Stora name. To recover your data, recreate the same user accounts.

If the issue persists, please contact support.

Cheers,
Roby!
Message 1 of 112
sprogy
Aspirant

Re: Re-flash your NetGear Stora

is this done with the hdd's in or out?
Message 2 of 112
ossienet
Aspirant

Re: Re-flash your NetGear Stora

sprogy wrote:
is this done with the hdd's in or out?


I don't see how the HDD LED's can blink if the HDDs are OUT :confused:
Message 3 of 112
Graculus
Aspirant

Re: Re-flash your NetGear Stora

I left the HDDs in. I've done it twice, recently. Be aware that it will get you back up and running, but in my case with the previous firmware (2.3.3 I think). Updating is simple afterwards though. Also the time taken to download and re-flash is seriously optimistic in the instructions, 4-5 mins should read 45mins! I'm not on a particularly slow connection. Don't worry if it seems to be taking ages, just let it do its thing...

Good luck!
Message 4 of 112
Graculus
Aspirant

Re: Re-flash your NetGear Stora

@ossienet - both lights blink. In my case I only have one HDD.
Message 5 of 112
sprogy
Aspirant

Re: Re-flash your NetGear Stora

ossienet wrote:
I don't see how the HDD LED's can blink if the HDDs are OUT :confused:


if your only using 1 drive how will you know its working then? as it does use both hdd led's?
Message 6 of 112
Graculus
Aspirant

Re: Re-flash your NetGear Stora

The one which you have a HDD in will flash orange, but be green otherwise, the one without will simply flash orange.
Message 7 of 112
Southkil
Aspirant

Re: Re-flash your NetGear Stora

In tha above procedure, the lights are not indicating whether the drives are working or not, the lights/LEDs are there for diagnostic only.

You do not need the drives in to do the procedure, but a drive is needed to download the new firmware to the stora, as the file is to big for the onboard memory.

Smiley Happy
Message 8 of 112
Kkthnx
Aspirant

Re: Re-flash your NetGear Stora

Im getting an error now. Something about a file system error. Wont let me log in
Message 9 of 112
Kkthnx
Aspirant

Re: Re-flash your NetGear Stora

Cancel the last.
Ive given up, it's a waste of time and ive arranged for it to be returned.
Message 10 of 112

Re: Re-flash your NetGear Stora

HI!!

I've had problems since firmware upgrade...tried all recommended fixes..nothing worked, the best one was the hard reset, entered user name and the system came back and said the name can't end with a "." it didn't the system had added it!!!

Now the re flash..that worked like a DREAM took about 5 mins to download and sort...tried to log on and it now tells me I require a new product code have e-mailed Support and I'm still waiting I've 'lost' loads of stuff.......
Message 11 of 112
robyb
Aspirant

Re: Re-flash your NetGear Stora

lost_and_confused wrote:
HI!!

I've had problems since firmware upgrade...tried all recommended fixes..nothing worked, the best one was the hard reset, entered user name and the system came back and said the name can't end with a "." it didn't the system had added it!!!

Now the re flash..that worked like a DREAM took about 5 mins to download and sort...tried to log on and it now tells me I require a new product code have e-mailed Support and I'm still waiting I've 'lost' loads of stuff.......


When you re-register, use the same Stora name. You won't need a new product key.

Cheers,
Roby!
Message 12 of 112

Re: Re-flash your NetGear Stora

robyb wrote:
When you re-register, use the same Stora name. You won't need a new product key.

Cheers,
Roby!


HI!!

Thanks for the reply....

I am using the same Stora name!!!

Regards
Message 13 of 112
robyb
Aspirant

Re: Re-flash your NetGear Stora

lost_and_confused wrote:
HI!!

Thanks for the reply....

I am using the same Stora name!!!

Regards


then check if you're using the same product key. are they perhaps different on the cd sleeve vs the bottom of the Stora?

Cheers,
Roby!
Message 14 of 112

Re: Re-flash your NetGear Stora

robyb wrote:
then check if you're using the same product key. are they perhaps different on the cd sleeve vs the bottom of the Stora?

Cheers,
Roby!


Thanks for reply......

I'm afraid it isn't as easy as that..the product code on the CD and the bottom of the unit are the same, I think it's pick up a 'name' when it was adding "." to the end of everything....the trouble is this went down last weekend and I need it back up for next week end as it's the end of the month lots of info on there that I need!!

Regards

Lost......
Message 15 of 112
robyb
Aspirant

Re: Re-flash your NetGear Stora

lost_and_confused wrote:
Thanks for reply......

I'm afraid it isn't as easy as that..the product code on the CD and the bottom of the unit are the same, I think it's pick up a 'name' when it was adding "." to the end of everything....the trouble is this went down last weekend and I need it back up for next week end as it's the end of the month lots of info on there that I need!!

Regards

Lost......


Ok then, contact Netgear Support, they can get you a new key.

Cheers,
Roby!
Message 16 of 112

Re: Re-flash your NetGear Stora

robyb wrote:
Ok then, contact Netgear Support, they can get you a new key.

Cheers,
Roby!


thanks...how quick do netgear support turn round support requests????
Message 17 of 112
robyb
Aspirant

Re: Re-flash your NetGear Stora

lost_and_confused wrote:
thanks...how quick do netgear support turn round support requests????


I don't have a clue, I don't work for Netgear Smiley Happy

GL,
Roby!
Message 18 of 112

Re: Re-flash your NetGear Stora

robyb wrote:
I don't have a clue, I don't work for Netgear Smiley Happy

GL,
Roby!


Thanks for your help Roby......

does anybody know what it's like getting answers from netgear???????

Regards

Lost....
Message 19 of 112
usualsuspect
Aspirant

Re: Re-flash your NetGear Stora

Is this or even Hard resetting it going to loose the data on the drives?
Message 20 of 112
mtiede
Aspirant

Re: Re-flash your NetGear Stora

I can attest that putting a paper clip in the little hole in the back counting the right number of flashes, etc. did NOT lose my data. You DO have to use the same User though in order to see the folder that contains your old data.

(look elsewhere on the site for the exact reset procedure)
Message 21 of 112
Davidovich
Aspirant

Re: Re-flash your NetGear Stora

I decided to do a re-flash based upon the various problems I was having with the web interface. It has been three hours and HDDLED 1 and 2 and blinking on and off in turns with power LED off which means that it is still working. Going home for the weekend and hope to see if this fixes the problems.

Am running out of options. By the way, does anyone know if HDD are hot swapable? I did do a hot swap of both drives and did not see any problems, but there are alot of comments on the web that Stora does not support Hot swapable drives. Does anyone know if I broke something as a result.

My biggest problem is with the web interface and that the drives seemed to be in constant motion. I noticed that the response of the NAS via FTP and remove drive letters was really fast. It just the web interface. In fact today the web interface flat out died, while the rest of the NAS worked fine.

I would appreciate anyone's input. Thanks
Message 22 of 112
Davidovich
Aspirant

Re: Re-flash your NetGear Stora

Bad News.

Stora died. After waiting over 24 hours for re-flash to finish it never finished. It would not shutdown so I killed power. After I turned power on it seemed to be booting up for the 1st 15 or so seconds and now only has the blue LED blink 3-4 times then go dark for a few seconds then repeat. The two HDD LEDS are just lite up and don't do anything.

Is it possible that I have a hardware problem?
Message 23 of 112
Davidovich
Aspirant

Re: Re-flash your NetGear Stora

Progress Report - After spending 4 hours with Netgear Tech Support, they decided that I had a hardware problem and would send out a new unit via RMA. After I hung up I decided to try to do re-flash with only 1 drive. IT WORKED!! It took about 5 minutes and then I had to then register. All my data was still there. I also noted that my files were accessible via the USB Backup, even though the USB drive was 80G verses the Strora drive of 112 GB. Don't know how the reason for the 32GB difference. Bottom-Line: Did not loose any data.

I then powered down the Stora and inserted the 2nd drive for the RAID1. After powering up, HDD lights would go orange and stay orange and I get no response on the PING. I then powered down, removed 2nd drive and Stora came right up. So it does appear that there is somekind of hardware problem. I will await for the new chassis, but am still confused over how the change will happen with a different product key. In the meantime, I will keep using the Stora with only 1 HDD.
Message 24 of 112
Dogbert
NETGEAR Employee

Re: Re-flash your NetGear Stora

The product key isn't unique to the specific chassis, but to the specific Stora name (after being registered). So once you get the RMA chassis you can use the same PK and Stora name on the replacement chassis.
Message 25 of 112
Discussion stats
Announcements