Reflashing a NetGear Stora

Hi All,


Currently trying to recover my STORA and am trying the reflashing process.


I have restarted it and waited 15 seconds then hit reset until the BLUE power light goes off and it cycles round the ORANGE hdd lights 


I'm now left with a solid BLUE led and 2 HDD lights flashing green/orange. Have left this for over 45mins.


I can see its connected to my home network using a BT SMART HUB router and its now called "storarecovery" and is pinging on


Not sure if the process is working as I've already tryed this several times and if i reboot I get solid GREEN HDD leds and a flashing BLUE power LED.


Any help appreciated as I've got 2 x 2TB inserted and lots of data I dont want to lose. thanks!





Message 1 of 32

Accepted Solutions
NETGEAR Employee Retired

Re: Reflashing a NetGear Stora

You're welcome!

Thanks for confirming it's now working again for you.


Whilst the server is up that's pretty much all we can do.

View solution in original post

Message 31 of 32

All Replies

Re: Reflashing a NetGear Stora



I have the same problem, i'm tryng reflash the Stora and the process start but after 5 secons the process fail and the led blue light on and the 2 led hdd are flashing.


do someone work the process today?.


Thank for advanced.



Message 2 of 32

Re: Reflashing a NetGear Stora

Please can someone from NETGEAR help?

My STORA is stuck! It has an IP but is stuck in recovery mode.
Message 3 of 32

Re: Reflashing a NetGear Stora

I have the same issue.......are there NetGear folks still monitoring these boards offering help?


I have two 1TB drives loaded.


My Stora has been running for a long time but every now and then I power it down - recently I powered it down then two days later powered it back on and it appears to start up normally but eventually the HDD drives turn orange.


After a number of reboots, checking cables, pulling network cable out and back in it came back online - the orange lights turned green.


Last weekend I powered off again, and a few days later powered back on and got the same issue - 2 HDD Orange lights.


I've tried the same as before, number of reboots, pulling network cable etc - but to no joy.


So I've since tried a hard reset and a reflash and all I now get is either:

1 - during reflash process the lights eventaully turn to Blue light ON, HDD lights flahing orange together

2 - during "normal" power up blue light flickers for a few seconds, then goes off, then flickers for a few seconds.....and repeat.


I'm considering buying a second hand Stora so I can get back online, rescue my files and consider my next steps.


Any help would be greatly appreciated.

Message 4 of 32

Re: Reflashing a NetGear Stora

I would almost think it has somehting to do withe outtage on the mystora portal, since you 2 have the same problem starting around when the site went down.

Maybe it tries to connect to the storaservers for firmware and gets a timeout?
Message 5 of 32

Re: Reflashing a NetGear Stora

So what can I do from here then?

Message 6 of 32

Re: Reflashing a NetGear Stora

The same thing I'm doing, hoping and praying someone from netgear accidentally stumbling upon our posts.

Or an engineer at netgear that misclicks and sees the server status screen.

Wish I could help out, but I got equivalent problems too (I'm on a remote site and havent been able to acces my stora for over a week now)
Message 7 of 32

Ive emailed them but not sure it'll work support@axentra....

Ive emailed them but not sure it'll work

I've also PMd a moderator for help

My stora can get a local IP (192.168...) but gets stuck at either STORARAMFS (trying a normal boot up) or STORARECOVERY (trying a reflash)

I only need to recover my family library contents not bothered about individual users

Wish I'd never tryed a reset/reflash now it was only because I was getting connection timed out when using the remote transmission app to view my torrents an them noticed I couldn't log into the myportal over the weekend :-(
Message 8 of 32

Re: Reflashing a NetGear Stora

Hoping someone at NETGEAR just needs to flick a switch so that my STORA can receive the firmware and carry on with reflash process ...or that it will just boot back up on its own but at the moment I can't connect to it using the software on my laptop. Tempted to try and SSH to it but don't want to break it further
Message 9 of 32

Re: Reflashing a NetGear Stora

Yeah it's one of those moment you slap yourself in the face when the servers are back up and you've created another problem for yourself Smiley Tongue
Message 10 of 32

Re: Reflashing a NetGear Stora

@DexterJB - can anything be done about this at end???

Message 11 of 32

Re: Reflashing a NetGear Stora

Netgear Holland contacted me via facebook this morning. They claimed to be aware of the problem and sent me a workaround. However that was for the previous certificate error, not for the current problems.

If only just one of them tries to login, they'll know. Even if you enter wrong credentis it still fails to even show the popup that it's wrong. Meaning their login server itself seems to have problems.
Message 12 of 32

Re: Reflashing a NetGear Stora

Hi Dimitri1337,


Could you possibly post that ''workaround'' here? I have problem accessing and I cannot find anything on the web to fix a problem with certificate error. Never had any problems accessing website but for past few months it's just says that ''certifcate has been revoked''. It does not matter what browser I use and whether I am at work or home.

Message 13 of 32

Re: Reflashing a NetGear Stora

Hello, the issue with the certificate is solved in this post.


You can try it.




Message 14 of 32

Re: Reflashing a NetGear Stora

Workaround is posted above, it will however run you into the same problem I am having, the website will give a missing resource error, which is a problem on their backend.


At the moment of writing the website is completely down (yet again), only thing I can pray on is that they're fixing it and thats the reason it's down.

Message 15 of 32

Re: Reflashing a NetGear Stora


U can mount STORA hards on some Linux (Ubuntu) and copy files from hards. STORA is XFS sile sistem and that is not problem.

Folow this 6


Message 16 of 32

Re: Reflashing a NetGear Stora

That's my next step as soon as drive enclosure arrives.....rescue files and buy a new NAS (not NetGear!!) unless, by some miracle, someone from @NetGear, @Axentra, @HipServ comes forward with some assistance for us all and the issue is resolved...... I did get a response from @DexterJB - have fed back to them and now waiting for a response but I got nothing from tweets to several related twitter accounts.



Message 17 of 32

Re: Reflashing a NetGear Stora

Consider making NAS with Free NAS. That is a best solution.

Message 18 of 32

Re: Reflashing a NetGear Stora

Guys I would just say to make clear that the problem is with so in any case of issues accessing remotely stora it is not necessary to reflash the stora, this would make less easy to retrieve files and data.


Let's hope NETGEAR helps us to get back our files and NAS and maybe let's hope we get some reply.

Meanwhile I have also contacted NETGEAR Italy and I would recommend you to contact your local NETGEAR references.

Message 19 of 32

Re: Reflashing a NetGear Stora

Im save my data from Stora and i buy Bufalo now.
Message 20 of 32

Re: Reflashing a NetGear Stora

Well a week on and my STORA is still stuck in RECOVERY mode waiting for the firmware. is still down it seems so it'd be nice if someone from NETGEAR could tell us what's going on and wether we are getting the service back!
Message 21 of 32

Re: Reflashing a NetGear Stora

I try one of this days witd serial console and Adruino to flash fiirmver

Message 22 of 32

Re: Reflashing a NetGear Stora

I'm in the same boat here. Had issues accessing my Stora via AFP on my Mac, could still access via the browser.


I tried doing a reset but couldn't access to re-register, then tried to re-flash and am now getting the solid blue light with two flashing orange lights.


From what I've read in this post it seems like the site being down is the issue as to why I couldn't re-register the Stora in the first place, and now why I can't re-flash to get the firmware again.


Coming in on this post to hopefully hear some feedback from the people in power as to when we can expect a solution.

Message 23 of 32

Re: Reflashing a NetGear Stora

Message 24 of 32

Re: Reflashing a NetGear Stora

Yeah I'm now keeping an eye on the other thread and hoping that NETGEAR can restore the service soon so I can re-register my STORA.

If they can't i will install Linux as a VM on my laptop and try an recover my stora data that way!
Message 25 of 32
Top Contributors
Discussion stats
  • 31 replies
  • 8 kudos
  • 10 in conversation