Reply
Highlighted
Tutor
Tutor

Only the Power Light blinks - no activity on any port

I've been completely stumped by these GS105v5 switches. I've been using GS105v3 and GS108 for years. I recently got 2 GS105v5 and have been unable to get them to work. I've even tried replacing a working GS105v3 with one of these v5 (like a hot swap to test in a config I know works) and all I get is a blinking power light when the switch is turned on. None of the port lights light up. I even just received a 3rd new one and same thing. Just a blinking power light. I've tried Cat6 cable and Cat5e cables both 568A and cross overs. I'd like to use it to add a few more ports from my Orbi and hooking up to Mac mini, Xbox, Apple TV, NAS, and printer. These are all devices with Cat5e cables that work just fine with the GS105v3. What's different about v5 that not one works as expected. I thought these were auto sensing auto config so they would know which is the uplink port and not require a crossover cable. Heck even with a crossover it doesn't work. At first I thought I had a dud but then I got a second one which exhibits the same behaviour. Now a 3rd. All brand new, came sealed with netgear sticker over the anti-static bag.

 

I'd love to get at least one to work. I had gotten 2, one to replace an old Linksys 10/100 switch that was locking up about once a month. In that office setup it's behind one of my older GS105v3 switches. The Linksys was working fine for years. I ended up finding a generic Amazon cheapie to replace it since I couldn't get one of these GS105v5 switches to work. That worked where GS105v5 wouldn't.

 

I thought these were bulletproof plug and play. 

Model: GS105|5 Port Gigabit Ethernet Switch
Message 1 of 2

Accepted Solutions
Highlighted
NETGEAR Moderator

Re: Only the Power Light blinks - no activity on any port

@UW,

 

all I get is a blinking power light when the switch is turned on. 

The power LED should be lit up solid green. If you have just newly purchased the 2 GS105v5 switches, I suggest you to return it to the store where you bought them and ask for a replacement. 

 

 

Regards,

 

DaneA

NETGEAR Community Team

View solution in original post

Message 2 of 2

All Replies
Highlighted
NETGEAR Moderator

Re: Only the Power Light blinks - no activity on any port

@UW,

 

all I get is a blinking power light when the switch is turned on. 

The power LED should be lit up solid green. If you have just newly purchased the 2 GS105v5 switches, I suggest you to return it to the store where you bought them and ask for a replacement. 

 

 

Regards,

 

DaneA

NETGEAR Community Team

View solution in original post

Message 2 of 2
Top Contributors
Discussion stats
  • 1 reply
  • 88 views
  • 0 kudos
  • 2 in conversation
Announcements