× NETGEAR will be terminating ReadyCLOUD service by July 1st, 2023. For more details click here.

6.10.x unable to boot with encrypted volume


6.10.x unable to boot with encrypted volume


Attempt to boot with console output on 6.10.1






attempt to boot on 6.10.0 after os reinstall 





After 10 minutes it now booted 



Model: RN428|ReadyNAS 428 – High-performance Business Data Storage - 8-Bays
Message 1 of 5

Re: 6.10.x unable to boot with encrypted volume

Did a restart and still having boot issues

Message 2 of 5

Re: 6.10.x unable to boot with encrypted volume

restarting again with my EDA500 connected now


basically stuck at this https://imgur.com/C4FK93f

Message 3 of 5

Re: 6.10.x unable to boot with encrypted volume

So to reiterate my steps... (DISCLAIMER - I'm an IT Manager and been working in IT for over 20 years)


1. Tried booting with my encryption keys on a different USB drive. My thinking here initially was that the flash drive failed

2. I tried booting with and without the EDA500 connected. 

3. Tried installing 6.10.0 from flash drive


None of these worked. 


With a suggestion of getting a console session going I took screenshots of the boot process. There seems to be an encryption dependency warning. Not sure what that's going to be. I don't work in linux that much as most of my companies have been windows shops. 


So at this point I was really put off. I'm not really happy with Netgear's lack of support for their products (its assinine to have to pay for support for these things past the 90 days/1 year in my opinion). I also am not happy with Netgear's lack of focus on the forum, especially when you've bought a rackmount model that's nearing $10k in cost. (/rant)


So I decided to everything back and just leave it and wait for someone on the forum to repsond. Well I realized I had a need to get some files off  and decided to turn it back on again. 


Well wouldn't you know, the f**king thing boots up...



 I put back the original flash drive with encryption keys, connected the EDA500. Mind you it took longer to boot, but it booted like nothing ever happened. 


This is not the first time something like this has happened to me with a ReadyNAS. A couple of my older 32 bit four bay models has weird sh*t like this happen as well. And with those things they were far simpler in my opinion. I had an instance where it was telling me I had a bad drive. So I put in a spare I had laying around that I knew worked. Well it gave me the finger on that. So I put back the original drive (which still worked) and the NAS gave me the finger on that as well telling me it was a foreign disk. So I shut it off, and let it sit for a week. 


For fun I turned it back on the following weekend. The f*cking thing starts right up and starts resyncing the drive like nothing happened. 


Weird thing though again was the admin password was not what I had set it to. Again forced to reset it and it didn't like being reset. 


Is this ghosts of Infrant? 


I've been a fan of ReadyNAS since the infrant days. After my experience in the last week I'm starting to reconsider my love of ReadyNAS. There's been a serious lack of media exposure and reviews of Netgear storage products in the last few years and the competition has way better app/feature support. Not to mention EASY MEMORY UPGRADABILITY!!! 

Message 4 of 5

Re: 6.10.x unable to boot with encrypted volume

Maybe a hotfix was applied, so something did change?


But as far as your rant goes, I'm a long time ReadyNAS user (back to the Infrant days).  When my department at work (division of a fortune 500 company that shall go unnamed) had a need for a NAS for access by systems segregated from the main servers on a VLAN,  the company recommendation was a ReadyNAS.  I was floored!  I wouldn't recommend a ReadyNAS for business use for anything over a very modest single-office company.  Netgear, IMHO, is just not in the running when it comes to business-ready features and support.


Dropping older systems (including mondo expensive ones like ReadyData) with little warning and no upgrade path or even easy migration from older to newer systems are not things one does when trying to attract business customers.  And do they think nobody looks at prices for business systems?  Have you seen what they want for a simple SAS HBA with external port for attaching an EDU to a Rack mount NAS?  More than 5x what Dell and others get for one.  Then, you add the EDA.  I guess they really want you to buy another NAS.

Message 5 of 5
Top Contributors
Discussion stats
  • 4 replies
  • 0 kudos
  • 2 in conversation