× NETGEAR will be terminating ReadyCLOUD service by July 1st, 2023. For more details click here.
Orbi WiFi 7 RBE973
Reply

All App images broken after RAID6 Volume

NetworkedinPA
Aspirant

All App images broken after RAID6 Volume

New 316 with 4 WD40EFRX drives.

Initial setup via ReadyCloud, upgraded FW to 6.2.2, disabled XRAID, deleted volume, created new volume with all drives with RAID6, enabled XRAID, waited for full rebuild.

I now have a RAID6 volume with 7.27TB free.

But I also have the missing apps directory/images/configuration/whatever that when I use the browser based admin page and look at available apps, the image links are all broken 😞

Looks similar to this:
This is the thread I read about it: http://www.readynas.com/forum/viewtopic.php?f=7&t=78690&hilit=available+apps

So...how do I fix this? I thought the FW + OS were outside of the user volume space?

I'd also like to know how to avoid this problem in the future. It is quite possible I may manipulate or change my data at some point in the future and don't want the ReadyNas 316 to go south with every volume configuration change.

Is there a non-destructive system restore that doesn't require a 16 hr + rebuild?

Please advise.

Edit: Path to images seems to be significant according to the other thread. Here is mine with ip address obscured: 'https://{myRNipaddress}/apps/logo/photos2.png'
Message 1 of 8
NetworkedinPA
Aspirant

Re: All App images broken after RAID6 Volume

Magic!

I renamed my NAS and rebooted. Still broken available apps icons. Tried refresh, nothing. Browser hard refresh all, nothing.

I downloaded and read ReadyNAS OS 6.2 Software Guide.

Poked around in Frontview, didn't make any changes.

Considered SSH to manually see what the directory structure is on these devices, see if the apps directory exists, etc.

Tried one last visit to Available Apps and viola! The apps icons have magically reappeared!

I'm guessing there may be an internet download that is out of control of the user for these apps and unaffected by the Refresh button in Frontview?

Any insight into this would be appreciated.
Message 2 of 8
mdgm-ntgr
NETGEAR Employee Retired

Re: All App images broken after RAID6 Volume

This data is stored on the main data volume. So it does need to be restored somehow e.g. via firmware update if you delete the volume on which the apps are stored.
Message 3 of 8
NetworkedinPA
Aspirant

Re: All App images broken after RAID6 Volume

mdgm wrote:
This data is stored on the main data volume. So it does need to be restored somehow e.g. via firmware update if you delete the volume on which the apps are stored.


I deleted my XRAID RAID5 that was being built by default, within the first few minutes and recreated it as RAID6. The rest of the GUI was there.

I don't see photos, documents, etc that was there initially. I wonder though if that is a function of turning on Cloud access? I haven't done that yet, still poking around in the corners for mouse traps.

Also, why would they just reappear?

If I were to speculate, I'd say the Available Apps section occasionally and automatically checks online for apps list, updates, etc and although one would expect a 'Refresh' to do that immediately, it is likely I just had to wait for the next 'update cycle'

Which makes sense. Else once you purchase the NAS, you would never get any updated apps...forever (or the next FW release) 😉
Message 4 of 8
mdgm-ntgr
NETGEAR Employee Retired

Re: All App images broken after RAID6 Volume

These images are stored in a hidden folder in the /apps section of the data volume.
Message 5 of 8
NetworkedinPA
Aspirant

Re: All App images broken after RAID6 Volume

mdgm wrote:
These images are stored in a hidden folder in the /apps section of the data volume.


Thanks. What about the update cycle? How often is it, what triggers it, how do we check for new apps? (Sorry if this has been covered before, I'm new to ReadyNAS)
Message 6 of 8
mdgm-ntgr
NETGEAR Employee Retired

Re: All App images broken after RAID6 Volume

Not sure how that was fixed, perhaps there's an automatic check to make sure those files are there at some point.
Message 7 of 8
NetworkedinPA
Aspirant

Re: All App images broken after RAID6 Volume

Yeah, I figured something like that. It would make sense to occasionally update the listings, wouldn't it? I guess if I had time I could set up a sniffer and watch it. Hoped someone would know. It could be important to know what type of 'phone home' it needs behind firewalls, especially appliances.
Message 8 of 8
Top Contributors
Discussion stats
  • 7 replies
  • 1632 views
  • 0 kudos
  • 2 in conversation
Announcements