Reply

Can't acces shares after upgrade to 6.5.0

darthy
Apprentice

Can't acces shares after upgrade to 6.5.0

Hi,

 

I updated my Readnas 314 to firmware 6.5.0 a few days ago. I also moved my account over to the new MyNETGEAR account. I have been using my ReadyNAS device for a good few years now with no problems.

 

After the firmware update all seemed to be working fine except that none of my Snapshots are showing - I have this issue opened for it: https://community.netgear.com/t5/Using-your-ReadyNAS/ReadyNAS-314-6-5-0-Upgrade-All-Snapshots-Delete...

 

Today I tried to access my shares and they are no longer working. When I browse to \\readynas in Windows Explorer I can see one folder, but can't open the folder.

 

I have read through the various discussions here and tried most of the recommendations but still cannot acces the shares.

 

I can log into the admin site and can browse the shares through the web interface fine.

 

I can also access my music through Plex so there is some sort of connectivity at a network level.

 

I have tried the following:

- I have changed the Workgroup Name to WORKGROUP to make it consistent with my Windows settings.

- All my shares have Anonymous access so I should be able to get to them regardless.

- I have gone into Windows Credentials Manager and changed the readynas settings there with no success.

- I have run RAIDar and it shows green for the readynas, but when I click on Browse I get an error - Element not found.

- I have gone into the share Settings | File Access and Reset the permissions for one of the shares. It reported as successful completed but still can't access it.

 

Would appreciate any help as at this point the system is unusable and I have all my files stored on it.

 

Thanks.

Model: RN31400|ReadyNAS 300 Series 4- Bay
Message 1 of 5
darthy
Apprentice

Re: Can't acces shares after upgrade to 6.5.0

I installed the ReadyCLOUD app on my Windows 10 PC (as advised by one of the other users), logged into it using my admin credentials and then navigated to one of the folders.

 

It opened up in Windows Explorer using the IP address of my ReadyNAS and I can now see all my shares again and navigate between them.

 

If I try to access the shares by going to \\readynas I still have the same problem as previously reported.

 

At least for now I can navigate to my ReadyNAS and use it, not ideal but at least working to some degree.

Message 2 of 5
darthy
Apprentice

Re: Can't acces shares after upgrade to 6.5.0

After some more experimenting I think I have fixed the issue, hopefully these steps might help someone else who experiences this.

 

I navigated to \\readynas and could see the one share that I couldn't access (if you can't see at least one share I'm not sure what you would do to resolve this).

I right clicked on the Share and mapped the network drive, but told windows to Connect using different credentials.

It asked me for the new credentials - I used my new MyNETGEAR account.

The drive was mapped fine and I could now browse normally to my \\readynas device.

 

So, it looks like windows might have been confusing my readynas and windows credentials. My windows account uses the same e-mail address as my readynas. I could find no way to force windows to prompt me for my updated credentials, even after deleting the account from Windows Credential manager (and also recreating the account in Windows Credential Manager using my MyNETGEAR credentials for the readynas).

 

This seems to either be a new problem with the 6.5.0 update or with the new MyNETGEAR account or a combination of both but extremely frustrating.

 

I have also uninstalled the ReadyCLOUD app, rebooted my PC and my drives continue to be mapped without a problem and I can also browse directly to \\readynas through Windows Explorer.

 

Also, there is nothing stored in Windows Credential Manager so not sure if this has been deprecated in 6.5.0 or not, but working fine without an account appearing there.

 

Also worth remembering that as a last resort using the ReadyCLOUD app might help when all else fails.

Message 3 of 5
raymondtunstal1
Aspirant

Re: Can't acces shares after upgrade to 6.5.0

I've also found this after upgrading to 6.5.0 (and new 'MyNETGEAR' login) on my RN104.

 

A mapped drive no longer works and I cannot browse (via file explorer) to either the \\ip or the \\NameOfReadyNas.

 

Unfortunately I can't even see the root, to try your workaround.

Model: RN104|ReadyNAS 100 Series
Message 4 of 5
darthy
Apprentice

Re: Can't acces shares after upgrade to 6.5.0

I just had a very tough time trying to get my Windows 10 laptop to connect again to the shares.

 

I could get to them by going to Window Explorer and typing \\x.x.x.x (the IP address of the readynas)

 

I went into Windows Credentials Manager and deleted the readynas entry. At this point it prompted me for a username and password but seems to default to the windows domain and don't know how to change it to tell it to use readynas to authenticate against.

 

Going back into Windows Credential Manager I noticed another entry for readynas, this time under the Windows Credentials section. Note that readynas seems to appear under both the Windows Credentials section and the Generic Credentials section. I might have missed this earlier in my initial trouble shooting on my primary PC (in fact another user had mentioned this in another post). Once I deleted this entry I managed to authenticate against the readynas, so either try changing the credentials here or delete the entry and see what happens.

Message 5 of 5
Top Contributors
Discussion stats
  • 4 replies
  • 2593 views
  • 2 kudos
  • 2 in conversation
Announcements