× NETGEAR will be terminating ReadyCLOUD service by July 1st, 2023. For more details click here.
Orbi WiFi 7 RBE973
Reply

Can't access shared folders on NAS anymore ... "Volume expansion failed"

anarchoi
Aspirant

Can't access shared folders on NAS anymore ... "Volume expansion failed"

I haven't used my ReadyNAS for a very long time. Today I booted it but I can't access my shared files anymore and I don't understand why.

The NAS shows up in the network but I can't access the shared folders.

So I tried logging in the web panel and got a warning "Volume expansion failed" ... however I have not changed the drives recently. The shared folders still show up in ReadyNAS Frontview web panel.

When checking the drives states, they show up with the green lights.

Then I tried opening RAIDar and got a message saying "The JVM could not be started. The maximum heap size (-Xmx) might be too large or an antivirus or firewall tool could block the execution"

I tried disabling my antivirus (Kapersky) and windows firewall was already turned off.

On my NAS LCD Panel, everything seems to be normal and the NAS is booting normally without any errors displayed on the LCD screen.

 

Please help!

Thanks

Model: ReadyNAS RNDU4220|ReadyNAS Ultra 4
Message 1 of 2
StephenB
Guru

Re: Can't access shared folders on NAS anymore ... "Volume expansion failed"

What firmware are you running?

 

Let's set aside the volume expansion warning for now.  The shares appear intact, and I think the first step is to regain access.  After that, I recommend backing up the files on the NAS. 

 

If you are using Windows 10, then it is likely that your access problem is because Microsoft is deprecating SMB 1.0/CIFS.  Try entering "run windows features on or off" in the the search bar, and bring up the control panel app.  Scroll down until you see the SMB 1.0/CIFS feature, and enable the SMB client if it is disabled.  You don't need to enable the server (though it is checked in the screenshot below). 

 

Note that SMB 1.0 isn't secure (and never has been) - that is why Microsoft is deprecating it.  However, your older NAS uses SMB 1.0/CIFS, not the newer SMB 3.0.  There are some options on this, but let's regain access first.

 

SMB1.png

 

After the client is installed, reboot the PC and then try accessing the NAS again.  If that fails, post back - there are some other things to try.

 

On RAIDar, You could try running RAIDar 6.x - it can co-exist with RAIDar 4.3.8.  The download is here: https://kb.netgear.com/20684/ReadyNAS-Downloads#raidar

 

 

Message 2 of 2
Top Contributors
Discussion stats
  • 1 reply
  • 3287 views
  • 0 kudos
  • 2 in conversation
Announcements