Reply
Highlighted
Aspirant

Cannot connect to ReadyNAS with windows 10

I have some time ago updated to windows 10 hoping that I had chosen a late update where most bugs had been identified and solved.

However, I cannot connect to my ReadyNAS Duo. I can see the NAS via Raidar, which is showing the NAS as healthy (firmware 4.1.14) and in full function but I can get any kind of access.

I have tried to implement most of the tricks already shown for connection issues with Windows 10 but non has so far worked for me. Either because I have not had the skills to do the corrections correctly or becuase my problem is another.

 


I have tried to add windows and microsoft log-ins for the NAS - but I may have done this in a wrong way - I´m not sure.

I have also installed most recent updates to Windows 10, I have checked that I have most recent netgear driver for my router, and I have made sure to have the most recent firmware for the router (Netgear genie firmware V1.1.2.58).

 

I would appreciate any help from this very knowlegdeable forum - preferably in a non-expect lingo. Thanks a lot Smiley Happy

best regards, Kirsten

Message 1 of 15

Accepted Solutions
Highlighted
Guru

Re: Cannot connect to ReadyNAS with windows 10


@kirsten_d wrote:

RAIDar shows 10.0.0.8 for the NAS.

Router-connected wireless devices all have IP addresses starting with 172.16.0.X - so that must be the area that the router deals in


If your router uses 172.16.0.x addresses, then you can't ping 10.0.0.8.

 

Did you configure the NAS to use a static address?  If not, can you give us some more info on how your NAS is connected to the router (giving the manufacturer/model for any intermediate devices)

 

There are a couple of things you can try:

(a) directly connect the PC ethernet to the NAS (bypassing the router).  Temporarily configure the PC to use 10.0.0.7, gateway 10.0.0.1, subnet mask 255.255.255.0.  Then enter https://10.0.0.8/admin in your browser, and reset the NAS network configuration to use DHCP.  Reconnect the system as before, and change the PC back to DHCP.

 

(b) set the router range to use 10.0.0.x, and use address reservation (a usual router feature) to reserve 10.0.0.8 for the NAS.  That should let you connect,  After that make sure the NAS is configured to use DHCP.

 

(c) Do an OS reinstall from the front panel of the NAS.  That resets the NAS to use DHCP, and also reset the NAS admin password to netgear1.  It shouldn't change any other settings or delete data.  OS reinstall is described on pages 15-16 here: http://www.downloads.netgear.com/files/GDC/RND2110/Duov1_NV+v1_HW_en_06Dec11.pdf  Be careful not to do a factory reset by mistake, that will delete your data.

View solution in original post

Message 10 of 15

All Replies
Highlighted
Guru

Re: Cannot connect to ReadyNAS with windows 10

Try running CMD on your windows system, and then enter

net use * /delete

net use t: \\nas-ip-address\c /user:admin nas-adimin password

 

Use the real IP address of your duo, and the real nas admin password.  Be careful on the spaces and the direction of the slashes.

 

The first command will end any open network sessions on the PC (it doesn't actually delete anything).  If it prompts, let it proceed.

 

The second attempts to mount the NAS C volume as drive letter t.  Let us know if it works (or what errors you get).

Message 2 of 15
Highlighted
Aspirant

Re: Cannot connect to ReadyNAS with windows 10

Thank you, StephenB

I tried the below - it didn´t help.

 

In the command Prompt I wrote

net use * /delete

I recieved the message: There are no entries in the list.

 

I then tried to write 

net use t: \\10.0.0.8\c /user:admin my password

I recived the message after a little time: The network path was not found.

 

Message 3 of 15
Highlighted
Guru

Re: Cannot connect to ReadyNAS with windows 10

Check the network classification in the Windows network and sharing center.  It needs to be set to "private", not "public".

 

Also, make sure the windows machine is in the same workgroup as the NAS.  The workgroup is not the same as homegroup, they are separate settings.

 

Can you log into the duo by entering http://10.0.0.8/admin in your browser?  You could get a security warning you need to click-through.  Also, if edge misbehaves you might want to try with firefox or chrome.

 

 

 

Message 4 of 15
Highlighted
Aspirant

Re: Cannot connect to ReadyNAS with windows 10

How do I found out what is the name of the WORKGROUP for the ReadyNAS when I can't access it? Any tips?

 

Windows network sharing and sharing center were already classified as private.

I can't contact the ReadyNAS via the IP address (in any browser). I get time out-reply.

 

Thanks in advance.

Message 5 of 15
Highlighted
Guru

Re: Cannot connect to ReadyNAS with windows 10


@kirsten_d wrote:

How do I found out what is the name of the WORKGROUP for the ReadyNAS when I can't access it? Any tips?

 


I assumed that you had access to frontview, obviously that was wrong.

 

Are you using Edge as the browser?  If so, I suggest downloading Chrome and see if that can connect to https://nas-ip-address/admin  It will give you a security warning that you need to click through.

 

Also, does the NAS respond to ping?

Message 6 of 15
Highlighted
Aspirant

Re: Cannot connect to ReadyNAS with windows 10

I am using Chrome by default.
I am not able to ping the Nas from cmd prompt.
Only signs of the Nas being alive is the Raidar search for the Nas: Raidar tells me that the Nas is healthy and running with two disc - as it should be.
However, when I try to browse the Nas or enter admin page from Raidar - I get a message that I can't get access - I should check network settings.
I think it is strange that Raidar is able to contact the Nas to get health status but I am not able to ping it?!

Thanks for your time and suggestions.
Message 7 of 15
Highlighted
Guru

Re: Cannot connect to ReadyNAS with windows 10


@kirsten_d wrote:


I think it is strange that Raidar is able to contact the Nas to get health status but I am not able to ping it?!



RAIDar has a special "broadcast discovery" protocol that allows it to reach the NAS even if the network interface is mis-configured.

 

Can you let us know what IP address RAIDar shows for the NAS?  Also, let us know the address range used in your router (or the IP address of your PC).

 

Private IP addresses (not internet accessible) are safe to post.  Private address are

  • 10.0.0.0 – 10.255.255.255
  • 172.16.0.0 – 172.31.255.255
  • 192.168.0.0 – 192.168.255.255
Message 8 of 15
Highlighted
Aspirant

Re: Cannot connect to ReadyNAS with windows 10

RAIDar shows 10.0.0.8 for the NAS. For the router the NAS device is registered with name "unknow" but I can recognize the NAS from its MAC address. Do you think the that the NAS name "unknown" on the router settings has any impact in this relation?

 

Router-connected wireless devices all have IP addresses starting with 172.16.0.X - so that must be the area that the router deals in
(IP subnet mask: 255.255.255.0 if that can be of any information).

 

Message 9 of 15
Highlighted
Guru

Re: Cannot connect to ReadyNAS with windows 10


@kirsten_d wrote:

RAIDar shows 10.0.0.8 for the NAS.

Router-connected wireless devices all have IP addresses starting with 172.16.0.X - so that must be the area that the router deals in


If your router uses 172.16.0.x addresses, then you can't ping 10.0.0.8.

 

Did you configure the NAS to use a static address?  If not, can you give us some more info on how your NAS is connected to the router (giving the manufacturer/model for any intermediate devices)

 

There are a couple of things you can try:

(a) directly connect the PC ethernet to the NAS (bypassing the router).  Temporarily configure the PC to use 10.0.0.7, gateway 10.0.0.1, subnet mask 255.255.255.0.  Then enter https://10.0.0.8/admin in your browser, and reset the NAS network configuration to use DHCP.  Reconnect the system as before, and change the PC back to DHCP.

 

(b) set the router range to use 10.0.0.x, and use address reservation (a usual router feature) to reserve 10.0.0.8 for the NAS.  That should let you connect,  After that make sure the NAS is configured to use DHCP.

 

(c) Do an OS reinstall from the front panel of the NAS.  That resets the NAS to use DHCP, and also reset the NAS admin password to netgear1.  It shouldn't change any other settings or delete data.  OS reinstall is described on pages 15-16 here: http://www.downloads.netgear.com/files/GDC/RND2110/Duov1_NV+v1_HW_en_06Dec11.pdf  Be careful not to do a factory reset by mistake, that will delete your data.

View solution in original post

Message 10 of 15
Highlighted
Aspirant

Re: Cannot connect to ReadyNAS with windows 10

Thanks - Stephen. sounds like I'm going to spend the evening on the attic with the NAS to get the working. Thanks - I'll try this out and get back Smiley Happy

Message 11 of 15
Highlighted
Tutor

Re: Cannot connect to ReadyNAS with windows 10

Have you enabled network discovery on your Windows 10 workstation? Open file explorer and click Network, if it prompts you to enable network discovery allow it to do so. See the following URL for additional information

 

http://www.dummies.com/computers/operating-systems/windows-10/how-to-enable-network-discovery-and-co...

Message 12 of 15
Highlighted
Aspirant

Re: Cannot connect to ReadyNAS with windows 10

Yes, network discovery is enable. But thanks anyway.

Message 13 of 15
Highlighted
Aspirant

Re: Cannot connect to ReadyNAS with windows 10

 

First I gave the PC an IP address that allowed me to connect via ethernet to the NAS - as suggested in a). This gave me access to the Nas (phew).

Then i tried to do the reseting of NAS IP by DHCP - that gave a completely new IP address that didn't math neither router or PC. So I had to give pc a new IP again to reconnect to NAS. Since my router gives IP addresses in the 172 area (I don't know how this asigning of IP addresses and subnet masks works) I guessed I needed to change the IP address of the NAS to something in that area - so I chose a IP number in the 172 series. I don't know how subnet numbers are assigned but I found a page that calculates subnet numbers based on IP addresses - I tried a subnet number from that page and it worked.  And then I changed the PC IP back to non-static IP addresses. Then I logged into the router and specified a static IP for this NAS IP address. And then I connected the NAS to the router and it worked. I hope it will continues working after power off and on.

 

Thanks a lot StephenB for all your help Smiley Happy

Message 14 of 15
Highlighted
Guru

Re: Cannot connect to ReadyNAS with windows 10


@kirsten_d wrote:

Then i tried to do the reseting of NAS IP by DHCP - that gave a completely new IP address that didn't math neither router or PC.


Something sounds wrong with your network setup.

 

What IP address did it get?

Message 15 of 15
Top Contributors
Discussion stats
  • 14 replies
  • 27053 views
  • 1 kudo
  • 3 in conversation
Announcements