× NETGEAR will be terminating ReadyCLOUD service by April 1st, 2023. For more details click here.
Reply

FTP with AD user auth not listing directory properly

disco_stu
Follower

FTP with AD user auth not listing directory properly

OS 6.9.1, AD Authentication, ProFTPD 1.3.6, client and 3220 NAS on same subnet.

Setting up a new FTP share for a network scanner.  Testing with FileZilla client and WinSCP and getting the same results: When anonymous FTP is enabled, everything works fine.  When I disable anon FTP and enable user auth, I can log in but not see the share called Scans.  Instead, I see a directory listing like this:

/..

/accounts;UNIX.mode=0770;UNIX.owner=32890;UNIX.ownername=scanner; Scans

 

There is nothing obvious in proftpd.log:

2017-12-26 14:10:45,349 mod_tls/2.7[12952]: TLS/TLS-C requested, starting TLS handshake
2017-12-26 14:10:45,353 mod_tls/2.7[12952]: client supports secure renegotiations
2017-12-26 14:10:45,353 mod_tls/2.7[12952]: TLSv1.2 connection accepted, using cipher ECDHE-RSA-AES256-GCM-SHA384 (256 bits)
2017-12-26 14:10:45,378 mod_tls/2.7[12952]: Protection set to Private

 

FTP Network access is set to the "scanner" user only.  Under the File Acess tab, I've set the folder owner to "scanner" and folder group to the primary group of the scanner account, as well as tried the default access settings.

 

I'm not sure where to go next. TIA.

 

Model: RN3220|ReadyNAS 3220
Message 1 of 2
mdgm-ntgr
NETGEAR Employee Retired

Re: FTP with AD user auth not listing directory properly

Try a different client or try changing your user's primary group to one that doesn't contain a space character.

Message 2 of 2
Top Contributors
Discussion stats
  • 1 reply
  • 543 views
  • 0 kudos
  • 2 in conversation
Announcements