Reply

New Win 8 laptop causes ReadyNas Duo to disconnect

laser162644
Aspirant

New Win 8 laptop causes ReadyNas Duo to disconnect

I'm trying to add a new Lenove G580 laptop running Win 8 Pro 64-bit to my existing network which consists of 2 Win 7 PCs and a ReadyNAS Duo V1 connected by a Draytek Vigor 2710n ADSL router. The existing setup works perfectly, but when the G580 laptop connects to the network, the ReadyNas disconnects (or becomes unavailable) after a short period - let's say 1 to 2 minutes. In this short period, I can navigate the ReadyNas folders from the laptop. If I try powering down and restarting the ReadyNas with the laptop on the network, the ReadyNas lights flash indefinitely and the drive isn't available on the network. Once the laptop is off the network, I can restart the ReadyNas and everything is fine again. Any suggestions for where to start would be very welcome.

As an aside - I also have an HP Officejet Pro 8600 plus all-in-one connected to the router. This was a pig to install as it caused exactly the same symptoms as described above. The final solution took some time to work out but was to power the ReadyNas down, install the printer and then switch off WS Discovery, Bonjour and SLP on the printer. With these off, it will happily co-exist with the ReadyNAS. I've tried turning network discovery off on the laptop but it didn't help.

All ideas welcome!
Message 1 of 8
StephenB
Guru

Re: New Win 8 laptop causes ReadyNas Duo to disconnect

Are all devices configured to use DHCP?
Message 2 of 8
laser162644
Aspirant

Re: New Win 8 laptop causes ReadyNas Duo to disconnect

Yes, the router is acting as the DHCP server. I did have the laptop working successfully for a day but then must have changed something and now it causes this problem with the ReadyNas.
Message 3 of 8
StephenB
Guru

Re: New Win 8 laptop causes ReadyNas Duo to disconnect

From your description it sounds like the NAS is still on the network, since the G580 can reach the folders.

Does anything change if you assign the G580 a static IP address?
Message 4 of 8
laser162644
Aspirant

Re: New Win 8 laptop causes ReadyNas Duo to disconnect

No, that doesn't make any difference. The G580 can only 'see' the network share for about a minute, after which it becomes unavailable to all the computers on the network. Clearly, it's something the G580 does a short while after connecting to the network - but what? Are there any WIN8 services that might ce causing this?
Message 5 of 8
StephenB
Guru

Re: New Win 8 laptop causes ReadyNas Duo to disconnect

After it fails, can you log into the NAS with your browser?
Message 6 of 8
laser162644
Aspirant

Re: New Win 8 laptop causes ReadyNas Duo to disconnect

No - once it falls over, that's it. It needs a complete re-start (with the laptop off the network) to get it up and running again.
I've now done some more testing.
If I start the laptop in safe mode, all is well. I can connect to the NAS and it is stable indefinitely. I then tried disabling the various startup programmes (using Task Manager) and discovered that, even with all of them disabled, a normal boot still causes the ReadyNAS to fall over after about 5 minutes. I guess I now have to look at the various background processes to see if it's one of those causing the problem. TThis could be dangerous as I don't know what most of them do!
Message 7 of 8
laser162644
Aspirant

Re: New Win 8 laptop causes ReadyNas Duo to disconnect

Finally found the problem. It's nothing to do with IP addresses or security policies. It was the crapware McAfee 30-day free trial. I've removed it and now everything works fine!
Message 8 of 8
Top Contributors
Discussion stats
  • 7 replies
  • 987 views
  • 0 kudos
  • 2 in conversation
Announcements