× NETGEAR will be terminating ReadyCLOUD service by July 1st, 2023. For more details click here.
Orbi WiFi 7 RBE973
Reply

Re: PHP scripts not processed

jum
Aspirant
Aspirant

PHP scripts not processed

I am running RAIDiator 4.2.17 on my ReadyNAS Ultra 2 Plus and have tried to install PHP according to the instructions in the Wordpress How-to installation (http://www.readynas.com/?p=213).

After step 4 and before installing Wordpress application I checked if PHP worked and it did not.

I got no faults during installation but PHP scripts are not processed, instead they are processed as a file for download.

HTML files works fine (including Frontview).

Although I am not running 4.01c1-p1 or earlier I have checked the content of HTTPD.CONF and there is a line containing "DirectoryIndex redirect.html index.html index.htm index.php".

Any suggestions?
Message 1 of 4
ppvp
Aspirant

Re: PHP scripts not processed

Any luck yet? Dealing with the same problem.
Message 2 of 4
dbott67
Guide

Re: PHP scripts not processed

Happened to me a few years ago and created this how-to: http://home.bott.ca/webserver/?p=127

*For some reason, whenever I tried to load a .php file in my browser the file would try to download rather than display. As it turns out, I needed to edit the /etc/frontview/apache/httpd.conf file to include the line in red to prevent the .php files from downloading:

LoadModule perl_module /usr/lib/apache2/modules/mod_perl.so
LoadModule apreq_module /usr/lib/apache2/modules/mod_apreq2.so
LoadModule php5_module /usr/lib/apache2/modules/libphp5.so


Not sure if it still applies, though.

-Dave
Message 3 of 4
jum
Aspirant
Aspirant

Re: PHP scripts not processed

Thanks to dbott67. I was totally stuck with this problem.

It works now on my ReadyNAS.

I have tested it with Firefox, IE and Chrome. I had a hard time with Chrome as it kept downloading my PHP test file until at cleared the cache (refresh did not work).
Message 4 of 4
Top Contributors
Discussion stats
  • 3 replies
  • 1064 views
  • 0 kudos
  • 3 in conversation
Announcements