× NETGEAR will be terminating ReadyCLOUD service by July 1st, 2023. For more details click here.
Orbi WiFi 7 RBE973
Reply

Permissions issue after upgrade

jasg
Aspirant

Permissions issue after upgrade

Hi,

I updated my readynas duo firmware to the latest 4.1.9 this morning, and now find that i've got an issue with file permissions.

I have a number of shares set as read only, and one writeable share.
Under the writeable share I have symbolic links to the other shares. (I did this so that I can set up clients to read from the read only shares, and I can write to them via the writeable share, and not have to worry about passwords).
This all worked fine until the upgrade today.

Now, in windows when I try and follow one of these symbolic links I get permission denied.
All symbolic links and shares are owned by nobody:nogroup and have full 777 permissions.

Any idea how I can fix this?

Many Thanks
J
Message 1 of 7
pugilares
Aspirant

Re: Permissions issue after upgrade

As I have seen something similar to this then I did ssh and chown'ed certain shares. After that the shares were visible in Frotview with owner/group I gave them through ssh. But then I rebooted the whole box and after reboot nobody/nogroup apeared again in Frontview.
Message 2 of 7
jasg
Aspirant

Re: Permissions issue after upgrade

Just a small update

In my writeable share with all the symbolic links to the other shares in, I can see all of the links as folders in windows.
I have read and write permission to this share.
If I try and go into one of the directories (which is actually a symbolic link) I get permission denied.
Even if the share the symbolic link points to is also writeable.

I'm guessing it's something to do with this change in the release note:
1. Updated CIFS service, works better with 2008r2 domain functionality, also includes security updates.

If possible, i'd like to be able to configure it to have the previous behaviour.

Thanks
J
Message 3 of 7
proteinnerd
Aspirant

Re: Permissions issue after upgrade

My unit automatically upgraded to 4.1.9 and now I can't even rename folders on my ReadyNas NV+

It was working fine prior to me rebooting. I got the message I should reboot the unit, so I did. The panel on the front said it was updating the FW and sure enough it upgraded to 4.1.9 from 4.1.8

Any suggestions on how to get my permissions back?
Message 4 of 7
pugilares
Aspirant

Re: Permissions issue after upgrade

Is it bug or a feature in the new firmware?

It seems for me that:

a.shares like media, backup belong to nobody/nogroup now and it's not possible for me to change it for good neithet through Frontview, neither through chown in ssh. Especially after reboot nobody/nogroup comes back.

b. folders located within the shares can be assigned to user/group through chown with no problem and keep it's owner/group after reboot.

Firmware 4.1.9.
Message 5 of 7
jasg
Aspirant

Re: Permissions issue after upgrade

Is nobody/nogroup a special user?
I'd just assumed it was the name chosen by netgear, and everything shared would have that user/group
I think my old mybook world worked like this, but that used www-data/www-data

I'm pretty sure the files always had nobody/nogroup owner
Message 6 of 7
mdgm-ntgr
NETGEAR Employee Retired

Re: Permissions issue after upgrade

nobody is the 'guest' user on Linux and 'nogroup' is the group associated with that user.
Message 7 of 7
Top Contributors
Discussion stats
  • 6 replies
  • 1049 views
  • 0 kudos
  • 4 in conversation
Announcements