× NETGEAR will be terminating ReadyCLOUD service by July 1st, 2023. For more details click here.
Orbi WiFi 7 RBE973
Reply

Re: Prevent CrashPlan service from starting automatically on reboot

InterClaw
Aspirant

Prevent CrashPlan service from starting automatically on reboot

When you reboot the NAS, CrashPlan is set to start its service, right? It will do so even if I manually stopped it with "./CrashPlanEngine stop" before rebooting, correct?

 

How do I prevent it from starting automatically on reboot? I don't want to uninstall it.

Model: ReadyNASRNDP6000|ReadyNAS Pro 6 Chassis only
Message 1 of 9

Accepted Solutions
StephenB
Guru

Re: Prevent CrashPlan service from starting automatically on reboot

If disable isn't available, then I'd either try chmod or break the symlink.  You should be able to create a new symlink later on.

View solution in original post

Message 5 of 9

All Replies
StephenB
Guru

Re: Prevent CrashPlan service from starting automatically on reboot

I think update-rc.d crashplan disable should work, using update-rc.d crashplan enable to reverse.

 

Alternatively you could try chmod -x /etc/init.d/crashplan, using chmod +x /etc/init.d/crashplan to reverse.

 

 

Message 2 of 9
InterClaw
Aspirant

Re: Prevent CrashPlan service from starting automatically on reboot

Running your first suggestion, I got this result: 

 

usage: update-rc.d [-n] [-f] <basename> remove
update-rc.d [-n] <basename> defaults [NN | sNN kNN]
update-rc.d [-n] <basename> start|stop NN runlvl [runlvl] [...] .
-n: not really
-f: force

 So I tried this: 

update-rc.d crashplan remove

... and then it said this: 

update-rc.d: /etc/init.d/crashplan exists during rc.d purge (use -f to force)

 Not sure if I should do this. What do you think Stephen? Maybe something should be changed in /etc/init.d/crashplan instead? It looks like this:

#!/bin/sh
# Linux Standard Base comments
### BEGIN INIT INFO
# Provides:          CrashPlanEngine
# Required-Start:    $local_fs $network $remote_fs
# Required-Stop:     $local_fs $network $remote_fs
# Should-Start:
# Should-Stop:
# Default-Start:     2 3 4 5
# Default-Stop:      0 1 6
# Short-Description: CrashPlan Engine
# Description:       CrashPlan backup service engine
### END INIT INFO

#############################################################
# Init script for CrashPlanEngine
#############################################################

# Defaults
SCRIPTNAME=/usr/local/crashplan/bin/CrashPlanEngine

case "$1" in
start)
        $SCRIPTNAME start
        ;;
stop)
        $SCRIPTNAME stop
        ;;
restart)
        $SCRIPTNAME restart
        ;;
force-reload)
        $SCRIPTNAME force-reload
        ;;
status)
        $SCRIPTNAME status
        ;;
*)
        echo "Usage: $0 <start|stop|restart|force-reload|status>" >&2
        exit 3
        ;;
esac
exit 0

 

Message 3 of 9
InterClaw
Aspirant

Re: Prevent CrashPlan service from starting automatically on reboot

Okay, now I'm learning things about runlevels... Seems like default runlevel for the NAS is 2? in /etc/rc2.d there's S01readynas_startup and S99crashplan. This is the only runlevel where crashplan is it seems.

 

Also seems like this update-rc.d disable is a new feature that might not be available in this semi-old Linux environment?

 

So removing is more permanent. Why is the force flag needed? Seems like S99crashplan is just a symlink to /etc/init.d/crashplan, which is the real startup script? So if I delete it from rc.d and want to restore it, can I just manually recreate the symlink in /etc/rc2.d, call it S99crashplan, pointing at /etc/init.d/crashplan, and it will work? Or is there more to it? Smiley Tongue

Message 4 of 9
StephenB
Guru

Re: Prevent CrashPlan service from starting automatically on reboot

If disable isn't available, then I'd either try chmod or break the symlink.  You should be able to create a new symlink later on.

Message 5 of 9
InterClaw
Aspirant

Re: Prevent CrashPlan service from starting automatically on reboot

Perfect. I used the chmod approach, so the system doesn't have access to run that script on boot (I'm guessing is what I did Smiley Happy).

 

I verified with ./CrashPlanEngine status after a reboot and the service stayed off.

Message 6 of 9
mdgm-ntgr
NETGEAR Employee Retired

Re: Prevent CrashPlan service from starting automatically on reboot

It's better where possible to use systemd service files rather rc.d scripts.

 

With systemd you have greater control over when the service starts, which services must start first etc.

Message 7 of 9
InterClaw
Aspirant

Re: Prevent CrashPlan service from starting automatically on reboot

Either you completely missed the point of the topic, or this is some weak phishing attempt.

Message 8 of 9
mdgm-ntgr
NETGEAR Employee Retired

Re: Prevent CrashPlan service from starting automatically on reboot

Thanks for reporting this. peterstrong was a spammer and his posts have been removed.
Message 9 of 9
Top Contributors
Discussion stats
  • 8 replies
  • 5244 views
  • 1 kudo
  • 3 in conversation
Announcements