Reply

Re: RN 102 has become very slow in transferring or accessing files

Hiryu
Aspirant

RN 102 has become very slow in transferring or accessing files

I have been using the RN102 for 2 years. It has been working well until recently.

I have a 4TB HDD installed and still have 2.2TB free with the latest firmware installed

Recently I have noticed the access time of the shared folder containing large number of files has become very long. Some folders are practically inassessible.

It appears when the number of files is fewer than certain number, it is fine.

For example, I have created a folder for photo backup. When I copy the photo to the shared folder, the files copying was normal. However, after a large number of files were copied, it becomes very slow in both copying to or accessing the folder. The transfer speed.is still fast, but there is a long pause between the files. 

I have the same problem using different computers with windows 7 or windows 8 installed.

 

 

 

 

 

Message 1 of 17

Accepted Solutions
Hiryu
Aspirant

Re: RN 102 has become very slow in transferring or accessing files

Problem solved, actually it is probably the latest firmware 6.4.1 caused the problem

The NAS seems to be working normally after I installed the 6.4.0. But I will see if problem will recur later.

 

View solution in original post

Message 12 of 17

All Replies
StephenB
Guru

Re: RN 102 has become very slow in transferring or accessing files

I'd much rather see actual firmware versions, and not just "latest".

 

What firmware version are you running?  Is Antivirus enabled?

Message 2 of 17
Artiah
Aspirant

Re: RN 102 has become very slow in transferring or accessing files

Hi @Hiryu and @StephenB  I have the same problem with a ReadyNAS N102, my firmware is 6.4.1, antivirus definition is 8/1/2016 and is enable. I want to make a SMART check to the hard drive (TOSHIBA DTO1ACA100 with 1 TB) but in the settings menú the option doesn't appear. I want to do this to discard bad function of the HD. Can you help me with this please?

 

NAS-forum.JPG

 

Many thanks in advance.

Message 3 of 17
StephenB
Guru

Re: RN 102 has become very slow in transferring or accessing files

Download the logs, and look in the zip file for smart_history.log. disk_info.log also contains it.

 

But if your system has become slow with 6.4.1, the thing to do first is disable antivirus (on system->settings->services)

 

 

Message 4 of 17
Artiah
Aspirant

Re: RN 102 has become very slow in transferring or accessing files

Hi @StephenB many thanks for your answer, I disabled the NAS antivirus and now I have more speed in the access. I left to you the logs you told me:

 

smart_history.log

 

Spoiler
model                                    TOSHIBA DT01ACA100
realloc_sect                           0
realloc_evnt                          0
spin_retry_cnt                       0
ioedc                                     -1
cmd_timeouts                       -1
pending_sect                       0
uncorrectable_err                0
ata_errors                            0
timestamp                            1366867474
time                                     2013-04-25 05:24:34

disk_info.log

 

Spoiler
Device:             sda
Controller:         0
Channel:            0
Model:              TOSHIBA DT01ACA100
Firmware:           MS2OA750
Class:              SATA
RPM:                7200
Sectors:            1953525168
Pool:               data ;
  ATA Error Count:                0
  Reallocated Sectors:            0
  Reallocation Events:            0
  Spin Retry Count:               0
  Current Pending Sector Count:   0
  Uncorrectable Sector Count:     0
  Temperature:                    35
  Start/Stop Count:               49
  Power-On Hours:                 19054
  Power Cycle Count:              49
  Load Cycle Count:               56

Do you know if Netgear have an app to do SMART checks in the ReadyNAS?

 

Many thanks in advance, cheers!

Message 5 of 17
StephenB
Guru

Re: RN 102 has become very slow in transferring or accessing files

Your SMART stats look fine.

 

You can see them in the web ui too,  Hover over the green balls on the system performance page, and you should see a scrollable pop-up. 

Message 6 of 17
mdgm-ntgr
NETGEAR Employee Retired

Re: RN 102 has become very slow in transferring or accessing files

Under System > Volumes > click on settings wheel for volume > Volume Schedule you can add a schedule to run a Disk Test.

You can also use the disk test boot menu option.

I doubt there is a problem with your disk at this time. As StephenB mentioned the SMART stats look fine.

Message 7 of 17
thcscientific
Aspirant

Re: RN 102 has become very slow in transferring or accessing files

so whats the issue thas causing this? I too have terrible accessibility using windows file explorer, but not a problem when logging in directly through ip on address bar. 

 

Message 8 of 17
BrianL
NETGEAR Employee Retired

Re: RN 102 has become very slow in transferring or accessing files

Hi thcscientific,

 

Which Firmware is running in your RN102 system? Either you disable AV or load the latest Beta Firmware (6.4.2 beta 2).

 

Looking forward to your response.

 

 

Kind regards,

 

BrianL
NETGEAR Community Team

Message 9 of 17
thcscientific
Aspirant

Re: RN 102 has become very slow in transferring or accessing files

I have a 104 running 6.4.1 and AV is on, i updated the AV and also unchecked ignor adware. Not sure which fixed it but its working better now

Message 10 of 17
BrianL
NETGEAR Employee Retired

Re: RN 102 has become very slow in transferring or accessing files

Hi thcscientific,

 

Thanks for the feedback. If in case the issue reoccurs, I suggest that you disable the AV feature.

 

 

Kind regards,

 

BrianL
NETGEAR Community Team

Message 11 of 17
Hiryu
Aspirant

Re: RN 102 has become very slow in transferring or accessing files

Problem solved, actually it is probably the latest firmware 6.4.1 caused the problem

The NAS seems to be working normally after I installed the 6.4.0. But I will see if problem will recur later.

 

Message 12 of 17
BrianL
NETGEAR Employee Retired

Re: RN 102 has become very slow in transferring or accessing files

Hi Hiryu,

 

Thanks for the feedback. For the meantime, you may now tag this thread as resolved by clicking the "Accept as Solution" button in one of the responses that you received.

 

 

Kind regards,

 

BrianL
NETGEAR Community Team

 

Message 13 of 17
AlKernc
Aspirant

Re: RN 102 has become very slow in transferring or accessing files

I tried to solve this problem for weeks, then found out that the Anti-Virus was the problem. After I disabled anti-virus the file transfers run much faster. Using Win 7 copying files to my NAS RN102. When will you fix this on 6.4.1 so I can run anti-virus and still be able to run anti-virus?  

Message 14 of 17
JennC
NETGEAR Employee Retired

Re: RN 102 has become very slow in transferring or accessing files

Hello Alkernc,

 

Welcome to the community!

 

Potential fix is still being worked on. You might want to update to the latest, 6.4.2.

 

Regards,

 

JennC
NETGEAR Community Team
Message 15 of 17
Artiah
Aspirant

Re: RN 102 has become very slow in transferring or accessing files

Hey @AlKernc don't change to the latest version. I have this one in my RN102 and with the AV still working slowly in the file access. Is much better disable the AV.

 

Cheers!

Message 16 of 17
StephenB
Guru

Re: RN 102 has become very slow in transferring or accessing files


@Artiah wrote:

Hey @AlKernc don't change to the latest version. I have this one in my RN102 and with the AV still working slowly in the file access. Is much better disable the AV.

 

Cheers!


It's true that the AV is still not fixed (and the release notes don't claim that it is).

 

But there are other reasons to upgrade to 6.4.2  For instance, it includes a few important security patches.

Message 17 of 17
Top Contributors
Discussion stats
  • 16 replies
  • 3475 views
  • 2 kudos
  • 8 in conversation
Announcements