× NETGEAR will be terminating ReadyCLOUD service by July 1st, 2023. For more details click here.
Orbi WiFi 7 RBE973
Reply

Re: RN102 disappears from network

Persilja
Aspirant

RN102 disappears from network

I got it this spring, but since I ran into some issues with the setup at the time and didn't have time to troubleshoot it then, I haven't made a concerted effort to setting it up until this last week.

What happens when I try to move stuff from an old external harddrive to the NAS (or from my desktop) is that the NAS stops responding completely after a couple of minutes - sometimes 5 minutes, sometimes 30.

The only way I have found to restart the NAS is to yank the power. (Is the "power button" on the front of the device supposed to be doing anything? It doesn't seem to).
By "stops responding" I mean that I cannot ping it, I cannot access the admin page ("Firefox can't establish a connection to the server at 192.168.1.113." Other browsers - same result).
I can't access the FTP shares or SMB shares that I have set up - the former because nothing responds at that IP. Nmap doesn't find anything alive at that IP on any port, and my router thinks that the device which used to have this IP presently is disconnected. Raidar 6.1 can't find it either.

The IP is statically set to 192.168.1.113 by DHCP from the router that the NAS is connected to (via ethernet. Yes, I've tried replacing the cable). NAS firmware version is 6.5.1, the disks are new and, when I reconnect the power to the NAS, it shows that the disks are healthy. Though it needs a 2+ hour resync every time I do that - although it usually stops responding before those 2 hours have passed.

Sometimes I wonder - and I have seen this hypothesis in other posts as well  - that the connection drops when a user tries to write a lot of data at once to the NAS. If that is the case, how do I, as the "administrator" of the family NAS, technically enforce that nobody writes a whole GB-sized folder to the NAS in one go, but dice it up in more digestible chunks?
But on the other hand, I just tried it again, without sending any data at all. This time the NAS disappeared after about 5 minutes: the IP is no longer on the network. My router can't find it, RAIDAR can't find it... I'm not sure if it is still resyncing, and if so, when it expects to be done? I guess I'll continue writing this question tomorrow - it did after all say it expected the sync to take 3(?) hours.

 

--10 hours later--

The NAS had disappeared again. I did another 'caveman reset', brought it up, and rebooted it gracefully. It kept syncing for about 90 minutes this time before it went offline again.


Since rebooting via unplugging is a particularly bad idea to do, what else can I do to reconnect safely once it does drop from the network? I know of no way of connecting a monitor and other periferials directly to the device, so I have been trying to run it headless - is there a way around that that I'm not thinking of? It has USB ports, but I don't know how to attach a monitor that way...

 

Other details about setup: The router mentioned is an AT&T/U-verse cable modem of brand "Pace"; my computer runs Fedora Linux - if absolutely needed for troubleshooting I have access to Windows computers as well. My goal for the NAS is to share documents, and to replace the aging USB-connected harddrive that has served as a backup for several years.

The good thing is that I don't have anything on the NAS yet that is not also available elsewhere.

 

Any ideas?

Model: RN102|ReadyNAS 100 Series
Message 1 of 18
bedlam1
Prodigy

Re: RN102 disappears from network

I think if I was exeperiencing your scenario, particularly as you had initial setup problems and have no problem with losing all the data on your disks, I would perform a factory default reset and start again, allowing the unit to seek updates itself,  as you cannot install 6.5 directly from some earlier versions

See here how to access the boot menu

 

BTW this will change the admin password to "password", also you have to press the blue button twice to shut down gracefully

Message 2 of 18
omicron_persei8
Luminary

Re: RN102 disappears from network

That is clearly not normal operation. I agree with @bedlam1. If you have nothing on it yet, you should do a factory default and start again.
The power being unresponsive prooves that the NAS is crashed. Otherwise, it can be used indeed.
Not everyone that owns a 102 have these issues and of course you could try to troubleshoot it. But if you have notjing on it, factory default would save you time. If you have the same issue straight after factory default, the conclusion would that there is a hardware issue, either chassis or HDDs. If you don't, it was simply software
Message 3 of 18
StephenB
Guru

Re: RN102 disappears from network


@omicron_persei8 wrote:
That is clearly not normal operation.

Totally agree here.  A factory reset is a pragmatic thing to try if the data on the NAS is easily restored.  BTW, it can also be done from the web ui (system->settings), which is a lot easier than using paper clips and counting blinking leds (esp. since you have no LCD display).

 

For a while I was seeing my RN102 lock up this way - in my case it was something done by plex (it only happened when plex was scouring the internet looking for metadata).  So it would also be relevant to know if you have any apps running.

 

What model disks are you using?  Have you checked the logs for disk errors?

 

 

Message 4 of 18
Persilja
Aspirant

Re: RN102 disappears from network

The logs contained nothing about disk errors. And no, I had no apps running.

The disks are WD Blue 1TB Desktop Hard Disk Drive - 7200 RPM SATA 6 Gb/s 64MB Cache 3.5 Inch - WD10EZEX

 

I have now made a factory reset, and it had been running continuously for maybe 8 hours.

But: then I initialized a file transfer (SMB) and within about 5 minutes the NAS disappeared again.

Model: RN10200|ReadyNAS 100 Series 2- Bay (Diskless)
Message 5 of 18
Persilja
Aspirant

Re: RN102 disappears from network

Folders have been configured to be accessible via: SMB, NFS, and FTP. In addition, Rsync, HTTP, HTTPS, and Upnp(?) are turned on, but not used for any actual folders (yet). I guess the last one is something internal that I'm adviced not to turn off.

Message 6 of 18
StephenB
Guru

Re: RN102 disappears from network


@Persilja wrote:

 ...I guess the last one [upnp] is something internal that I'm adviced not to turn off.


http://whatis.techtarget.com/definition/Universal-Plug-and-Play-UPnP

Message 7 of 18
Persilja
Aspirant

Re: RN102 disappears from network

Probably time to see if the device still is under warranty.

Message 8 of 18
StephenB
Guru

Re: RN102 disappears from network

Did you try the factory reset?

Message 9 of 18
Persilja
Aspirant

Re: RN102 disappears from network

Yes I did a factory reset (please see my second post above).

 

In short, I did the factory reset and let it run for about 8 hours. It was still up.

Next, I attempted to move my files onto the NAS. I attempted to move individual subfolders - maybe 100MB to 500MB each - and after 5 minutes  of moving files the NAS was gone again.

I did the experiment twice: once moving it via the SMB protocol, and once via FTP. Same result: the NAS disappears after 5 or 10 minutes.

Message 10 of 18
StephenB
Guru

Re: RN102 disappears from network

The warranty is 3 years from purchase, so that is not an issue.

 

There is 90-day phone support also - which might be up, so check on that (and take action right away if you are close).

Message 11 of 18
Retired_Member
Not applicable

Re: RN102 disappears from network

Message 12 of 18
Persilja
Aspirant

Re: RN102 disappears from network

Tried the beta. Would that include a factory reset again?

 

I haven't done that yet, but: after installing 6.5.2 beta and rebooting it stopped responding to FTP after about 3 minutes of file transfers. I can no longer ping it either, so just the firmware upgrade made no difference.

Message 13 of 18
Persilja
Aspirant

Re: RN102 disappears from network

Marking as "solved" - well, at least worked-around. So far it appears that if I limit myself to using FTP, and enforce rate limits (presently 1500kB/s*), it appears to be stable. I have been able to run file transfers continuously for over 15 minutes now, which is a first.

 

Tomorrow morning I'll experiment with SMB and a Windows system, and my Linux system with NFS, to see if the Linux implementation of SAMBA is to blame. Speaking of that, is there a way to get the NAS to enforce rate limits for other protocols than FTP?

 

 

*I also tried 2000kB/s, but then the NAS admin page disabled FTP on me. What is the highest permitted speed? Seems to be somewhere between 1500 and 2000kB/s.

Message 14 of 18
Persilja
Aspirant

Re: RN102 disappears from network

Well, the lower speed worked better - 10 hours instead of 2-10 minutes, but it just disappeared again. Time to open a formal support case, I guess.

Message 15 of 18
Persilja
Aspirant

Re: RN102 disappears from network

Sent an email to customer care on Friday, since the online form didn't seem to work properly.

Message 16 of 18
Persilja
Aspirant

Re: RN102 disappears from network

A week later, I'm still waiting for the customer service people to respond. Any other recommendations for what email address to use? The "contact us" section only provides customer.service@netgear.com, and I'm giving up now on actually getting an answer from that account.

Message 17 of 18
gksolutions
Aspirant

Re: RN102 disappears from network

I am also experiencing similar issues with my NAS RN 516 over the past few weeks.  

 

No matter what I do, or if I setup SMB/NFS the computers on my local network can no longer see the NAS RN 516.  Constantly having to force-boot the machine in order to access my files which work for a few minutes, but then I lose all connections to it, including Frontview. Failed attempts to shutdown/restart/reboot via Frontview, RAIDar, or by double-pressing the front button.  Can only force-boot the machine by holding down the front button until powered-off and then re-pressing button or by disconnecting-reconecting power cable and pressing front button.

 

I have another NAS (Pro 6) on the same local network, workgroup and subnet and it works fine.  Both machines have been updated to firmware 6.5.2, though I was experiencing this issue about 2/3 weeks prior to updating.  Both machines are running Anti-Virus Plus and Transmission for Readynas and the RN516 also is running Plex.  Have disabled ReadyCloud and Replicate on both machines to see if this resolves the issue.

 

All shares have:

  • SMB set to allow Read/Write to everyone and to allow anonymous access and DFS Root disabled
  • SMB is enabled an all machines on local network (NASes, desktops) are set with 'NL' workgroup name
  • NFS set to allow Read/Write to AnyHost with Root Access to IP Address 192.168.0.0/24 and async disabled
  • NFS Settings have NFS enabled with 12 threads and NFSv4 disabled (enabling or disabling NFSv4 did not resolve issue)
  • AFP, FTP, iTunes and SNMP is disabled
  • HTTP access to specific user groups and webdav enabled
  • No snapshots are being taken on any share
  • File Access has Folder Owner and Folder Group set to guest with rename and delete privileges to non-owners enabled
  • File Access has Read/Write enabled for Everyone, Folder Owner and Folder Group
  • Home Folders are disabled and Not Shared
  • UPnP is On
  • Anti-Virus is enabled
  • SSH is enabled with password authentication (SSH key has been downloaded then added to admin and to my 'local username')
  • HTTPS is enabled with additiona ports (RN516: port 8082  |  Pro 6: port 8083) and port forwarding setup on router
  • SSL Key Host is set (RN516: 192.168.0.2  |  Pro 6: 192.168.0.3)
  • RSync Setting is enabled
  • and finally both NASes including two local desktops have their ethernet Cat-6 cables plugged into a TP-Link (TL-SG1016 V10) Gigabit Switch and the switch is connected directly to the router.  (hard reset of entire network and router/switch did not resolve issue)
  • Both have HTTP Admin disabled (enabling or disabling this setting did not resolve issue)
  • Both have WOL enabled and no UPS
  • Both machines have a single RAID-0 volume at approx. 75% capacity
  • RN516 has a redirect default web access folder set
  • RN516 has DLNA  and Auto Scan enabled but with TiVo disabled
  • RN516 has Disk Spin-Down enabled after 5 minutes - Pro 6 displays red warning that fan is not working if this is enabled even though the fans sound like they are running as normal
  • ...and most shares have RSync with Read/Write default access and password protection enabled
  • ...and a few shares have DLNA enabled for videos

Both machine have static IPv4 addresses (RN516: 192.168.0.2  |  Pro 6: 192.168.0.3) / Subnet: 255.255.255.0:

  • with both network ports on each bonded and in Adaptive Load Balancing Mode
  • both are set at 1500 MTU (have disabled Jumbo Packets which was previously on until experiencing this issue)
  • both are configured to Using DHCP for IPv6
Model: RN51600|ReadyNAS 516 6-Bay
Message 18 of 18
Top Contributors
Discussion stats
  • 17 replies
  • 4456 views
  • 4 kudos
  • 6 in conversation
Announcements