× NETGEAR will be terminating ReadyCLOUD service by July 1st, 2023. For more details click here.
Orbi WiFi 7 RBE973
Reply

Re: RN3138 (fw 6.10.5) - became unresponsive after enabling sleep hard drive during inactivity featu

CMDIT
Aspirant

RN3138 (fw 6.10.5) - became unresponsive after enabling sleep hard drive during inactivity feature

After enabling the "sleep hard drive during inactivity feature" the unit stopped responding, web page does not work, cannot ping IP addresses, Raidar does not detect it. The unit responds normally with no drives inserted or other drives inserted. The OS reinstall feature and firmware reinstall do not resolve the issue. A factory default will resolve the issue but we need to maintain the data on the unit. This seems to be a bug with firmware 6.10.5. 

 

Is there a way change this setting or revert to a previous firmware usnig the tech debug option?

Model: RN3138|ReadyNAS 3138 Series 4- Bay (Diskless)
Message 1 of 8
StephenB
Guru

Re: RN3138 (fw 6.10.5) - became unresponsive after enabling sleep hard drive during inactivity featu


@CMDIT wrote:

After enabling the "sleep hard drive during inactivity feature" the unit stopped responding,  This seems to be a bug with firmware 6.10.5. 

 


FWIW, I do use that option with 6.10.5 hotfix 1 and have no issue with it.  Though I do not have an RN3138.

 

Firmware can be downgraded in tech support mode - but I think the first step is to see if you can boot up into tech support mode, and log into the NAS. 

Message 2 of 8
CMDIT
Aspirant

Re: RN3138 (fw 6.10.5) - became unresponsive after enabling sleep hard drive during inactivity featu

Yes, I am able to get into tech support mode, is there a way to disable that feature there? If not, how do I revert to a previous firmware?

Message 3 of 8
StephenB
Guru

Re: RN3138 (fw 6.10.5) - became unresponsive after enabling sleep hard drive during inactivity featu


@CMDIT wrote:

Yes, I am able to get into tech support mode, is there a way to disable that feature there? 


Likely there is, but I am not certain what it is.  You might list /etc/hdparm.conf and see if it is in there.

 


@CMDIT wrote:

If not, how do I revert to a previous firmware?


I haven't needed to do this myself, but I believe you  first copy the firmware .img file to /root and then do

echo /root/name_of_image_file  >  /etc/.flash_update

Then reboot the NAS (the reboot command should work).

 

Message 4 of 8
CMDIT
Aspirant

Re: RN3138 (fw 6.10.5) - became unresponsive after enabling sleep hard drive during inactivity featu


@StephenB wrote:

@CMDIT wrote:

Yes, I am able to get into tech support mode, is there a way to disable that feature there? 


Likely there is, but I am not certain what it is.  You might list /etc/hdparm.conf and see if it is in there.

 

That file does not exist. Any other ideas?

 


@CMDIT wrote:

If not, how do I revert to a previous firmware?


I haven't needed to do this myself, but I believe you  first copy the firmware .img file to /root and then do

echo /root/name_of_image_file  >  /etc/.flash_update

Then reboot the NAS (the reboot command should work).

 


 

Message 5 of 8
StephenB
Guru

Re: RN3138 (fw 6.10.5) - became unresponsive after enabling sleep hard drive during inactivity featu


@CMDIT wrote:

You might list /etc/hdparm.conf and see if it is in there.

That file does not exist. Any other ideas?

Odd, as it is on all my NAS. But looking at the ones with spindown enabled, it doesn't seem to be controlled from there.  It looks like the NAS manages spindown with rnutil.  But I'm not seeing where the spindown schedule is stored - it might be in the ReadyNAS database somewhere.

 

Did you enter

rnutil chroot

after you got into tech support mode?  That will start RAID, and chroot in one step.

 

After that you can try mounting the NAS data volume, and see if that works.  

btrfs device scan
btrfs fi show
mount /dev/md127 /data

Note the above assumes your volume is named data (as it would be if you are using XRAID).

 

@CMDIT wrote: Any other ideas?

Use journalctl to look at the NAS error logs, and see if you can find the start up errors.

 

 

 

Message 6 of 8
Sandshark
Sensei

Re: RN3138 (fw 6.10.5) - became unresponsive after enabling sleep hard drive during inactivity featu

It is my understanding that drive spin-down has been disabled on all rackmount units.  I don't know when that happened.  It stll shows up as an option on my legacy 12-bay units converted to OS6, but does not seem to actually do anything.  Also, I'm still running 6.9.6 on them.

Message 7 of 8
StephenB
Guru

Re: RN3138 (fw 6.10.5) - became unresponsive after enabling sleep hard drive during inactivity featu


@Sandshark wrote:

It is my understanding that drive spin-down has been disabled on all rackmount units.  I don't know when that happened.  It stll shows up as an option on my legacy 12-bay units converted to OS6, but does not seem to actually do anything.  Also, I'm still running 6.9.6 on them.


FWIW, even if spindown is working, it doesn't seem likely that it is actually the cause of your problem.  Spindown wouldn't kick in until well after boot ( I think the default threshold is 5 minutes) - and your NAS isn't booting at all.  So I am thinking that something else might be wrong. 

 

That is one reason for looking in journalctl, and also one reason I suggested trying to mount the data volume in tech support mode.

 

It is also possible to test the disks with smartctl.

Message 8 of 8
Top Contributors
Discussion stats
  • 7 replies
  • 1240 views
  • 0 kudos
  • 3 in conversation
Announcements