× NETGEAR will be terminating ReadyCLOUD service by April 1st, 2023. For more details click here.
Reply

ReadyNAS RN628X stuck booting after confirming reboot to install firmware 6.10.0

ronaldvr2132
Apprentice

ReadyNAS RN628X stuck booting after confirming reboot to install firmware 6.10.0

I have seen several people having the same issue and reading about a USB recovery option or something. My RN628X won't boot nor does the boot menu can be opened with the option to press the reset buton and power up the device. It is doing the same and that is shwoing Booting... and that is it. I left it on for more then 24 hours but nothing is happening. Can someone advise me how to bring my RN628X back alive?

Message 1 of 61
JohnCM_S
NETGEAR Employee Retired

Re: ReadyNAS RN628X stuck booting after confirming reboot to install firmware 6.10.0

Hi ronaldvr2132,

 

Is the NAS detected on RAIDar? If yes, please check if you can download the logs then provide it to us. We will check what caused the issue. You may provide it to us by uploading it to Google Drive then PM me the download link.

 

You can also do an OS reinstall and see if it will fix the issue. For the steps on how to access the boot menu and select OS reinstall, you can visit this link.

 

Regards,

JohnCM_S
NETGEAR Community Team
Message 2 of 61
ronaldvr2132
Apprentice

Re: ReadyNAS RN628X stuck booting after confirming reboot to install firmware 6.10.0

Hi JohnCM_S thank you for your reply. No  the RN628X is not visible via Raidar and as such I can't download the logs. I also tried to come into the boot menu to do a OS reinstall but the method in the link does not work. I have shutdown the RN628X via the power button on the front side of the device (while it said Booting...) and then pressed the reset button with a paperclip and switched the power back on via the front switch. Nothing happended still showing Boot... and not a boot menu or something. Very annoying this as I just did the firmware udpated that was suggested by the RN628X when I logged in on it. Then I did a reboot to install. The first time the device came up but still said I should do a formware upgrade which I did again and the second time it got stuck in Booting.... Very annoying that this happened. The RN628X was working fine untill I tried to update the firmware as suggested by the RN628X. Hope to get guidance on how to get the RN628X back online without losing data and configuration information.

Message 3 of 61
JohnCM_S
NETGEAR Employee Retired

Re: ReadyNAS RN628X stuck booting after confirming reboot to install firmware 6.10.0

Hi ronaldvr2132,

 

I would like to gather additional information regarding this issue:

 

1. Have you tried doing the USB boot recovery using 6.10.0 firmware?

2. Are you getting the same issue if there are no drives inside the NAS? 

3. What was the firmware of the NAS prior to updating it?

 

Regards,

JohnCM_S
NETGEAR Community Team
Message 4 of 61
ronaldvr2132
Apprentice

Re: ReadyNAS RN628X stuck booting after confirming reboot to install firmware 6.10.0

Hi JohnCM_S,

 

Here the answers on your questions:

1. How does this UBS boot recovery work? Seems as a good solution to try, but I have not done this before.

2. Have not tried this. Will try this when 1. is not succesfull;

3. I was running the latest firmware before 6.10.0 (6.9.5. Hotfix 1)

Message 5 of 61
JohnCM_S
NETGEAR Employee Retired

Re: ReadyNAS RN628X stuck booting after confirming reboot to install firmware 6.10.0

Hi ronaldvr2132,

 

Thanks for the feedback. You may just update this thread of what will be the result.

 

Regards,

JohnCM_S
NETGEAR Community Team
Message 6 of 61
ronaldvr2132
Apprentice

Re: ReadyNAS RN628X stuck booting after confirming reboot to install firmware 6.10.0

Hi JohnCM_S thanks for your reply. Do you have the instructions with regards to the USB recovery method for me? Hopefully it works without having to come into the boot menu as that does not seem to work and also the RN628X is not visible in RAIDar.

Message 7 of 61
JohnCM_S
NETGEAR Employee Retired

Re: ReadyNAS RN628X stuck booting after confirming reboot to install firmware 6.10.0

Hi ronaldvr2132,

 

Here is an article on how to do a USB Boot Recovery on the OS6 units.

 

Regards,

JohnCM_S
NETGEAR Community Team
Message 8 of 61
ronaldvr2132
Apprentice

Re: ReadyNAS RN628X stuck booting after confirming reboot to install firmware 6.10.0

In the meantime I have tried to do the USB recovery method as described in the document, I have disconnected the drives and I have tried to come into the boot menu by pressing the reset button while doing a power on with the power switch at the back of the RN628X. Nothing helps. After turning the power on I see welcome and then Booting... and that keeps there for more than 24 hours and nothing I do does seem to influence this. This is my back-up and I am leaving this location where my back-up is stored tomorrow and it needs to be alive by tomorrow. I am really annoyed that a firmware update that was suggested via the webinterface on my RN628X seems to cause these isssues! Is this tested properly before it it brought online by Netgear and how can it be that the solutions does not seem to work? Hope to get some advise what I can do to get my RN628X online without data or configuration loss.

Message 9 of 61
JohnCM_S
NETGEAR Employee Retired

Re: ReadyNAS RN628X stuck booting after confirming reboot to install firmware 6.10.0

Hi ronaldvr2132,

 

You can connect a console cable to the NAS so you can see what it says. You may provide to me the console logs via PM so we can check it as well and provide on how to fix it.

 

If you still have support warranty on the NAS, you can also contact NETGEAR support so they can fix it as well.

 

Regards,

JohnCM_S
NETGEAR Community Team
Message 10 of 61
ronaldvr2132
Apprentice

Re: ReadyNAS RN628X stuck booting after confirming reboot to install firmware 6.10.0

How does that work a console cable and how can I get info out of it?

The RN628X is from the end of January 2017 and I am not sure if I still am entitlted to support. As this is celearly caused by the firmware upgrade process as the RN628X was working fine I guess it should be covered by support but for me the most important is that I get my RN628X back on line as soon as possible. Hope I can get these logs out of the RN628X with a console cable but please let me know what such a cable is and how I can get then the logs out of the RN628X. And thank you for your assistance JohnCM_S which is very much appreciated.

Message 11 of 61
JohnCM_S
NETGEAR Employee Retired

Re: ReadyNAS RN628X stuck booting after confirming reboot to install firmware 6.10.0

Hi ronaldvr2132,

 

There is a micro USB console connector (marked as UART) at the back panel of the chassis. You can connect a PC to that port using a micro USB cable. In case you need the driver, you can download it here.

 

Once the PC is connected, open a terminal emulation program (e.g. PuTTY) to the COM port assigned by your PC to the ReadyNAS console. You can use these following settings:

 

Speed: 115200 baud

Data bits: 8

Stop bits: 1

Parity: None

Flow control: None

 

Once you have done that, you can start the connection then power up the NAS then let it boot.

 

Regards,

JohnCM_S
NETGEAR Community Team
Message 12 of 61
ronaldvr2132
Apprentice

Re: ReadyNAS RN628X stuck booting after confirming reboot to install firmware 6.10.0

Hi JohnCM_S at the place with the descirption UART there is a solit black square. It is not someting where I can put a Micro USB cable in. Am I looking at the right place on the chassis?Photo_chassis_RN628X.jpg 

Message 13 of 61
StephenB
Guru

Re: ReadyNAS RN628X stuck booting after confirming reboot to install firmware 6.10.0


@ronaldvr2132 wrote:

Hi JohnCM_S at the place with the descirption UART there is a solid black square. It is not someting where I can put a Micro USB cable in. Am I looking at the right place on the chassis? 


It is the right place.  You pull off the black square.

Message 14 of 61
ronaldvr2132
Apprentice

Re: ReadyNAS RN628X stuck booting after confirming reboot to install firmware 6.10.0

I have connected the console cable and installed the Windows 7 driver(s) on my Windows 7 computer and was not able to get any data from the ReadyNAS via Putty or free serial monitor. After this I switched to a Windows 10 computer on which I installed the Windows 10 driver (as there was only one universal driver for Windows 10) and connected the cable. The same as in Windows 7 in device manager you can see the port and everything seems to be working but there is not data coming from the RN628X. In free serial monitor it automatically selects the right com port but it says that it did not receive any bytes. How frustrating this is!

Message 15 of 61
ronaldvr2132
Apprentice

Re: ReadyNAS RN628X stuck booting after confirming reboot to install firmware 6.10.0

Is there any news with regards to my booting issue?

Message 16 of 61
JohnCM_S
NETGEAR Employee Retired

Re: ReadyNAS RN628X stuck booting after confirming reboot to install firmware 6.10.0

Hi ronaldvr2132,

 

Have you tried rebooting the NAS while the serial connection is open? You will need to reboot the NAS so you can get data from the console while the NAS is booting.


Regards,

JohnCM_S
NETGEAR Community Team
Message 17 of 61
ronaldvr2132
Apprentice

Re: ReadyNAS RN628X stuck booting after confirming reboot to install firmware 6.10.0

Hi JohnCM_S yes I did this and it seems that no data is being transmitted by the RN628X. As far as I can tell the connection with the PC is OK.

Message 18 of 61
JohnCM_S
NETGEAR Employee Retired

Re: ReadyNAS RN628X stuck booting after confirming reboot to install firmware 6.10.0

Hi ronaldvr2132,

 

What do you see on the console output? Is it just a blank page?

 

You may also try using a different USB cable.

 

Can you also provide a screenshot of your device manager (showing the COM port) and your Putty settings as well?

 

Regards,

JohnCM_S
NETGEAR Community Team
Message 19 of 61
ronaldvr2132
Apprentice

Re: ReadyNAS RN628X stuck booting after confirming reboot to install firmware 6.10.0

Hi JohnCM_S I will give it a try but can you give some more guidance on how this works with Putty? I have put in the correct settings, the device manager shows the com port as being active, in the com port settings and in Putty I have put in the correct settings (115200,8,1,no,no) and when I press open nothings happens. Not sure if this is something I did wrong so therefore the question how should I use Putty and set-up the USB to Serial connection etc. When I connect the USB cable I do get an additonal COM port in device manager which is going away when I disconnect the USB cable so I guess it works, but I don't get anything into Putty nor does the other tool I installed provide any output. This is really annoying as this should not have happened and it has taken me already a lot of time and negative energy!

Message 20 of 61
JohnCM_S
NETGEAR Employee Retired

Re: ReadyNAS RN628X stuck booting after confirming reboot to install firmware 6.10.0

Hi ronaldvr2132,

 

You can try these steps:

 

1. After opening Putty, click the Serial radio button.

2. Type the COM address (e.g. COM1, COM2) to which the NAS is attached to on the Serial Line box.

3. On the Speed box, type the baud rate of 115200.

4. Open the connection then boot up the NAS.

 

Regards,

JohnCM_S
NETGEAR Community Team
Message 21 of 61
ronaldvr2132
Apprentice

Re: ReadyNAS RN628X stuck booting after confirming reboot to install firmware 6.10.0

Hi JohnCM_S step 4: "Open the connection then boot up the NAS" does not work. When I have the correct settings for the serial communication and have the Com port that shows up in the device manager and press open nothing happens. I guess another screen should pup up or is this not the expected behaviour? Again nothing hapens when I press open in Putty.

Message 22 of 61
JohnCM_S
NETGEAR Employee Retired

Re: ReadyNAS RN628X stuck booting after confirming reboot to install firmware 6.10.0

Hi ronaldvr2132,

 

Okay. Thanks for that feedback. Can you tell me what happened when you tried the USB boot recovery before? Does it have the same status of 'Booting...'?

 

Also, have you tried a different USB drive as well?


Regards,

JohnCM_S
NETGEAR Community Team
Message 23 of 61
ronaldvr2132
Apprentice

Re: ReadyNAS RN628X stuck booting after confirming reboot to install firmware 6.10.0

Yes the status remains Booting... Pressing the reset button at the back does not help to come into the boot menu and the USB recovery method does not seem to work as well. Even when the USB disk is not working I would expect some kind of change on the display to the message Booting..., but nothing happens! As to the instruction of the USB recovery method: this is not very clear by the way for the RN620 series. It says in the provided link to the document:

 

"3. Press and hold the Backup button, then power on the ReadyNAS system and continue to hold the Backup button for up to 15 seconds, depending on your ReadyNAS model.
- If your ReadyNAS system is an RN420, RN520, or RN620 series:
After powering on the ReadyNAS system, wait for the backlight on the navigational buttons to turn off.
Instead of the Backup button, press and hold the OK button (the center of the navigational buttons) for up to 30 seconds, until the LCD confirms that the ReadyNAS is attempting to boot from the USB drive."

 

For me this seems sequential: first press and hold the non existing Backup button when powering on and then after powering on wait for the backlight to go off.... So I gues only the last items should be followed and that is what I did. I switched on the RN628X waited untill the backlight was off and then pressed the middle dot for a very long time while and this all with the USB recovery key inserted in the front USB port. Again nothing happened and the RN628X is only showing Booting...

One thing I did not mention is that there seems to be some activity on the hard disks (also still after 24 hours), but not a lot though.

Message 24 of 61
zeke561
Guide

Re: ReadyNAS RN628X stuck booting after confirming reboot to install firmware 6.10.0

I don't want to hijack this thread, but I have the same problem. My model is 524X. In my case it rebooted once but did not show the upgrade, then  I tried to reboot again, and I got to the perpetual booting... display. So rereading the previous posts, my situation sounds identical.

Message 25 of 61
Top Contributors
Discussion stats
  • 60 replies
  • 2829 views
  • 2 kudos
  • 4 in conversation
Announcements