× NETGEAR will be terminating ReadyCLOUD service by July 1st, 2023. For more details click here.
Orbi WiFi 7 RBE973
Reply

Readynass RN104 - hot swap problem #26498818

loky5
Aspirant

Readynass RN104 - hot swap problem #26498818

Hello from France

 

I have a readynas 104 with 4 HDD (3x3To + 1x1To ~6.3To only one Volume with X-Raid)

I bought a new 3To HDD to replace the 1To. I did an hotswap, but wrong disk, so I let it rebuilt the raid properly.

 

Then, next try, I replace the good one, but nothing happened : no sync, but the New 3To HDD is online, SMART OK.

In the Volume page, I see the new volume in black, the 3 old 3To in red. Seems the Raid is gone.

Nothing change at reboot.

 

So I tried to put back the 1To hoping it would rebuild the raid. Nothing happend once more.
But at reboot, the LED panel shows "Err Used Disk".

 

I have updated the firmware. 

But maybe it was a bad idea.

 

If someone could give me advises, it would be great.

At least, my coworker told me about a Linux software to recreate the raid in order to backup my data, and then recreate the volume properly. 

 

 

There is some screenshots (in french) :

2016-02-21 12_01_14-ReadyNAS - log.png

2016-02-21 12_01_57-ReadyNAS - volume.png

 

Thanks for reading.

Model: RN10400|ReadyNAS 100 Series 4- Bay (Diskless)
Message 1 of 10
StephenB
Guru

Re: Readynass RN104 - hotswap problem

I suggest contacting netgear support (support.netgear.com), though they likely will charge.

 

Alternatively do a factory default of the NAS with all the 3 TB disks in place - which requires you to set up the NAS again and reload all the data from backup.

Message 2 of 10
lundmilo
Luminary

Re: Readynass RN104 - hotswap problem

I think that if you first pulled the wrong disc and then try to use it in another bay, you have to format it beforehand, so 's the NAS sees it as a previously used disc.
Message 3 of 10
StephenB
Guru

Re: Readynass RN104 - hotswap problem


@lundmilo wrote:
I think that if you first pulled the wrong disc and then try to use it in another bay, you have to format it beforehand, so 's the NAS sees it as a previously used disc.

If he doesn't have a backup he should contact support.  In the screen shot, none of the volumes are functioning (including the original xraid volume).

 

 

Message 4 of 10
loky5
Aspirant

Re: Readynass RN104 - hotswap problem

Thank you for the replies.

I have opened a ticket for support.

 

But I tried lundmilo's idea :

I pulled out the disk 4, replaced it with the new 3To nothing happened, for sure.

I waited a couple of hour, and I replaced it with the disk 4. And now it resyncing. I don't understand why or what...

If it resyncs, it must know a RAID is lying down there

 

2016-02-22 07_57_53-ReadyNAS - resync.png

Message 5 of 10
cpu8088
Virtuoso

Re: Readynass RN104 - hotswap problem

just destroy the data-0 and data-1

 

it should rebuild under x-raid

 

 

Message 6 of 10
StephenB
Guru

Re: Readynass RN104 - hotswap problem


@cpu8088 wrote:

just destroy the data-0 and data-1

 

it should rebuild under x-raid

 


I think it is very likely that the data will be lost.  

 

Which is why (yet again) I am suggesting support.netgear.com if the OP has no backups.  

 

The more things you try on your own, the more difficult the fix becomes.  So unless you are skilled and know what you are doing, it is best to engage support early - and not do more damage.

Message 7 of 10
mdgm-ntgr
NETGEAR Employee Retired

Re: Readynass RN104 - hotswap problem

I agree with StephenB. Don't try to fix this yourself and contact support.

Message 8 of 10
loky5
Aspirant

Re: Readynass RN104 - hot swap problem #26498818

Thank you for the advices.

I'm IT network administrator, and don't know so much about stockage solutions.

I don't think the volumes suppression is a good thing either.

 

Support wanted me to do this :

- do a factory reset with only the new 3To HDD.

- add the 3 old 3To HDD to reload the volume 

- the new one have to resync

 

At the moment, it didn't work totaly : The new one created a new working volume, but it reload the 3 old "corrupted" (I think) volumes and did not resync.

 

I will post the next steps.

Thanks for following this case.

 

2016-02-23 23_30_27-ReadyNas - volume.png

Message 9 of 10
Whiskeypod
Aspirant

Re: Readynass RN104 - hot swap problem #26498818

Did you ever manage to resolve this with support and get your data back?

Message 10 of 10
Top Contributors
Discussion stats
  • 9 replies
  • 4006 views
  • 0 kudos
  • 6 in conversation
Announcements