× NETGEAR will be terminating ReadyCLOUD service by July 1st, 2023. For more details click here.
Orbi WiFi 7 RBE973

Secure delete on Ultra2?


Secure delete on Ultra2?

I have an Ultra2 running 4.2.17-T2. It replaced an older Duo. The Duo had 2x1TB drives that I'd like to completely wipe before I sell it.

I know that I could take the drives out of the Duo, plug them into my PC via USB dock and run Eraser on them. But that takes forever even with a simple 1-pass pseudorandom wipe, and I don't like leaving my computer on overnight if possible. I'd like to put the drives in my USB dock, mount them on the Ultra2, and run the delete command on the Ultra2 since it's on 24/7 anyways.

I tried to install the secure-delete package with 'apt-get install secure-delete', but I get:

Ultra2:~# apt-get -f install secure-delete
Reading package lists... Done
Building dependency tree... Done
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
squeezeboxserver: Depends: sox but it is not going to be installed
Depends: libvorbisenc2 but it is not going to be installed
Depends: libvorbisfile3 but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

I do not want to mess with the libs on which squeezeboxserver depends, as it has nothing to do with secure-delete. I've tried a bunch of apt-get flags but can't figure out how to get it to install the secure-delete package so that I could wipe a USB-attached drive. What's the magic apt-get command? Will the secure-delete package do what I think it will, or am I barking up the wrong tree?

Or maybe there's another way. Posts I see on the forum say that the Ultra can securely erase disks during a factory reset. I am not going to reset the Ultra just to erase some disks, but if the NAS can securely erase there's got to be something in the CLI that I can to wipe a USB-attached drive. Right?

Message 1 of 2

Re: Secure delete on Ultra2?

I had the same issue on my ReadyNAS Duo. Turns out it is due to a dodgy addon (I think TwonkyMedia Server did it for me) I installed that obviously had frigged with apt's database somehow, annoyingly this then stops you from installing anything else!

It's actually quite easy to fix, just run the command it gives you in the error message!

apt-get install -f
Message 2 of 2
Top Contributors
Discussion stats
  • 1 reply
  • 0 kudos
  • 2 in conversation