× NETGEAR will be terminating ReadyCLOUD service by July 1st, 2023. For more details click here.
Orbi WiFi 7 RBE973
Reply

Re: cannot access admin page 'Secure Connection Failed'/'unsupported protocol

Luuta_Scooter
Aspirant

cannot access admin page 'Secure Connection Failed'/'unsupported protocol

A recent change with the Local Server Settings of older Readynas devices meant that Today I Was Locked Out Of the Admin Page Of My Readynas Ultra 4. I Know It's An Old Model, But I've Not Been Able To Afford A New Device Since Buying This One Back In 2012. 

 

I've Read That There Is A Way To Unofficially Update It To OS6, Solving The Issue, but To Do So Requires Access To The Admin Page To Run The Bin File, so It's A Catch 22. 

 

I Understand That The Security Issue Arises From The Access Being Local, So The Security Certificate Can't Be Verified And Is Out Of Date Anyway. 

 

It's Not An Issue With Security Software.

 

I'm Sure I Can't Be The Only One Who Has Suddenly Found Themselves Unable To Access The NAS Settings And Therefore Wondered If Netgear Will Provide A Fix Despite The Old Devices Being Out Of Warranty. It Will Be At Least Another Year Before I Can Afford A New Netgear NAS because I Lost My Job 10 years Ago. 

 

I Heard That An Old Version Of A Web Browser, Not Chrome, Might Allow Access. IfThis Is True, Can Anyone Point Me To A Site Where I Can Download It? 

 

My Computer Has Also Started Losing Connection With The NAS Multiple Times During The Day, Which I Take To Be A Symptom Of The New Net Security Measures. I Have To Remap The NAS Directories At Least Once A Day As A Result. SoAny Solution Would Be Gratefully Appreciated.

 

Sorry For The Typos, The Form Isn't AddingAutomatic Spaces And Keeps Capitalising Everything.

 

AnyHelp Would Be Gratefully Received.

 

Luuta

 

 

 

 

Model: RNDU4000|ReadyNAS Ultra 4 Chassis only
Message 1 of 8

Accepted Solutions
StephenB
Guru

Re: cannot access admin page 'Secure Connection Failed'/'unsupported protocol


@Luuta_Scooter wrote:

Have Tried Firefox Portable Going Back To Version 80, and Although It's LettingMe Into Admin Page/Shares, ThePage Is Blank (No Shares Found) And That'sTheOnly Tab It's Showing. Looks Like I'm Stuffed.


You don't want to access https://nas-ip-address/shares

 

Entering just https://nas-ip-address will redirect to /shares - so make sure you explicitly enter https://nas-ip-address/admin  

View solution in original post

Message 5 of 8

All Replies
StephenB
Guru

Re: cannot access admin page 'Secure Connection Failed'/'unsupported protocol


@Luuta_Scooter wrote:

 

I Understand That The Security Issue Arises From The Access Being Local, So The Security Certificate Can't Be Verified

No. It's true that the self-signed certificate on the NAS can't be verified, but there is still a way to click through that problem and connect anyway.

 

The problem is that the old NAS use a protocol called TLS version 1.0.  This is outdated, and the browsers have (very) recently dropped support for TLS 1.0 and TLS 1.1.  So they will no longer connect to the NAS.

 


@Luuta_Scooter wrote:

 

I Heard That An Old Version Of A Web Browser, Not Chrome, Might Allow Access. IfThis Is True, Can Anyone Point Me To A Site Where I Can Download It? 

 


Internet Explorer still works, so if you are running windows, see if that is installed on the PC.

 

FireFox 94.0.2 also works.  Follow the instructions to immediately disable automatic updates after you install it.  https://support.mozilla.org/en-US/kb/install-older-version-firefox 

 


@Luuta_Scooter wrote:

Wondered If Netgear Will Provide A Fix Despite The Old Devices Being Out Of Warranty.


They might of course, but I would be surprised if they did.

 

I know of one (non-Netgear) person looking at a patch which would update the TLS verion on the NAS to 1.2. The other option is to patch the NAS to disable https, and only use http.  

 

Though in your case, I suggest the best option is to convert your Ultra 4 to run OS-6 after you regain access.  I do recommend upgrading the Ultra to use 2 GB of RAM (instead of the stock 1 GB) before you convert it.  That is quite inexpensive (USD cost would be about $20).

 

 

 

Message 2 of 8
Luuta_Scooter
Aspirant

Re: cannot access admin page 'Secure Connection Failed'/'unsupported protocol

Thank you. I'll look into that later today and get back to the forum when I've been able to give it a go.
Message 3 of 8
Luuta_Scooter
Aspirant

Re: cannot access admin page 'Secure Connection Failed'/'unsupported protocol

Have Tried Firefox Portable Going Back To Version 80, and Although It's LettingMe Into Admin Page/Shares, ThePage Is Blank (No Shares Found) And That'sTheOnly Tab It's Showing. Looks Like I'm Stuffed.

Message 4 of 8
StephenB
Guru

Re: cannot access admin page 'Secure Connection Failed'/'unsupported protocol


@Luuta_Scooter wrote:

Have Tried Firefox Portable Going Back To Version 80, and Although It's LettingMe Into Admin Page/Shares, ThePage Is Blank (No Shares Found) And That'sTheOnly Tab It's Showing. Looks Like I'm Stuffed.


You don't want to access https://nas-ip-address/shares

 

Entering just https://nas-ip-address will redirect to /shares - so make sure you explicitly enter https://nas-ip-address/admin  

Message 5 of 8
Luuta_Scooter
Aspirant

Re: cannot access admin page 'Secure Connection Failed'/'unsupported protocol

Many thanks. I'll try, when I can recover my pc which I trashed trying to fix the issue, haha.
Message 6 of 8
wptyree
Initiate

Re: cannot access admin page 'Secure Connection Failed'/'unsupported protocol

I have a ReadyNAS purchased in 2013.

Encountered the same issue using Chrome and MS-Edge.

Web browsers are turning off support for TL1.0 and TL1.1

(wonder why? but that's a different question for another time)
Solution: Download and install Firefox/Mozilla v77 (which supposedly is the
last version to support TL1.0/1.1). Am now able to access the admin page.
Would certainly appreciate a work around s/w upgrade from Netgear.
It can't be "that" expensive 😉

Model: RND4000v2|ReadyNAS NV+ v2 Chassis only
Message 7 of 8
StephenB
Guru

Re: cannot access admin page 'Secure Connection Failed'/'unsupported protocol


@wptyree wrote:


Solution: Download and install Firefox/Mozilla v77 (which supposedly is the
last version to support TL1.0/1.1). 


Not sure where you saw that, but FireFox 94.0.2 also still works.  Of course you do need to immediately disable automatic updates after installation.

 

FWIW, Internet Explorer also still works.

 


@wptyree wrote:

Would certainly appreciate a work around s/w upgrade from Netgear.


It would be nice, and I have enquired about that.  Though the last updates were 5 years ago, and Netgear did say at the time that they wouldn't do any more.

 

There are some others also looking at solutions - there are two main options

  • Provide a patch to the libraries to support TLS 1.2 in 4.1.x, 4.2.x, and 5.3.x firmware
  • Provide a patch to disable HTTPS in the NAS Apache Configuration.

 

Message 8 of 8
Top Contributors
Discussion stats
  • 7 replies
  • 6291 views
  • 4 kudos
  • 3 in conversation
Announcements