Reply

Re: ftp refusing connections

stgeorge
Guide

ftp refusing connections

Hey all-

 

I'm curious what the most typical reason is for the standard ftp server loaded on these nas devices to 'refuse connections' ?

 

Here's the messaging that I'm getting via a filezilla client when trying to connect:

 

Status: TLS connection established.

Status: Logged in

Status: Retrieving directory listing...

Status: Server sent passive reply with unroutable address. Using server address instead.

Command: MLSD

Error: The data connection could not be established: ECONNREFUSED - Connection refused by server

Thanks for your thoughts

Blue beacons unite !
Model: ReadyNAS RNDP6000|ReadyNAS Pro 6 Chassis only
Message 1 of 8
StephenB
Guru

Re: ftp refusing connections

It sounds like you are connecting remotely (over the internet) - is that correct?

 

If so, you normally need to 

  • set a much smaller set of passive ports (perhaps 4 per expected simultaneous connection)
  • forward the passive port range in your router to the NAS

 

Did you do those things?

Message 2 of 8
stgeorge
Guide

Re: ftp refusing connections

Thanks for the help!

 

I am trying to connect over the WAN (internet), yes.  I guess I need a lesson on port forwarding when it comes to ftp. 

 

I do have the default ftp port (21) forwarded to this particular NAS- the one running this ftp server.  I've also set ftp to disabled on the share listing, but have enabled certain users (two for read only and one for read/write).  I've listed a 10 port range in the admin screens of the NAS / ftp server settings, but hadn't yet forwarded that port range in my router- I'll try that now.

Blue beacons unite !
Message 3 of 8
stgeorge
Guide

Re: ftp refusing connections

I'm beginning to think that my issue is more with FileZilla than it is with my network and/or NAS settings.... I've just tried logging in with an android app called ANDFTP and it works fine.... not sure- maybe my FileZilla version is old or for whatever reason not playing nice with the NAS server...?

 

Blue beacons unite !
Message 4 of 8
stgeorge
Guide

Re: ftp refusing connections

So I've forwarded the 10 port range for passive use (from my router to this NAS), and I've gone into a different NAS that I had running on our LAN and killed the ftp server (thinking that it might be causing some confusion to FileZilla), but am still having trouble getting FileZilla to be able to connect properly.... not sure why...

Blue beacons unite !
Message 5 of 8
StephenB
Guru

Re: ftp refusing connections


@stgeorge wrote:

So I've forwarded the 10 port range for passive use (from my router to this NAS), and I've gone into a different NAS that I had running on our LAN and killed the ftp server (thinking that it might be causing some confusion to FileZilla), but am still having trouble getting FileZilla to be able to connect properly.... not sure why...


The original Status: Server sent passive reply with unroutable address. Using server address instead is because you don't have masquerading set on the NAS.  That's a convenient FileZilla feature, as it allows you to use FTP on both your local network and remotely.

 

-Have you checked local FTP access?

-Have you double-checked that port 21 is forwarded to the ReadyNAS and not the other server?

-If you are using FTPS, you need to set FileZilla to "require explicit FTP over TLS".

 

You might also confirm that the passive ports are all open (with canyouseeme.org for instance)

 

 

 

Message 6 of 8
stgeorge
Guide

Re: ftp refusing connections

I actually have had masquerading set on the NAS- that wasn't the issue- the issue was that the passive port range (in the ftp server's settings) was not the same range as that which I had forwarded in our router.  It sounds pretty stupid of me, I'm sure, but the experience that I've found in the past (aka earlier versions of FileZilla) was that I didn't need to forward passive ports at all.  In fact, if I remove the port forwarding instruction in my router for the passive port range, many ftp clients will work fine, and FileZilla used to, but this current version will not.  Once I forwarded the same passive port range as was in the ftp server's settings, FileZilla works beautifully.

Blue beacons unite !
Message 7 of 8
StephenB
Guru

Re: ftp refusing connections


@stgeorge wrote:

 the experience that I've found in the past (aka earlier versions of FileZilla) was that I didn't need to forward passive ports at all. 

It the port isn't forwarded by the router, the connection can't be made.  The client behavior doesn't matter, there is no workaround that it can use.

 

Alternative explanation: Your old FTP server was using upnp to open the passive ports in your router.


@stgeorge wrote:

I actually have had masquerading set on the NAS- that wasn't the issue

The status message in the first post says that either masquerading is mis-configured or it is not enabled.  That might have changed after that post was made. So perhaps double-check that setting.

Message 8 of 8
Top Contributors
Discussion stats
  • 7 replies
  • 3888 views
  • 0 kudos
  • 2 in conversation
Announcements