Reply

Re: "XZ-compressed data is corrupt - system halted" after upgrade to 6.5.2 #27451687

laalves1
Aspirant

"XZ-compressed data is corrupt - system halted" after upgrade to 6.5.2 #27451687

Hi all,

 

Yesterday, I logged into the admin page to do a routine check and noticed that 6.5.2 was available. The system was running 6.5.1. I proceeded to upgrade and it took a loooong time to become available, which eventually it didn't. I went downstairs to check and it was saying its IP was 192.168.70.24 which was very weird since its fixed IP is 192.168.70.100. I decided to reboot it and it got stuck on "Booting...".

 

Then I created a USB recovery drive and tried the reboot from the USB. Nothing, it just gets stuck on "Booting from external USB". The USB drive LED doesn't even flash.

 

As this box has a HDMI plug, I connected it to my TV and the result is that it goes through the boot process, BIOS loading and all until it stops with:

 

"XZ-compressed data is corrupt - system halted"

 

And that's it. What can I do?

Model: RN51600|ReadyNAS 516 6-Bay
Message 1 of 19
laalves1
Aspirant

Re: "XZ-compressed data is corrupt - system halted" after upgrade to 6.5.2

IMG_9854.JPG

Message 2 of 19
YeZ
NETGEAR Expert
NETGEAR Expert

Re: "XZ-compressed data is corrupt - system halted" after upgrade to 6.5.2

It seems like the NAS does not recognize your USB drive, can you find another USB drive that works to do the USB boot recovery? 

Message 3 of 19
laalves1
Aspirant

Re: "XZ-compressed data is corrupt - system halted" after upgrade to 6.5.2

Hi, I tried with 3 different ones already. Formatted them using the utility itself and created the drives.
Message 4 of 19
Skywalker
NETGEAR Expert

Re: "XZ-compressed data is corrupt - system halted" after upgrade to 6.5.2

What's the output from HDMI when you do USB recovery?

Message 5 of 19
laalves1
Aspirant

Re: "XZ-compressed data is corrupt - system halted" after upgrade to 6.5.2

Hi,

 

Exactly the same as without the USB: "XZ-compressed data is corrupt - system halted"

 

I have in the meantime escalated this to a support case (#27451687)

Message 6 of 19
Skywalker
NETGEAR Expert

Re: "XZ-compressed data is corrupt - system halted" after upgrade to 6.5.2 #27451687

It sounds like it's just not booting off USB.  You could try connecting a USB keyboard to the NAS and using the BIOS to select the alternate boot device.

Message 7 of 19
kohdee
NETGEAR Expert

Re: "XZ-compressed data is corrupt - system halted" after upgrade to 6.5.2 #27451687

What is the console output from when you boot normally?

Message 8 of 19
laalves1
Aspirant

Re: "XZ-compressed data is corrupt - system halted" after upgrade to 6.5.2 #27451687

The same.

 

If I try to boot normally, the LCD gets stuck on "Booting...". If I try to boot from a USB, the LCD gets stuck on "Booting from External USB"

 

Regarding external display output, both internal or external boot attempts go through BIOS but get stuck on:

 

"LINUX 4.06 EDD20121002 Copyright (c) 1994-2012

Loading kernel........

Loading initrd.gz......ready.

XZ-compressed data is corrupt

- System halted"

Message 9 of 19
kohdee
NETGEAR Expert

Re: "XZ-compressed data is corrupt - system halted" after upgrade to 6.5.2 #27451687

I wonder if the boot flash became faulty and then upgrading the OS on the chassis caused significant changes and wrote the data strangely. From my experience, I was able to get into a shell and run some simple commands that confirmed that information for me. The keyboard suggestion might help get you to a prompt to really confirm more of the behavior. 

If your device is still within warranty, it might be possible to persue an RMA replacement of the device. 

Message 10 of 19
laalves1
Aspirant

Re: "XZ-compressed data is corrupt - system halted" after upgrade to 6.5.2 #27451687

So I tried the USB keyboard, entered BIOS and went to the Boot override option explicitly selecting the USB drive but the result is the same. Running out of ideas...

Message 11 of 19
Ki_Adi_Mundi
NETGEAR Expert

Re: "XZ-compressed data is corrupt - system halted" after upgrade to 6.5.2 #27451687

what version of usbrecovery tool you are trying ?   and  you selected ReadyNASOS-6.5.2-x86_64.img as the firmware image ? 

Message 12 of 19
laalves1
Aspirant

Re: "XZ-compressed data is corrupt - system halted" after upgrade to 6.5.2 #27451687

The version.txt file says "T7" and yes, I used 6.5.2 as the firmware image. Still stumped and support has not got back to me yet on what to do. 

Message 13 of 19
kohdee
NETGEAR Expert

Re: "XZ-compressed data is corrupt - system halted" after upgrade to 6.5.2 #27451687

I went to authorize an RMA for you but your country of purchase for the NAS and your account's country are not the same, preventing the RMA from being created. 

Message 14 of 19
laalves1
Aspirant

Re: "XZ-compressed data is corrupt - system halted" after upgrade to 6.5.2 #27451687

I don't know what to do about that... I live in Portugal but bought the ReadyNAS from amazon.de. I don't know what the implications of that are, but this is just normal web purchasing habits I guess. BTW, there's no Amazon web storefront in Portugal, so I just buy from the most convenient Amazon (.de, .es, .co.uk, etc) for me.

Message 15 of 19
Ki_Adi_Mundi
NETGEAR Expert

Re: "XZ-compressed data is corrupt - system halted" after upgrade to 6.5.2 #27451687

seems it's a little old ,  better try a newer version.  Let's see how to deliver a newer version for you to try. 

Message 16 of 19
Ki_Adi_Mundi
NETGEAR Expert

Re: "XZ-compressed data is corrupt - system halted" after upgrade to 6.5.2 #27451687

https://ntgr-my.sharepoint.com/personal/mili_netgear_com/_layouts/15/guestaccess.aspx?guestaccesstok...

 

can you try if the link work for you ?  it's T11.   the link will expire in 5 days. 

Message 17 of 19
kohdee
NETGEAR Expert

Re: "XZ-compressed data is corrupt - system halted" after upgrade to 6.5.2 #27451687

I'll update the KB with this tool update tomorrow.

Message 18 of 19
laalves1
Aspirant

Re: "XZ-compressed data is corrupt - system halted" after upgrade to 6.5.2 #27451687

Thank you for this but I'm not at the office and will only be for a brief period on Saturday before going back in the air to a 10 week trip. I have received an RMA to have the unit replaced and have accepted it. I will still try this version of the USB Recovery tool before I prep it for shipment. Thnx for all your efforts!

Message 19 of 19
Top Contributors
Discussion stats
  • 18 replies
  • 13677 views
  • 1 kudo
  • 5 in conversation
Announcements