× NETGEAR will be terminating ReadyCLOUD service by July 1st, 2023. For more details click here.
Orbi WiFi 7 RBE973
Reply

Re: ssh: permission denied (publickey)

davidr1
Luminary

ssh: permission denied (publickey)

Hi,

I tried to ssh into my 314, root@192.168.x.x

I got a message saying, from memory, did I want to import the certificate (yes,no)

Replied yes

But now what happens is:

ssh root@192.168.x.x
root@192.168.x.x: Permission denied (publickey).

I've never come accross this before. Any help, please? (Unsuccessful on google & netgear)

Regards,

david

Model: RN31400|ReadyNAS 300 Series 4- Bay (Diskless)
Message 1 of 6

Accepted Solutions
StephenB
Guru

Re: ssh: permission denied (publickey)

One thing you could try is deleting the known_hosts file in the pc.

 

This is in c:\users\user-name\.ssh (which is a hidden folder).  You'll get the prompt on whether you want to trust the NAS again after you do this.

View solution in original post

Message 5 of 6

All Replies
StephenB
Guru

Re: ssh: permission denied (publickey)

Check that "password authentication" is checked in the SSH settings in system->settings->services.

 


@davidr1 wrote:

Hi,

I tried to ssh into my 314, root@192.168.x.x

I got a message saying, from memory, did I want to import the certificate (yes,no)

 


Was this the first time you used ssh to connect to the NAS on this PC?  There will be a prompt asking asking if you trust the NAS, and showing you some fingerprint information.  Importing the certificate allows you to avoid that prompt in the future.

Message 2 of 6
Sandshark
Sensei

Re: ssh: permission denied (publickey)

When you enabled SSH, did yoiu check the "Enable password authentication" box?

Message 3 of 6
davidr1
Luminary

Re: ssh: permission denied (publickey)

Hi StephenB,

Yes - it is and was.

 

 

Message 4 of 6
StephenB
Guru

Re: ssh: permission denied (publickey)

One thing you could try is deleting the known_hosts file in the pc.

 

This is in c:\users\user-name\.ssh (which is a hidden folder).  You'll get the prompt on whether you want to trust the NAS again after you do this.

Message 5 of 6
davidr1
Luminary

Re: ssh: permission denied (publickey)

That worked - thank you very much.

Message 6 of 6
Top Contributors
Discussion stats
  • 5 replies
  • 2879 views
  • 1 kudo
  • 3 in conversation
Announcements